No Pixel History displayed
I have two machines with Visual Studio 2015. Both have the latest version of NSight (5.2.0.16321) One machine has a GeForce GTX 970, the other a GeForce GTX 660. (The first card is a Maxwell GPU and the second a Kepler GPU) Both machines running windows 10. My application is using Directx 11. I can successfully launch NSight Graphics Debugging and Capture a Frame. Everything looks good when I do that. Selecting an event in the scrubber that is of interest, and going to the API Inspector and selecting OM works fine. In the Render Target and Depth Stencil Views of the Output Merger, I can double click on my render target. This brings up the Resources view and my render target is shown in the Graphical window. Clicking the Pixel History button below my render target brings up the cross hairs and clicking on a pixel brings up the Pixel History window. However there is no pixel history displayed in the Pixel History window. I can click on the Show Event Info icon in Pixel History window's toolbar and it shows the correct event. Despite trying this on both machines, in multiple different events and render targets I never get pixel history. (I get the Pixel History window but no history is displayed) Is there some setting that I need to set or maybe something in my code that would turn on pixel history? Any ideas? Is Pixel History working in version 5.2? Any help or insight appreciated. Thanks, Chip
I have two machines with Visual Studio 2015. Both have the latest version of NSight (5.2.0.16321) One machine has a GeForce GTX 970, the other a GeForce GTX 660. (The first card is a Maxwell GPU and the second a Kepler GPU) Both machines running windows 10. My application is using Directx 11.

I can successfully launch NSight Graphics Debugging and Capture a Frame. Everything looks good when I do that.

Selecting an event in the scrubber that is of interest, and going to the API Inspector and selecting OM works fine. In the Render Target and Depth Stencil Views of the Output Merger, I can double click on my render target. This brings up the Resources view and my render target is shown in the Graphical window. Clicking the Pixel History button below my render target brings up the cross hairs and clicking on a pixel brings up the Pixel History window. However there is no pixel history displayed in the Pixel History window. I can click on the Show Event Info icon in Pixel History window's toolbar and it shows the correct event. Despite trying this on both machines, in multiple different events and render targets I never get pixel history. (I get the Pixel History window but no history is displayed)

Is there some setting that I need to set or maybe something in my code that would turn on pixel history? Any ideas? Is Pixel History working in version 5.2? Any help or insight appreciated.

Thanks,
Chip

#1
Posted 04/09/2017 01:01 AM   
Anybody got any ideas here? Anyone from NVidia monitor these boards at all? Thanks in advance, Chip
Anybody got any ideas here? Anyone from NVidia monitor these boards at all? Thanks in advance, Chip

#2
Posted 04/11/2017 02:19 PM   
Scroll To Top

Add Reply