The PC freezes when using Nsight debugger
I have the PC with two display adapters: 1. Intel HD Graphics 4000 2. NVIDIA GeForce GTX 680 In addition: - Processor Intel Core i/-3770 CPU @ 3.4 GHz - 32 GB RAM - Windows 10 - CUDA 8.0 integrated in the VS 2015 - GeForce Game Ready driver 382.52 - NVIDIA Nsight Visual Studio Edition, Version 5.2, Build 5.2.0.16321 I use the marchingCubes project from the CUDA samples. marchingCubes is built for Debug/x64. The following values I've changed in the Nsight Options for the "Microsoft Display Driver" section: - WDDM TDR Delay = 8 - WDDM TDR enabled = False a) I run the Nsight Monitor as Admin b) In Visual Studio as a Transport I set the Nsight GPU Debugger. c) Nsight shows the established connection d) I run the marchingCubes.exe e) In Visual Studio 2015 I attach to the running marchingCubes process. After one or two seconds [b]the PC freezes[/b]. All I can do is switch off the machine. It should be mentioned that I can debug the CUDA code when I run the "Start CUDA Debugging" from the Nsight menu in Visual Studio. Can someone give an advice on what the right settings are, to be able to debug the CUDA code when one attaches to a process from the Visual Studio?
I have the PC with two display adapters:
1. Intel HD Graphics 4000
2. NVIDIA GeForce GTX 680

In addition:
- Processor Intel Core i/-3770 CPU @ 3.4 GHz
- 32 GB RAM
- Windows 10
- CUDA 8.0 integrated in the VS 2015
- GeForce Game Ready driver 382.52
- NVIDIA Nsight Visual Studio Edition, Version 5.2, Build 5.2.0.16321


I use the marchingCubes project from the CUDA samples. marchingCubes is built for Debug/x64.

The following values I've changed in the Nsight Options for the "Microsoft Display Driver" section:

- WDDM TDR Delay = 8
- WDDM TDR enabled = False

a) I run the Nsight Monitor as Admin
b) In Visual Studio as a Transport I set the Nsight GPU Debugger.
c) Nsight shows the established connection
d) I run the marchingCubes.exe
e) In Visual Studio 2015 I attach to the running marchingCubes process.

After one or two seconds the PC freezes. All I can do is switch off the machine.

It should be mentioned that I can debug the CUDA code when I run the "Start CUDA Debugging" from the Nsight menu in Visual Studio.

Can someone give an advice on what the right settings are, to be able to debug the CUDA code when one attaches to a process from the Visual Studio?

#1
Posted 06/30/2017 10:24 PM   
Hi, TDR is triggered when you are debugging, here are my suggestion. 1. Enabling/Disabling require system reboot and administrator privilege, please make sure that nsight monitor run ad Admi, increase the "WDDM TDR Delay", set "WDDM TDR enabled " to false the reboot you computer. 2. Use software preemption mode, I'm sure your computer env, but 5.2 seems doesn't work well with the hybrid env, intel+nvidia gpu, you can force it to use software preemption mode then TDR will never be triggered, "Nsight monitor options -> CUDA" set all software preemption related entries to True. Also I suggest to use the latest 5.3
Hi,

TDR is triggered when you are debugging, here are my suggestion.

1. Enabling/Disabling require system reboot and administrator privilege, please make sure that nsight monitor run ad Admi, increase the "WDDM TDR Delay", set "WDDM TDR enabled " to false the reboot you computer.
2. Use software preemption mode, I'm sure your computer env, but 5.2 seems doesn't work well with the hybrid env, intel+nvidia gpu, you can force it to use software preemption mode then TDR will never be triggered, "Nsight monitor options -> CUDA" set all software preemption related entries to True.

Also I suggest to use the latest 5.3

#2
Posted 07/03/2017 06:15 AM   
Hi, done as suggested in your points 1. and 2. and I've updated the Nsight to 5.3 but nothing changed.
Hi,

done as suggested in your points 1. and 2. and I've updated the Nsight to 5.3 but nothing changed.

#3
Posted 07/04/2017 03:27 PM   
Do you use a desktop PC or laptop, if you use a PC, I suggest you to disable the intel gpu in bios, I'm not sure if nsight works well on intel + nvidia gpu.
Do you use a desktop PC or laptop, if you use a PC, I suggest you to disable the intel gpu in bios, I'm not sure if nsight works well on intel + nvidia gpu.

#4
Posted 07/05/2017 03:53 AM   
Scroll To Top

Add Reply