Nsight 5.3, Visual Studio 2017, working directory
Hi, when Nsight 5.3 is installed it seems to mess around with the working directory of my solutions. I have some custom dlls in my working directory. Whenever I debug my application with Nsight installed those dlls cannot be found anymore. This happens with both, the nsight graphics debugger and the local windows debugger (which should have nothing to do with nsight, right?). I checked all the projects properties twice and recompiled everything completely. As soon as I uninstall Nsight it works again. Edit: It seems like Nsight ignores the working directory completely (also outside visual studio when running the app from a shortcut with a custom working dir). A workaround is to set the VS output directory to the same value as the working directory. Would be nice if that can be fixed.
Hi,

when Nsight 5.3 is installed it seems to mess around with the working directory of my solutions. I have some custom dlls in my working directory. Whenever I debug my application with Nsight installed those dlls cannot be found anymore. This happens with both, the nsight graphics debugger and the local windows debugger (which should have nothing to do with nsight, right?). I checked all the projects properties twice and recompiled everything completely. As soon as I uninstall Nsight it works again.

Edit: It seems like Nsight ignores the working directory completely (also outside visual studio when running the app from a shortcut with a custom working dir). A workaround is to set the VS output directory to the same value as the working directory. Would be nice if that can be fixed.

#1
Posted 07/04/2017 04:30 PM   
I have the same problem using VS 2015. Reinstalled it 3 times to no avail.
I have the same problem using VS 2015. Reinstalled it 3 times to no avail.

#2
Posted 07/05/2017 03:23 PM   
Hi nico3000, Thanks for your feedback about Nsight problem, please provide more information for investigating the problem: - Did the working directory in NVIDIA Nsight User Settings contain the dlls? If not, please open NVIDIA Nsight User Settings, set the working directory to contain the dlls. Please refer to the link: http://docs.nvidia.com/nsight-visual-studio-edition/5.3/Nsight_Visual_Studio_Edition_User_Guide.htm#Host_Basics.htm#kanchor92 - If the problem isn't solved yet, can we have your samples to repro the issue please? Regards, Letitia
Hi nico3000,

Thanks for your feedback about Nsight problem, please provide more information for investigating the problem:
- Did the working directory in NVIDIA Nsight User Settings contain the dlls? If not, please open NVIDIA Nsight User Settings, set the working directory to contain the dlls.
Please refer to the link: http://docs.nvidia.com/nsight-visual-studio-edition/5.3/Nsight_Visual_Studio_Edition_User_Guide.htm#Host_Basics.htm#kanchor92
- If the problem isn't solved yet, can we have your samples to repro the issue please?

Regards,
Letitia

#3
Posted 07/12/2017 03:47 AM   
Scroll To Top

Add Reply