Nsight frame profiler(no hardware signals found for API/GPU combination)
I am using Nsight Visual Studio Edition 5.3, and as I was using Graphics Debugging, I tried to [b]Profile Frame[/b], it returned this result: "No hardware signals found for API/GPU combination", does anyone know why this happened? I am a newbie on Nsight and I found that in the user guide it can be 2 reasons: [.]You are not running NVIDIA Nsight as an administrator. [/.] [.]You are running NVIDIA Nsight on a non-MSHybrid laptop. [/.] but I did run the NSight as an administrator, and my laptop should be a MSHybrid laptop. There was another problem, when I tried to add a new signal on Grphics HUD configuration, there was only one options that was "[b]Signal(Raw)[/b]", is it supposed to be another option "Signal(Normalized)", 'cause I'd like to watch the gpu busy state, and there is no choice for that if I used "[b]Signal(Raw)[/b]"
I am using Nsight Visual Studio Edition 5.3, and as I was using Graphics Debugging, I tried to Profile Frame, it returned this result:
"No hardware signals found for API/GPU combination", does anyone know why this happened?
I am a newbie on Nsight and I found that in the user guide it can be 2 reasons:
  • You are not running NVIDIA Nsight as an administrator.
  • You are running NVIDIA Nsight on a non-MSHybrid laptop.

  • but I did run the NSight as an administrator, and my laptop should be a MSHybrid laptop.


    There was another problem, when I tried to add a new signal on Grphics HUD configuration, there was only one options that was "Signal(Raw)", is it supposed to be another option "Signal(Normalized)", 'cause I'd like to watch the gpu busy state, and there is no choice for that if I used "Signal(Raw)"

    #1
    Posted 07/17/2017 08:44 AM   
    Hi JiaV, Please open NVIDIA Control Panel, click 3D settings->Manage 3D settings, activate the global settings page,in the drop-down list of "Preferred graphics processor", there should be "High-performance NVIDIA processor" and "Integrated graphics" options if it's a MSHybrid laptop.Choose "High-performance NVIDIA processor" in the drop-down list,and try it again. If the issue still existed, can you provide more information please? - Laptop version, that we can check if it is a MSHybrid machine. - Can we have your sample please? then we can identify the issue quickly. Regards, Letitia
    Hi JiaV,

    Please open NVIDIA Control Panel, click 3D settings->Manage 3D settings, activate the global settings page,in the drop-down list of "Preferred graphics processor", there should be "High-performance NVIDIA processor" and "Integrated graphics" options if it's a MSHybrid laptop.Choose "High-performance NVIDIA processor" in the drop-down list,and try it again.

    If the issue still existed, can you provide more information please?
    - Laptop version, that we can check if it is a MSHybrid machine.
    - Can we have your sample please? then we can identify the issue quickly.


    Regards,
    Letitia

    #2
    Posted 07/18/2017 05:39 AM   
    I've choose "High-performance NVIDIA processor", the problem still existed. - Alienware 15 R2 Signature Edition - https://drive.google.com/file/d/0B1GM9QFwlqLMZGNnWk1OLTRseUE/view?usp=sharing the link is a sample I use. Thanks, JiaV
    I've choose "High-performance NVIDIA processor", the problem still existed.

    - Alienware 15 R2 Signature Edition
    - https://drive.google.com/file/d/0B1GM9QFwlqLMZGNnWk1OLTRseUE/view?usp=sharing the link is a sample I use.


    Thanks,
    JiaV

    #3
    Posted 07/18/2017 06:27 AM   
    Hi JiaV, I've checked the sample on a hybrid machine with an internal build, the profiler view showed valid data. Please wait for the release build and check it again. Regards, Letitia
    Hi JiaV,

    I've checked the sample on a hybrid machine with an internal build, the profiler view showed valid data.
    Please wait for the release build and check it again.

    Regards,
    Letitia

    #4
    Posted 07/27/2017 09:17 AM   
    Scroll To Top

    Add Reply