"Serialize capture" fails if you dont have the NVIDIA Nsight/Captures folder
With and obscure message "could not write to capture folder" Creating the folder solves the problem. -It would be helpful if the error message told you what folder it failed to write to -And if it was able to create it itself.
With and obscure message "could not write to capture folder"

Creating the folder solves the problem.

-It would be helpful if the error message told you what folder it failed to write to
-And if it was able to create it itself.

#1
Posted 10/10/2017 11:32 AM   
Hi jonasm, Thanks for your feedback. If the folder "NVIDIA Nsight/Captures" doesn't exist, the folder will be created automatically when you do serialization. Regards, Letitia
Hi jonasm,

Thanks for your feedback.
If the folder "NVIDIA Nsight/Captures" doesn't exist, the folder will be created automatically when you do serialization.

Regards,
Letitia

#2
Posted 10/24/2017 06:21 AM   
The same thing happened for me. Running Visual Studio Pro 2015 (v. 14.0.25431.01 Update 3) on Windows 10 (Version 10.0.16299.125) with Nsight v5.4 Build number 5.4.0.17240. It did not create the folder automatically.
The same thing happened for me. Running Visual Studio Pro 2015 (v. 14.0.25431.01 Update 3) on Windows 10 (Version 10.0.16299.125) with Nsight v5.4 Build number 5.4.0.17240.

It did not create the folder automatically.

#3
Posted 12/14/2017 08:16 PM   
Hi jerm007, Sorry for delay. Did you mean that the serialization project isn't saved in the path {Documents}\NVIDIA Nsight\Captures after done serialization? Regards, Letitia
Hi jerm007,

Sorry for delay.
Did you mean that the serialization project isn't saved in the path {Documents}\NVIDIA Nsight\Captures after done serialization?

Regards,
Letitia

#4
Posted 12/25/2017 03:36 AM   
I reproduced this just now, it failed until I manually created the path you specified. There was no {Documents}\NVIDIA Nsight directory, but once I created it, and the Captures directory, then it worked.
I reproduced this just now, it failed until I manually created the path you specified. There was no {Documents}\NVIDIA Nsight directory, but once I created it, and the Captures directory, then it worked.

#5
Posted 12/31/2017 03:59 AM   
Hi davidvhk7w, I'm sorry for the problem you met. The issue is very weird, for I never encountered the problem. Can you try it again as the following steps please? - login the machine as administrator - uninstall Nsight - Delete the NVIDIA Nsight directory under the path {Documents} - Install Nsight again - launch Visual Studio as administrator - launch your sample with nsight, then click menu Nsight-> Start Graphics Debugging, pause&capture the frame, then click the menu Nsight-> Serialize Capture to C/C++ If the issue still happened, please provide the following information: - OS, GPU, Nsight info - the screenshot of NVIDIA Nsight Options, including General and Graphics. Just click menu Nsight-> Options - the screenshot of NVIDIA Nsight User Settings, including Launch,Synchronization and Shader Compilation. Just right-click the project in Solution Explorer, then choose "Nsight User Properties". Thanks, Letitia
Hi davidvhk7w,

I'm sorry for the problem you met. The issue is very weird, for I never encountered the problem.
Can you try it again as the following steps please?
- login the machine as administrator
- uninstall Nsight
- Delete the NVIDIA Nsight directory under the path {Documents}
- Install Nsight again
- launch Visual Studio as administrator
- launch your sample with nsight, then click menu Nsight-> Start Graphics Debugging, pause&capture the frame, then click the menu Nsight-> Serialize Capture to C/C++

If the issue still happened, please provide the following information:
- OS, GPU, Nsight info
- the screenshot of NVIDIA Nsight Options, including General and Graphics. Just click menu Nsight-> Options
- the screenshot of NVIDIA Nsight User Settings, including Launch,Synchronization and Shader Compilation. Just right-click the project in Solution Explorer, then choose "Nsight User Properties".

Thanks,
Letitia

#6
Posted 01/02/2018 06:25 AM   
Scroll To Top

Add Reply