No console after 387.22 also with 387.34
To not repeat myself https://bbs.archlinux.org/viewtopic.php?pid=1751141 This thread will be a copy/paste of that thread. Alright, I was in another country from 10.08.2017-21.11.2017. When I returned I did a pacman -Syu and rebooted. After reboot I couldn't get past "loading initial ramdisk...". So it seemed. What actually happened and happens is I can't get a console and it can't get past that. I switched to text mode grub and it boots however I still don't get a console And when I reboot the system it's the same, when the system shuts down I get that black screen or alternating backlights or so it seems as if it turns on and off. The motherboard is a UEFI board Gigabyte GA-X170-EXTREME-ECC and there's a nvidia gtx 1080 connected via DP to a 4k monitor Intel(R) Xeon(R) CPU E3-1275 v5 @ 3.60GHz, for what it's worth noveuau is blacklisted sddm or gdm - there's no difference I get to gdm or pass sddm's autologin into cinnamon or gnome3 if you like but only if grub text mode is enabled else I'm not getting anywhere past the loading initrd message /etc/default/grub [code] GRUB_DEFAULT=0 GRUB_TIMEOUT=5 GRUB_DISTRIBUTOR="Arch" GRUB_CMDLINE_LINUX_DEFAULT="transparent_hugepage=never" GRUB_CMDLINE_LINUX="" # Preload both GPT and MBR modules so that they are not missed GRUB_PRELOAD_MODULES="part_gpt part_msdos" # Uncomment to use basic console GRUB_TERMINAL_INPUT=console # Uncomment to disable graphical terminal GRUB_TERMINAL_OUTPUT=console # The resolution used on graphical terminal # note that you can use only modes which your graphic card supports via VBE # you can see them in real GRUB with the command `vbeinfo' GRUB_GFXMODE=3140x2160,1920x1080,1280x1024,auto # Uncomment to allow the kernel use the same resolution used by grub GRUB_GFXPAYLOAD_LINUX=text # Uncomment to disable generation of recovery mode menu entries GRUB_DISABLE_RECOVERY=true [/code] /etc/mkinitcpio.conf [code] MODULES="nvidia nvidia_modeset nvidia_uvm nvidia_drm" BINARIES="" FILES="" HOOKS="base udev autodetect keyboard modconf block filesystems fsck" [/code] I also had MODULES="" dmesg, you'll notice the kernel segfaults, which is not happening with the lts kernel -snip dmesg for readability-
To not repeat myself
https://bbs.archlinux.org/viewtopic.php?pid=1751141

This thread will be a copy/paste of that thread.

Alright,
I was in another country from 10.08.2017-21.11.2017.
When I returned I did a pacman -Syu
and rebooted.

After reboot I couldn't get past "loading initial ramdisk...".
So it seemed.
What actually happened and happens is I can't get a console and it can't get past that.

I switched to text mode grub and it boots however I still don't get a console
And when I reboot the system it's the same, when the system shuts down I get that black screen or alternating backlights or so it seems as if it turns on and off.

The motherboard is a UEFI board Gigabyte GA-X170-EXTREME-ECC
and there's a nvidia gtx 1080
connected via DP to a 4k monitor
Intel(R) Xeon(R) CPU E3-1275 v5 @ 3.60GHz, for what it's worth

noveuau is blacklisted

sddm or gdm - there's no difference

I get to gdm or pass sddm's autologin into cinnamon or gnome3 if you like
but only if grub text mode is enabled
else I'm not getting anywhere past the loading initrd message

/etc/default/grub
GRUB_DEFAULT=0
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR="Arch"
GRUB_CMDLINE_LINUX_DEFAULT="transparent_hugepage=never"
GRUB_CMDLINE_LINUX=""

# Preload both GPT and MBR modules so that they are not missed
GRUB_PRELOAD_MODULES="part_gpt part_msdos"

# Uncomment to use basic console
GRUB_TERMINAL_INPUT=console

# Uncomment to disable graphical terminal
GRUB_TERMINAL_OUTPUT=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
GRUB_GFXMODE=3140x2160,1920x1080,1280x1024,auto

# Uncomment to allow the kernel use the same resolution used by grub
GRUB_GFXPAYLOAD_LINUX=text

# Uncomment to disable generation of recovery mode menu entries
GRUB_DISABLE_RECOVERY=true


/etc/mkinitcpio.conf
MODULES="nvidia nvidia_modeset nvidia_uvm nvidia_drm"
BINARIES=""
FILES=""
HOOKS="base udev autodetect keyboard modconf block filesystems fsck"

I also had MODULES=""

dmesg, you'll notice the kernel segfaults, which is not happening with the lts kernel

-snip dmesg for readability-

#1
Posted 11/25/2017 02:01 PM   
bug report attachment post.. I think this forum is weird
bug report attachment post.. I think
this forum is weird

#2
Posted 11/25/2017 02:24 PM   
You don't get a console at all after the initial ramdisk is loaded? That doesn't sound like a driver problem -- does it work if you uninstall the driver entirely? Since you're booting in EFI mode, there should be messages about efifb initializing in the dmesg output. It's not in the logs you pasted, but it's in nvidia-bug-report-log.gz: [code] [ 0.457391] efifb: probing for efifb [ 0.457409] efifb: framebuffer at 0xe0000000, mapped to 0xffffc90005c00000, using 8640k, total 8640k [ 0.457410] efifb: mode is 1920x1080x32, linelength=8192, pages=1 [ 0.457411] efifb: scrolling: redraw [ 0.457412] efifb: Truecolor: size=8:8:8:8, shift=24:16:8:0 [ 0.461308] Console: switching to colour frame buffer device 240x67 [ 0.465469] fb0: EFI VGA frame buffer device [/code] It looks like you booted the kernel with the "quiet" parameter. If you remove that, do you get a working console?
You don't get a console at all after the initial ramdisk is loaded? That doesn't sound like a driver problem -- does it work if you uninstall the driver entirely?

Since you're booting in EFI mode, there should be messages about efifb initializing in the dmesg output. It's not in the logs you pasted, but it's in nvidia-bug-report-log.gz:
[    0.457391] efifb: probing for efifb
[ 0.457409] efifb: framebuffer at 0xe0000000, mapped to 0xffffc90005c00000, using 8640k, total 8640k
[ 0.457410] efifb: mode is 1920x1080x32, linelength=8192, pages=1
[ 0.457411] efifb: scrolling: redraw
[ 0.457412] efifb: Truecolor: size=8:8:8:8, shift=24:16:8:0
[ 0.461308] Console: switching to colour frame buffer device 240x67
[ 0.465469] fb0: EFI VGA frame buffer device

It looks like you booted the kernel with the "quiet" parameter. If you remove that, do you get a working console?

Aaron Plattner
NVIDIA Linux Graphics

#3
Posted 11/25/2017 05:25 PM   
Please try /etc/default/grub [code] # Uncomment to use basic console GRUB_TERMINAL_INPUT=console # Uncomment to disable graphical terminal -GRUB_TERMINAL_OUTPUT=console +#GRUB_TERMINAL_OUTPUT=console # The resolution used on graphical terminal # note that you can use only modes which your graphic card supports via VBE # you can see them in real GRUB with the command `vbeinfo' -GRUB_GFXMODE=3140x2160,1920x1080,1280x1024,auto +GRUB_GFXMODE=auto # Uncomment to allow the kernel use the same resolution used by grub -GRUB_GFXPAYLOAD_LINUX=text +GRUB_GFXPAYLOAD_LINUX=keep # Uncomment to disable generation of recovery mode menu entries GRUB_DISABLE_RECOVERY=true [/code]
Please try

/etc/default/grub
# Uncomment to use basic console
GRUB_TERMINAL_INPUT=console

# Uncomment to disable graphical terminal
-GRUB_TERMINAL_OUTPUT=console
+#GRUB_TERMINAL_OUTPUT=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
-GRUB_GFXMODE=3140x2160,1920x1080,1280x1024,auto
+GRUB_GFXMODE=auto

# Uncomment to allow the kernel use the same resolution used by grub
-GRUB_GFXPAYLOAD_LINUX=text
+GRUB_GFXPAYLOAD_LINUX=keep

# Uncomment to disable generation of recovery mode menu entries
GRUB_DISABLE_RECOVERY=true

#4
Posted 11/25/2017 10:00 PM   
blablo, when I do that I don't get past the initrd. (see also archlinux forum thread, it's more detailed) believe me when I write that I tried all kinds of combinations. GRUB_TERMINAL_OUTPUT=gfxterm GRUB_TERMINAL_OUTPUT=console I'll try commenting GRUB_TERMINAL_OUTPUT now, but I doubt that it will be much difference. aplattner, I'm not booting with quiet on. [code] menuentry 'Arch Linux' --class arch --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-simple-932147a3-5af2-48e0-a5fb-f94d686f2b16' { set gfxpayload=text insmod gzio insmod part_gpt insmod ext2 set root='hd1,gpt2' if [ x$feature_platform_search_hint = xy ]; then search --no-floppy --fs-uuid --set=root --hint-bios=hd1,gpt2 --hint-efi=hd1,gpt2 --hint-baremetal=ahci1,gpt2 932147a3-5af2-48e0-a5fb-f94d686f2b16 else search --no-floppy --fs-uuid --set=root 932147a3-5af2-48e0-a5fb-f94d686f2b16 fi echo 'Loading Linux linux ...' linux /boot/vmlinuz-linux root=UUID=932147a3-5af2-48e0-a5fb-f94d686f2b16 rw transparent_hugepage=never nvidia-drm.modeset=1 systemd.unit=default.target echo 'Loading initial ramdisk ...' initrd /boot/intel-ucode.img /boot/initramfs-linux.img } [/code] Idk why it's in the bug report logs but not in the dmesg [code] dev ~ # dmesg | grep efifb dev ~ # [/code] were you browsing a different log? according to arch wiki efifb is compiled into the kernel. [code] # zgrep EFI /proc/config.gz CONFIG_EFI_PARTITION=y CONFIG_EFI=y CONFIG_EFI_STUB=y CONFIG_EFI_MIXED=y CONFIG_FB_EFI=y CONFIG_XEN_EFI=y CONFIG_DMI_SCAN_MACHINE_NON_EFI_FALLBACK=y # EFI (Extensible Firmware Interface) Support # CONFIG_EFI_VARS is not set CONFIG_EFI_ESRT=y CONFIG_EFI_RUNTIME_MAP=y # CONFIG_EFI_FAKE_MEMMAP is not set CONFIG_EFI_RUNTIME_WRAPPERS=y CONFIG_EFI_CAPSULE_LOADER=m # CONFIG_EFI_TEST is not set CONFIG_UEFI_CPER=y CONFIG_EFI_DEV_PATH_PARSER=y CONFIG_CACHEFILES=m # CONFIG_CACHEFILES_DEBUG is not set # CONFIG_CACHEFILES_HISTOGRAM is not set CONFIG_EFIVAR_FS=y CONFIG_EARLY_PRINTK_EFI=y # CONFIG_EFI_PGT_DUMP is not set [/code] and it is No I have not tried disabling and uninstalling the driver entirely, yet. I have tried booting without the nvidia modules in the initrd with the same result. I'm pretty sure that I could absolutely boot with noveau, but I'm not keen on not having adaptive power switching and no glx. I don't know what booting without the driver is supposed to achive, since I'm interested in using the driver and the problem occurs when the driver is used. If it was a kernel issue then the lts 4.9 kernel would be able to boot and have a console of what ever kind. But it doesn't. (yes kernel-lts and nvidia-lts (aka 387.22 for 4.9 kernel) installed)
blablo,
when I do that I don't get past the initrd. (see also archlinux forum thread, it's more detailed)
believe me when I write that I tried all kinds of combinations.
GRUB_TERMINAL_OUTPUT=gfxterm
GRUB_TERMINAL_OUTPUT=console
I'll try commenting GRUB_TERMINAL_OUTPUT now, but I doubt that it will be much difference.

aplattner,
I'm not booting with quiet on.
menuentry 'Arch Linux' --class arch --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-simple-932147a3-5af2-48e0-a5fb-f94d686f2b16' {
set gfxpayload=text
insmod gzio
insmod part_gpt
insmod ext2
set root='hd1,gpt2'
if [ x$feature_platform_search_hint = xy ]; then
search --no-floppy --fs-uuid --set=root --hint-bios=hd1,gpt2 --hint-efi=hd1,gpt2 --hint-baremetal=ahci1,gpt2 932147a3-5af2-48e0-a5fb-f94d686f2b16
else
search --no-floppy --fs-uuid --set=root 932147a3-5af2-48e0-a5fb-f94d686f2b16
fi
echo 'Loading Linux linux ...'
linux /boot/vmlinuz-linux root=UUID=932147a3-5af2-48e0-a5fb-f94d686f2b16 rw transparent_hugepage=never nvidia-drm.modeset=1 systemd.unit=default.target
echo 'Loading initial ramdisk ...'
initrd /boot/intel-ucode.img /boot/initramfs-linux.img
}


Idk why it's in the bug report logs but not in the dmesg
dev ~ # dmesg | grep efifb
dev ~ #

were you browsing a different log?

according to arch wiki efifb is compiled into the kernel.
# zgrep EFI /proc/config.gz 
CONFIG_EFI_PARTITION=y
CONFIG_EFI=y
CONFIG_EFI_STUB=y
CONFIG_EFI_MIXED=y
CONFIG_FB_EFI=y
CONFIG_XEN_EFI=y
CONFIG_DMI_SCAN_MACHINE_NON_EFI_FALLBACK=y
# EFI (Extensible Firmware Interface) Support
# CONFIG_EFI_VARS is not set
CONFIG_EFI_ESRT=y
CONFIG_EFI_RUNTIME_MAP=y
# CONFIG_EFI_FAKE_MEMMAP is not set
CONFIG_EFI_RUNTIME_WRAPPERS=y
CONFIG_EFI_CAPSULE_LOADER=m
# CONFIG_EFI_TEST is not set
CONFIG_UEFI_CPER=y
CONFIG_EFI_DEV_PATH_PARSER=y
CONFIG_CACHEFILES=m
# CONFIG_CACHEFILES_DEBUG is not set
# CONFIG_CACHEFILES_HISTOGRAM is not set
CONFIG_EFIVAR_FS=y
CONFIG_EARLY_PRINTK_EFI=y
# CONFIG_EFI_PGT_DUMP is not set

and it is

No I have not tried disabling and uninstalling the driver entirely, yet.
I have tried booting without the nvidia modules in the initrd with the same result.

I'm pretty sure that I could absolutely boot with noveau, but I'm not keen on not having adaptive power switching and no glx.
I don't know what booting without the driver is supposed to achive, since I'm interested in using the driver and the problem occurs when the driver is used.
If it was a kernel issue then the lts 4.9 kernel would be able to boot and have a console of what ever kind.
But it doesn't. (yes kernel-lts and nvidia-lts (aka 387.22 for 4.9 kernel) installed)

#5
Posted 11/26/2017 06:58 AM   
I did now, again, try booting in gfxmode, with what blablo suggested and I didn't get past the loading initrd screen. [quote] - I boot with gfxmode on in grub I can't get anywhere past the "Loading Initial Ramdisk..." - I boot with text mode on in grub I get the backlight on/off thing and then x starts and I get a cinnamon or w/e session. [/quote] the "backlight on/off thing" looks like a corrupted display.. blue dots on the top left side. please see photos in the archlinux forum's thread. https://lh3.googleusercontent.com/ExFeIriE2S2ZJRq9hp4Imr1FgZqBnM3HEqrR6Y-ec1UBpX-3VnNua73q_9poudiawmYfRkBR20Hdsw https://lh3.googleusercontent.com/oNY3uhFGkid6GnLeL8deK-lm-X43FrB467uR6YWbqjAICftOLTjSdWwDvMjPP7yCQAA1i6c1xXDT2w It's the same blue dots. Also, aplattner: I don't know where you see quiet boot or efifb in the log file. You have the wrong log file.
I did now, again, try booting in gfxmode, with what blablo suggested and I didn't get past the loading initrd screen.


- I boot with gfxmode on in grub
I can't get anywhere past the "Loading Initial Ramdisk..."

- I boot with text mode on in grub
I get the backlight on/off thing and then x starts and I get a cinnamon or w/e session.


the "backlight on/off thing" looks like a corrupted display.. blue dots on the top left side.
please see photos in the archlinux forum's thread.


https://lh3.googleusercontent.com/ExFeIriE2S2ZJRq9hp4Imr1FgZqBnM3HEqrR6Y-ec1UBpX-3VnNua73q_9poudiawmYfRkBR20Hdsw

https://lh3.googleusercontent.com/oNY3uhFGkid6GnLeL8deK-lm-X43FrB467uR6YWbqjAICftOLTjSdWwDvMjPP7yCQAA1i6c1xXDT2w


It's the same blue dots.

Also, aplattner:
I don't know where you see quiet boot or efifb in the log file. You have the wrong log file.

#6
Posted 11/26/2017 07:14 AM   
What the hell, this is not the log file I've uploaded. This forum software is...bad
What the hell, this is not the log file I've uploaded.
This forum software is...bad

#7
Posted 11/26/2017 07:16 AM   
https://drive.google.com/open?id=1zdj3pIRvyHVK_AN3Boer9LOT4xeijIlW this is my log

#8
Posted 11/26/2017 07:18 AM   
Some more info: 1. uninstalled nvidia package *turned off vt-d* in bios removed the modules from mkinitcpio.conf grub mode remained text booted with noveau I'm getting a vga console but I'm not getting an xorg session (cinnamon) 2. grub mode gfx system locks, no vga console 3. installed nvidia package NOT added nvidia stuff to mkinitcpio.conf MODULES nvidia-drm.modeset=1 remained in /etc/modprobe.d/nvidia grub text mode I'm getting a vga console but unable to get an xorg session 4. added nvidia stuff to mkinitcpio.conf MODULES grub text mode not getting a vga console or any console at all but getting an xorg session however I'm able to ctrl+alt+f2(e.g.) and back to ctrl+alt+f1 without the system crashing things I've noticed: noveau before switching to vga console displays one horizontal stripe of grey/green short blocks (like 1mm grey|1mm green) nvidia before switching to vga console displays the blue dots So now I'm going to try to [code] sudo mv /etc/X11/xorg.conf.d/20-nvidia.conf ./ [/code] and remove the MODULES from mkinitcpio.conf update so what actually happens in 3. is: altough the nvidia package blacklists nouveau in /usr/lib/modprobe.d/nvidia this is completely ignored nouveau is loaded (I noticed because of the grey/green blocks) and nvidia can't load resulting in xorg not running however the current config with nvidia loaded and nouveau blacklisted in /etc/modprobe.d/blacklist_nouveau and [code] MODULES="nvidia nvidia_modeset nvidia_uvm nvidia_drm" [/code] in /etc/mkinitcpio.conf results in more of the same, blue dots and no console but xorg running... goto 10 and the same happens with kernel 4.14.2 and 387.34-6 So what happened between august 10th and november 21st that killed the console?
Some more info:

1.
uninstalled nvidia package
*turned off vt-d* in bios
removed the modules from mkinitcpio.conf
grub mode remained text
booted with noveau
I'm getting a vga console
but I'm not getting an xorg session (cinnamon)

2.
grub mode gfx
system locks, no vga console

3.
installed nvidia package
NOT added nvidia stuff to mkinitcpio.conf MODULES
nvidia-drm.modeset=1 remained in /etc/modprobe.d/nvidia
grub text mode
I'm getting a vga console
but unable to get an xorg session

4.
added nvidia stuff to mkinitcpio.conf MODULES
grub text mode
not getting a vga console or any console at all
but getting an xorg session

however I'm able to ctrl+alt+f2(e.g.) and back to ctrl+alt+f1 without the system crashing

things I've noticed:
noveau before switching to vga console displays one horizontal stripe of grey/green short blocks (like 1mm grey|1mm green)
nvidia before switching to vga console displays the blue dots

So now I'm going to try to
sudo mv /etc/X11/xorg.conf.d/20-nvidia.conf ./

and remove the MODULES from mkinitcpio.conf

update

so what actually happens in 3. is:
altough the nvidia package blacklists nouveau in /usr/lib/modprobe.d/nvidia
this is completely ignored
nouveau is loaded (I noticed because of the grey/green blocks)
and nvidia can't load resulting in xorg not running

however the current config with nvidia loaded and nouveau blacklisted in /etc/modprobe.d/blacklist_nouveau
and
MODULES="nvidia nvidia_modeset nvidia_uvm nvidia_drm"

in /etc/mkinitcpio.conf
results in more of the same, blue dots and no console but xorg running...
goto 10

and the same happens with kernel 4.14.2 and 387.34-6

So what happened between august 10th and november 21st that killed the console?

#9
Posted 11/27/2017 11:49 AM   
When nouveau loads, it will do its own modeset to graphics mode, overriding whatever the console was before (assuming you didn't configure it with the 'nomodeset' option). That's something I've considered for the nvidia driver, but I haven't implemented anything like that yet. For now, the nvidia driver inherits whatever console configuration it got from the kernel. From your new log from Google Drive, it looks like the kernel is not getting an EFI framebuffer configuration from grub, or maybe it's not recognizing what grub is telling it. If it did get a framebuffer configuration, it would have initialized efifb and printed lines like the ones I pasted in #3. Since the nvidia driver doesn't override the console with its own, then you won't get a console if the kernel never set one up in the first place. This seems like an interaction problem between grub and the kernel, and nothing fundamentally wrong with the driver. On a related note, there is no VGA text mode in EFI. To have a console at all, it has to be a framebuffer console of some kind. That's probably why it complains when you try to set it to "text". In the configuration blablo suggested where you say it doesn't get past the initial ramdisk, can you SSH into the system? If not, my next suggestion would be to set up a serial console, if possible, to see why it's getting stuck.
When nouveau loads, it will do its own modeset to graphics mode, overriding whatever the console was before (assuming you didn't configure it with the 'nomodeset' option). That's something I've considered for the nvidia driver, but I haven't implemented anything like that yet. For now, the nvidia driver inherits whatever console configuration it got from the kernel.

From your new log from Google Drive, it looks like the kernel is not getting an EFI framebuffer configuration from grub, or maybe it's not recognizing what grub is telling it. If it did get a framebuffer configuration, it would have initialized efifb and printed lines like the ones I pasted in #3.

Since the nvidia driver doesn't override the console with its own, then you won't get a console if the kernel never set one up in the first place. This seems like an interaction problem between grub and the kernel, and nothing fundamentally wrong with the driver.

On a related note, there is no VGA text mode in EFI. To have a console at all, it has to be a framebuffer console of some kind. That's probably why it complains when you try to set it to "text".

In the configuration blablo suggested where you say it doesn't get past the initial ramdisk, can you SSH into the system? If not, my next suggestion would be to set up a serial console, if possible, to see why it's getting stuck.

Aaron Plattner
NVIDIA Linux Graphics

#10
Posted 11/27/2017 08:36 PM   
I can't ICMP ping because Networkmanager sets the IP. And even if I wait 5 minutes I can't send pings to the configured static IP. This pretend-professional motherboard doesn't have a serial port (hardware), but I can toggle "serial port" in the BIOS (woohoo).
I can't ICMP ping because Networkmanager sets the IP.
And even if I wait 5 minutes I can't send pings to the configured static IP.

This pretend-professional motherboard doesn't have a serial port (hardware), but I can toggle "serial port" in the BIOS (woohoo).

#11
Posted 11/29/2017 10:33 AM   
I seem to be having a similar problem. Recovery mode freezes after "loading initial ramdisk..." indefinitely. I can boot into desktop manager however TTYs don't work and the screen freezes at the point where it's supposed to show the console at startup and it resumes once the desktop manager takes over. TTY screens are blank, however If I login on the TTY blindly and type a command it is executed. These issues do not occur with the nouveau driver I've tried many of the same things as described in OP to no avail. ==================== Ubuntu 17.10 MOBO: ASUS Maximus VIII Hero UEFI Mode GTX 970 with 384.90 driver $ uname -a Linux caleb-whiting 4.13.0-17-generic #20-Ubuntu SMP Mon Nov 6 10:04:08 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux $ hwinfo --gfxcard 22: PCI 100.0: 0300 VGA compatible controller (VGA) [Created at pci.378] Unique ID: VCu0.IuoTaz1A7sA Parent ID: vSkL.uQnIAf5OKS4 SysFS ID: /devices/pci0000:00/0000:00:01.0/0000:01:00.0 SysFS BusID: 0000:01:00.0 Hardware Class: graphics card Model: "nVidia GM204 [GeForce GTX 970]" Vendor: pci 0x10de "nVidia Corporation" Device: pci 0x13c2 "GM204 [GeForce GTX 970]" SubVendor: pci 0x1462 "Micro-Star International Co., Ltd. [MSI]" SubDevice: pci 0x3160 Revision: 0xa1 Driver: "nvidia" Driver Modules: "nvidia" Memory Range: 0xde000000-0xdeffffff (rw,non-prefetchable) Memory Range: 0x2fe0000000-0x2fefffffff (ro,non-prefetchable) Memory Range: 0x2ff0000000-0x2ff1ffffff (ro,non-prefetchable) I/O Ports: 0xe000-0xe07f (rw) Memory Range: 0x000c0000-0x000dffff (rw,non-prefetchable,disabled) IRQ: 139 (436410 events) Module Alias: "pci:v000010DEd000013C2sv00001462sd00003160bc03sc00i00" Driver Info #0: Driver Status: nvidiafb is not active Driver Activation Cmd: "modprobe nvidiafb" Driver Info #1: Driver Status: nouveau is not active Driver Activation Cmd: "modprobe nouveau" Driver Info #2: Driver Status: nvidia_384_drm is not active Driver Activation Cmd: "modprobe nvidia_384_drm" Driver Info #3: Driver Status: nvidia_384 is not active Driver Activation Cmd: "modprobe nvidia_384" Config Status: cfg=new, avail=yes, need=no, active=unknown Attached to: #20 (PCI bridge) Primary display adapter: #22
I seem to be having a similar problem.

Recovery mode freezes after "loading initial ramdisk..." indefinitely.
I can boot into desktop manager however TTYs don't work and the screen freezes at the point where it's supposed to show the console at startup and it resumes once the desktop manager takes over.

TTY screens are blank, however If I login on the TTY blindly and type a command it is executed.

These issues do not occur with the nouveau driver

I've tried many of the same things as described in OP to no avail.

====================
Ubuntu 17.10
MOBO: ASUS Maximus VIII Hero
UEFI Mode
GTX 970 with 384.90 driver

$ uname -a
Linux caleb-whiting 4.13.0-17-generic #20-Ubuntu SMP Mon Nov 6 10:04:08 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

$ hwinfo --gfxcard
22: PCI 100.0: 0300 VGA compatible controller (VGA)
[Created at pci.378]
Unique ID: VCu0.IuoTaz1A7sA
Parent ID: vSkL.uQnIAf5OKS4
SysFS ID: /devices/pci0000:00/0000:00:01.0/0000:01:00.0
SysFS BusID: 0000:01:00.0
Hardware Class: graphics card
Model: "nVidia GM204 [GeForce GTX 970]"
Vendor: pci 0x10de "nVidia Corporation"
Device: pci 0x13c2 "GM204 [GeForce GTX 970]"
SubVendor: pci 0x1462 "Micro-Star International Co., Ltd. [MSI]"
SubDevice: pci 0x3160
Revision: 0xa1
Driver: "nvidia"
Driver Modules: "nvidia"
Memory Range: 0xde000000-0xdeffffff (rw,non-prefetchable)
Memory Range: 0x2fe0000000-0x2fefffffff (ro,non-prefetchable)
Memory Range: 0x2ff0000000-0x2ff1ffffff (ro,non-prefetchable)
I/O Ports: 0xe000-0xe07f (rw)
Memory Range: 0x000c0000-0x000dffff (rw,non-prefetchable,disabled)
IRQ: 139 (436410 events)
Module Alias: "pci:v000010DEd000013C2sv00001462sd00003160bc03sc00i00"
Driver Info #0:
Driver Status: nvidiafb is not active
Driver Activation Cmd: "modprobe nvidiafb"
Driver Info #1:
Driver Status: nouveau is not active
Driver Activation Cmd: "modprobe nouveau"
Driver Info #2:
Driver Status: nvidia_384_drm is not active
Driver Activation Cmd: "modprobe nvidia_384_drm"
Driver Info #3:
Driver Status: nvidia_384 is not active
Driver Activation Cmd: "modprobe nvidia_384"
Config Status: cfg=new, avail=yes, need=no, active=unknown
Attached to: #20 (PCI bridge)

Primary display adapter: #22

#12
Posted 11/29/2017 05:24 PM   
you're also using grub2, I assume?
you're also using grub2, I assume?

#13
Posted 11/30/2017 08:42 AM   
[quote=""]you're also using grub2, I assume?[/quote] That's correct, GRUB is working fine.
said:you're also using grub2, I assume?

That's correct, GRUB is working fine.

#14
Posted 11/30/2017 12:29 PM   
I beg to differ. I got rid of grub2 and am using systemd-boot now. And I'm getting a console, not a high-res one but it's a console. So the problem is with grub2. Version 2.02. Arch's version 2.02-3 And Aaron's info is what lead me to this [quote] On a related note, there is no VGA text mode in EFI. To have a console at all, it has to be a framebuffer console of some kind. That's probably why it complains when you try to set it to "text". [/quote] since the fb is corrupt and grub delivers this fb it has to be grub and it is.
I beg to differ.

I got rid of grub2 and am using systemd-boot now.
And I'm getting a console, not a high-res one but it's a console.

So the problem is with grub2. Version 2.02. Arch's version 2.02-3

And Aaron's info is what lead me to this

On a related note, there is no VGA text mode in EFI. To have a console at all, it has to be a framebuffer console of some kind. That's probably why it complains when you try to set it to "text".

since the fb is corrupt and grub delivers this fb it has to be grub and it is.

#15
Posted 11/30/2017 03:44 PM   
Scroll To Top

Add Reply