Nsight 5.4: glTexImage3D - Unsupported operation
After starting graphics debugging of the application, the Debugger fails with "Unsupported operation encountered" message. The only entry in the compatibility log is glTexImage3D. This function is definitely in 4.5 core profile. So, according to the documentation, it should be supported, right? The environment: Windows 7, 64 bit; MSVC 2015; K3100 card; all recent drivers installed. Any explanation or suggestion would be greatly appreciated.
After starting graphics debugging of the application, the Debugger fails with "Unsupported operation encountered" message. The only entry in the compatibility log is glTexImage3D. This function is definitely in 4.5 core profile. So, according to the documentation, it should be supported, right?

The environment: Windows 7, 64 bit; MSVC 2015; K3100 card; all recent drivers installed.

Any explanation or suggestion would be greatly appreciated.

#1
Posted 11/28/2017 04:05 AM   
Hi vvinycity, I'm sorry for the problem you met. Can you provide more information please? - Do you mean the function "glTexImage3D", since you wrote "glTextImage3D"? - Can we have your sample please? then we can identify the issue quickly. Thanks, Letitia
Hi vvinycity,

I'm sorry for the problem you met. Can you provide more information please?
- Do you mean the function "glTexImage3D", since you wrote "glTextImage3D"?
- Can we have your sample please? then we can identify the issue quickly.

Thanks,
Letitia

#2
Posted 11/29/2017 02:50 AM   
Hi Letitia, Thank you for your reply. Yes, it was a typo. After all, with glTextImage3d the code would not even compile. About my code sample: I tested several different 3D-rendering projects, some use OpenGL from QT, some call OpenGL functions directly. And they all have the same issue with unsupported glTexImage3D. So, it seems to me that the problem has nothing to do with our code. After all, it is always the same call to OpenGL32.dll. I am sure, NVIDIA developers should have a very sophisticated environment to test NSIGHT with all OpenGL functions, so why do you need my code?
Hi Letitia,

Thank you for your reply. Yes, it was a typo. After all, with glTextImage3d the code would not even compile.

About my code sample: I tested several different 3D-rendering projects, some use OpenGL from QT, some call OpenGL functions directly. And they all have the same issue with unsupported glTexImage3D. So, it seems to me that the problem has nothing to do with our code. After all, it is always the same call to OpenGL32.dll.

I am sure, NVIDIA developers should have a very sophisticated environment to test NSIGHT with all OpenGL functions, so why do you need my code?

#3
Posted 11/30/2017 03:47 AM   
Hi vvinycity, I tested an OpenGL sample with an internal Nsight build, it worked fine with nsight, no unsupported message about glTexImage3D. OS: WIN7 64bit Visual Studio: VS2015 GPU: GTX 670(which is also GK104) driver: 388.30 Sample: gl-320-texture-3d which used the function glTexImage3D, link is https://github.com/g-truc/ogl-samples. Can you try the sample above please? If the issue still happened, please wait for the release build and then test your sample again. Thanks, Letitia
Hi vvinycity,

I tested an OpenGL sample with an internal Nsight build, it worked fine with nsight, no unsupported message about glTexImage3D.

OS: WIN7 64bit
Visual Studio: VS2015
GPU: GTX 670(which is also GK104)
driver: 388.30
Sample: gl-320-texture-3d which used the function glTexImage3D, link is https://github.com/g-truc/ogl-samples.


Can you try the sample above please? If the issue still happened, please wait for the release build and then test your sample again.


Thanks,
Letitia

#4
Posted 11/30/2017 07:28 AM   
Hello Letitia, Thank you very much for the sample. I will test it today ASAP.
Hello Letitia,

Thank you very much for the sample. I will test it today ASAP.

#5
Posted 11/30/2017 12:53 PM   
So, the function works from the test in both Debug and Release modes. But I have no clue why, or how to change our code to make it work. Actually, it is not exactly our code, it is QT. However, all OpenGL functions in QT should be used exactly the same way, so why only this one has an issue is a mystery. I will leave the comment here as soon as I will figure it out. By the way, Nsight is amazing. The ability to debug shaders make the development so much more productive, I don't believe it. Thanks a lot for your help! --vvi
So, the function works from the test in both Debug and Release modes. But I have no clue why, or how to change our code to make it work. Actually, it is not exactly our code, it is QT. However, all OpenGL functions in QT should be used exactly the same way, so why only this one has an issue is a mystery.

I will leave the comment here as soon as I will figure it out.

By the way, Nsight is amazing. The ability to debug shaders make the development so much more productive, I don't believe it.

Thanks a lot for your help!

--vvi

#6
Posted 11/30/2017 10:46 PM   
Scroll To Top

Add Reply