Nsight crashes on application launch Win10 GTX1070
When trying to debug my application, it runs fine running either through the visual studio debugger or without a debugger. However, when I try to launch via Nsight it crashes. Via the logger of my program I've determined the crash is happening on a call to wglChoosePixelFormatARB. The code for opengl initialization can be found here: https://pastebin.com/DKJ1QnSg This code is executing fine on multiple machines but crashes for Nsight. I got this log from the crash: Error,12/14/2017 19:27:32,devenv.exe,'' id: 1,[vsip][connection],"Exception while trying to obtaining device information. Nvda.ObjectModel.Monitor.SystemInfoException: No system information available. 'No system information available' ",,<>c__DisplayClass8.<Execute>b__6 => GraphicsCommandHandler.ExecuteStartGraphicsDebuggingStartupProject => DeviceCommandHandler.ExecuteStartDebuggingStartupProject => DeviceCommandHandler.ExecuteStartDebuggingCore => DebugProcessLauncher.Launch => NLogLogger.Log => NLogLogger.LogCore Error,12/14/2017 19:27:32,devenv.exe,'' id: 1,[vsip][connection]," at Ark.AsyncResultValue`1.EndInvoke() ",,<>c__DisplayClass8.<Execute>b__6 => GraphicsCommandHandler.ExecuteStartGraphicsDebuggingStartupProject => DeviceCommandHandler.ExecuteStartDebuggingStartupProject => DeviceCommandHandler.ExecuteStartDebuggingCore => DebugProcessLauncher.Launch => NLogLogger.Log => NLogLogger.LogCore Error,12/14/2017 19:27:32,devenv.exe,'' id: 1,[vsip][connection]," at Nvda.ObjectModel.Monitor.WindowsSystem.EndGetSystemInfo(IAsyncResult ar) ",,<>c__DisplayClass8.<Execute>b__6 => GraphicsCommandHandler.ExecuteStartGraphicsDebuggingStartupProject => DeviceCommandHandler.ExecuteStartDebuggingStartupProject => DeviceCommandHandler.ExecuteStartDebuggingCore => DebugProcessLauncher.Launch => NLogLogger.Log => NLogLogger.LogCore Error,12/14/2017 19:27:32,devenv.exe,'' id: 1,[vsip][connection]," at Nvda.ObjectModel.Monitor.WindowsSystem.<GetSystemInfo>b__1(IAsyncResult ar) ",,<>c__DisplayClass8.<Execute>b__6 => GraphicsCommandHandler.ExecuteStartGraphicsDebuggingStartupProject => DeviceCommandHandler.ExecuteStartDebuggingStartupProject => DeviceCommandHandler.ExecuteStartDebuggingCore => DebugProcessLauncher.Launch => NLogLogger.Log => NLogLogger.LogCore Error,12/14/2017 19:27:32,devenv.exe,'' id: 1,[vsip][connection]," at Nvda.Device.BlockingMessageDispatcher.ExecuteSynchronousCommand[TResult](Func`1 beginCommand, Func`2 endCommand, Action`2 exceptionHandler, TimeSpan commandTimeout) ",,<>c__DisplayClass8.<Execute>b__6 => GraphicsCommandHandler.ExecuteStartGraphicsDebuggingStartupProject => DeviceCommandHandler.ExecuteStartDebuggingStartupProject => DeviceCommandHandler.ExecuteStartDebuggingCore => DebugProcessLauncher.Launch => NLogLogger.Log => NLogLogger.LogCore Error,12/14/2017 19:27:32,devenv.exe,'' id: 1,[vsip][connection]," at Nvda.ObjectModel.Monitor.WindowsSystem.GetSystemInfo(TimeSpan timeSpan, SystemInfoOptions options) ",,<>c__DisplayClass8.<Execute>b__6 => GraphicsCommandHandler.ExecuteStartGraphicsDebuggingStartupProject => DeviceCommandHandler.ExecuteStartDebuggingStartupProject => DeviceCommandHandler.ExecuteStartDebuggingCore => DebugProcessLauncher.Launch => NLogLogger.Log => NLogLogger.LogCore Error,12/14/2017 19:27:32,devenv.exe,'' id: 1,[vsip][connection]," at Nvda.ObjectModel.Monitor.Tracking.MonitorSessionDeviceInfo(IDeviceHostSession deviceHostSession, String domain) ",,<>c__DisplayClass8.<Execute>b__6 => GraphicsCommandHandler.ExecuteStartGraphicsDebuggingStartupProject => DeviceCommandHandler.ExecuteStartDebuggingStartupProject => DeviceCommandHandler.ExecuteStartDebuggingCore => DebugProcessLauncher.Launch => NLogLogger.Log => NLogLogger.LogCore Error,12/14/2017 19:27:32,devenv.exe,'' id: 1,[vsip][connection]," at Nvda.Vsip.Debugger.DebugProcessLauncher.Launch() ",,<>c__DisplayClass8.<Execute>b__6 => GraphicsCommandHandler.ExecuteStartGraphicsDebuggingStartupProject => DeviceCommandHandler.ExecuteStartDebuggingStartupProject => DeviceCommandHandler.ExecuteStartDebuggingCore => DebugProcessLauncher.Launch => NLogLogger.Log => NLogLogger.LogCore I am running windows 10 with the latest updates. GTX 1070 driver version 388.71. Previously on this same machine when windows 7 was installed I had no issues running the program.
When trying to debug my application, it runs fine running either through the visual studio debugger or without a debugger. However, when I try to launch via Nsight it crashes. Via the logger of my program I've determined the crash is happening on a call to wglChoosePixelFormatARB.

The code for opengl initialization can be found here:

https://pastebin.com/DKJ1QnSg


This code is executing fine on multiple machines but crashes for Nsight.

I got this log from the crash:
Error,12/14/2017 19:27:32,devenv.exe,'' id: 1,[vsip][connection],"Exception while trying to obtaining device information. Nvda.ObjectModel.Monitor.SystemInfoException: No system information available. 'No system information available'
",,<>c__DisplayClass8.<Execute>b__6 => GraphicsCommandHandler.ExecuteStartGraphicsDebuggingStartupProject => DeviceCommandHandler.ExecuteStartDebuggingStartupProject => DeviceCommandHandler.ExecuteStartDebuggingCore => DebugProcessLauncher.Launch => NLogLogger.Log => NLogLogger.LogCore
Error,12/14/2017 19:27:32,devenv.exe,'' id: 1,[vsip][connection]," at Ark.AsyncResultValue`1.EndInvoke()
",,<>c__DisplayClass8.<Execute>b__6 => GraphicsCommandHandler.ExecuteStartGraphicsDebuggingStartupProject => DeviceCommandHandler.ExecuteStartDebuggingStartupProject => DeviceCommandHandler.ExecuteStartDebuggingCore => DebugProcessLauncher.Launch => NLogLogger.Log => NLogLogger.LogCore
Error,12/14/2017 19:27:32,devenv.exe,'' id: 1,[vsip][connection]," at Nvda.ObjectModel.Monitor.WindowsSystem.EndGetSystemInfo(IAsyncResult ar)
",,<>c__DisplayClass8.<Execute>b__6 => GraphicsCommandHandler.ExecuteStartGraphicsDebuggingStartupProject => DeviceCommandHandler.ExecuteStartDebuggingStartupProject => DeviceCommandHandler.ExecuteStartDebuggingCore => DebugProcessLauncher.Launch => NLogLogger.Log => NLogLogger.LogCore
Error,12/14/2017 19:27:32,devenv.exe,'' id: 1,[vsip][connection]," at Nvda.ObjectModel.Monitor.WindowsSystem.<GetSystemInfo>b__1(IAsyncResult ar)
",,<>c__DisplayClass8.<Execute>b__6 => GraphicsCommandHandler.ExecuteStartGraphicsDebuggingStartupProject => DeviceCommandHandler.ExecuteStartDebuggingStartupProject => DeviceCommandHandler.ExecuteStartDebuggingCore => DebugProcessLauncher.Launch => NLogLogger.Log => NLogLogger.LogCore
Error,12/14/2017 19:27:32,devenv.exe,'' id: 1,[vsip][connection]," at Nvda.Device.BlockingMessageDispatcher.ExecuteSynchronousCommand[TResult](Func`1 beginCommand, Func`2 endCommand, Action`2 exceptionHandler, TimeSpan commandTimeout)
",,<>c__DisplayClass8.<Execute>b__6 => GraphicsCommandHandler.ExecuteStartGraphicsDebuggingStartupProject => DeviceCommandHandler.ExecuteStartDebuggingStartupProject => DeviceCommandHandler.ExecuteStartDebuggingCore => DebugProcessLauncher.Launch => NLogLogger.Log => NLogLogger.LogCore
Error,12/14/2017 19:27:32,devenv.exe,'' id: 1,[vsip][connection]," at Nvda.ObjectModel.Monitor.WindowsSystem.GetSystemInfo(TimeSpan timeSpan, SystemInfoOptions options)
",,<>c__DisplayClass8.<Execute>b__6 => GraphicsCommandHandler.ExecuteStartGraphicsDebuggingStartupProject => DeviceCommandHandler.ExecuteStartDebuggingStartupProject => DeviceCommandHandler.ExecuteStartDebuggingCore => DebugProcessLauncher.Launch => NLogLogger.Log => NLogLogger.LogCore
Error,12/14/2017 19:27:32,devenv.exe,'' id: 1,[vsip][connection]," at Nvda.ObjectModel.Monitor.Tracking.MonitorSessionDeviceInfo(IDeviceHostSession deviceHostSession, String domain)
",,<>c__DisplayClass8.<Execute>b__6 => GraphicsCommandHandler.ExecuteStartGraphicsDebuggingStartupProject => DeviceCommandHandler.ExecuteStartDebuggingStartupProject => DeviceCommandHandler.ExecuteStartDebuggingCore => DebugProcessLauncher.Launch => NLogLogger.Log => NLogLogger.LogCore
Error,12/14/2017 19:27:32,devenv.exe,'' id: 1,[vsip][connection]," at Nvda.Vsip.Debugger.DebugProcessLauncher.Launch()
",,<>c__DisplayClass8.<Execute>b__6 => GraphicsCommandHandler.ExecuteStartGraphicsDebuggingStartupProject => DeviceCommandHandler.ExecuteStartDebuggingStartupProject => DeviceCommandHandler.ExecuteStartDebuggingCore => DebugProcessLauncher.Launch => NLogLogger.Log => NLogLogger.LogCore

I am running windows 10 with the latest updates.
GTX 1070 driver version 388.71.
Previously on this same machine when windows 7 was installed I had no issues running the program.

#1
Posted 12/21/2017 12:43 AM   
Hi flayne1996, I'm sorry for the problem you met. Can we have your sample please? Then we can identify the issue quickly. Thanks, Letitia
Hi flayne1996,

I'm sorry for the problem you met.
Can we have your sample please? Then we can identify the issue quickly.

Thanks,
Letitia

#2
Posted 12/22/2017 09:52 AM   
I am getting a crash similar. Software works fine when debugging, running, etc. But if I am Graphics Debugging with NSight it crashes. Windows 10 and a 1060 GTX. Specific spot is crashes is using glew and specifically glewInit(); I'm not sure where in the call it crashes but you can get glew here: http://glew.sourceforge.net/
I am getting a crash similar. Software works fine when debugging, running, etc. But if I am Graphics Debugging with NSight it crashes.

Windows 10 and a 1060 GTX.

Specific spot is crashes is using glew and specifically glewInit();

I'm not sure where in the call it crashes but you can get glew here:


http://glew.sourceforge.net/

#3
Posted 12/22/2017 01:06 PM   
[quote=""]Hi flayne1996, I'm sorry for the problem you met. Can we have your sample please? Then we can identify the issue quickly. Thanks, Letitia[/quote] The exact location of the crash is specified in my original post. The full source code file where the OpenGL initialization occurs can be found here: https://github.com/flayneorange/DontBlink/blob/master/source/WinDontBlink.cpp
said:Hi flayne1996,

I'm sorry for the problem you met.
Can we have your sample please? Then we can identify the issue quickly.

Thanks,
Letitia


The exact location of the crash is specified in my original post. The full source code file where the OpenGL initialization occurs can be found here: https://github.com/flayneorange/DontBlink/blob/master/source/WinDontBlink.cpp

#4
Posted 12/22/2017 06:43 PM   
Hi flayne1996, I downloaded the sample as you provided, built the project as the guide build.txt, but it seemed lack of FoxLib.hpp when I tried to compile the project, do you know how to build the project please? Thanks, Letitia
Hi flayne1996,

I downloaded the sample as you provided, built the project as the guide build.txt, but it seemed lack of FoxLib.hpp when I tried to compile the project, do you know how to build the project please?

Thanks,
Letitia

#5
Posted 12/25/2017 06:56 AM   
Hi RevenantBob, Can we have your sample please then we can identify the issue quickly? Thanks, Letitia
Hi RevenantBob,

Can we have your sample please then we can identify the issue quickly?

Thanks,
Letitia

#6
Posted 12/25/2017 07:35 AM   
I isolated the code in it's own sample: http://www.retrosmack.com/peorth/crash.zip Open the solution in Visual Studio 2017. Build the 64-bit executeable. 32-bit doesn't seem to cause the crash but 64-bit crashes on my system every time when NSight graphics debugging only.
I isolated the code in it's own sample:


http://www.retrosmack.com/peorth/crash.zip


Open the solution in Visual Studio 2017. Build the 64-bit executeable. 32-bit doesn't seem to cause the crash but 64-bit crashes on my system every time when NSight graphics debugging only.

#7
Posted 12/25/2017 03:12 PM   
Hi RevenantBob, I compiled the solution as release|x64, it showed blank view after launched even without nsight. Is it expected? Thanks, Letitia
Hi RevenantBob,

I compiled the solution as release|x64, it showed blank view after launched even without nsight. Is it expected?

Thanks,
Letitia

#8
Posted 12/26/2017 05:48 AM   
Yes. It isn't rendering. glewInit just crashes using NSight for me. So that's all it pretty much does.
Yes. It isn't rendering. glewInit just crashes using NSight for me. So that's all it pretty much does.

#9
Posted 12/26/2017 06:12 AM   
[quote=""]Hi flayne1996, I downloaded the sample as you provided, built the project as the guide build.txt, but it seemed lack of FoxLib.hpp when I tried to compile the project, do you know how to build the project please? Thanks, Letitia[/quote] Thanks again for your attention. I've updated build.txt to include instructions for downloading and installing foxlib. It is a header only library so it should be trivial to install.
said:Hi flayne1996,

I downloaded the sample as you provided, built the project as the guide build.txt, but it seemed lack of FoxLib.hpp when I tried to compile the project, do you know how to build the project please?

Thanks,
Letitia


Thanks again for your attention. I've updated build.txt to include instructions for downloading and installing foxlib. It is a header only library so it should be trivial to install.

#10
Posted 12/28/2017 07:28 PM   
Hi flayne1996, I re-synced the sample, and then built the project as the new guide build.txt, but I still failed to compile the project, error log as the link https://imgur.com/a/6ohOD Regards, Letitia
Hi flayne1996,

I re-synced the sample, and then built the project as the new guide build.txt, but I still failed to compile the project, error log as the link https://imgur.com/a/6ohOD


Regards,
Letitia

#11
Posted 12/29/2017 06:28 AM   
Hi RevenantBob, Thanks for your information. I've created an internal bug to track the issue. Thanks, Letitia
Hi RevenantBob,

Thanks for your information.
I've created an internal bug to track the issue.

Thanks,
Letitia

#12
Posted 12/29/2017 06:38 AM   
Scroll To Top

Add Reply