Protoc errors with version 2.6 and 3.5
If I have version 3.5 of protoc installed, I can make caffe and make pycaffe without an error but when I try to start DIGITS I get an error: [code]from caffe.proto import caffe_pb2 \x10\x64\x65t_bg_threshold\x18\x37 \x01(\x02:\x03\x30.5\x12\x1d\n\x0f\x64\x65t_fg_fraction\x18\x38 #............ a lot more of this TypeError: __init__() got an unexpected keyword argument 'syntax'[/code] If I have version 2.6 of protoc installed, I can start DIGITS but when I try to create a model I get an error: [code]This program requires version 3.5.0 of the Protocol Buffer runtime library, but the installed version is 2.6.1.[/code] Should I use version 2.6 or 3.5 and then has anyone been able to fix that respective error?
If I have version 3.5 of protoc installed, I can make caffe and make pycaffe without an error but when I try to start DIGITS I get an error:
from caffe.proto import caffe_pb2
\x10\x64\x65t_bg_threshold\x18\x37 \x01(\x02:\x03\x30.5\x12\x1d\n\x0f\x64\x65t_fg_fraction\x18\x38 #............ a lot more of this
TypeError: __init__() got an unexpected keyword argument 'syntax'

If I have version 2.6 of protoc installed, I can start DIGITS but when I try to create a model I get an error:
This program requires version 3.5.0 of the Protocol Buffer runtime library, but the installed version is 2.6.1.

Should I use version 2.6 or 3.5 and then has anyone been able to fix that respective error?

#1
Posted 12/21/2017 04:50 AM   
What version of the NGC containers are you using for Caffe and DIGITS?
What version of the NGC containers are you using for Caffe and DIGITS?

#2
Posted 01/02/2018 03:59 PM   
Scroll To Top

Add Reply