Error upgrading to 4.14.10 kernel in xubuntu 17.10 in dkms 384.90
cc1: some warnings being treated as errors scripts/Makefile.build:314: recipe for target '/var/lib/dkms/nvidia-384/384.90/build/nvidia-uvm/uvm8_va_block.o' failed make[2]: *** [/var/lib/dkms/nvidia-384/384.90/build/nvidia-uvm/uvm8_va_block.o] Error 1 make[2]: *** Waiting for unfinished jobs.... make[2]: *** wait: No child processes. Stop. Makefile:1510: recipe for target '_module_/var/lib/dkms/nvidia-384/384.90/build' failed make[1]: *** [_module_/var/lib/dkms/nvidia-384/384.90/build] Error 2 make[1]: Leaving directory '/usr/src/linux-headers-4.14.10-041410-generic' Makefile:81: recipe for target 'modules' failed make: *** [modules] Error 2
cc1: some warnings being treated as errors
scripts/Makefile.build:314: recipe for target '/var/lib/dkms/nvidia-384/384.90/build/nvidia-uvm/uvm8_va_block.o' failed
make[2]: *** [/var/lib/dkms/nvidia-384/384.90/build/nvidia-uvm/uvm8_va_block.o] Error 1
make[2]: *** Waiting for unfinished jobs....
make[2]: *** wait: No child processes. Stop.
Makefile:1510: recipe for target '_module_/var/lib/dkms/nvidia-384/384.90/build' failed
make[1]: *** [_module_/var/lib/dkms/nvidia-384/384.90/build] Error 2
make[1]: Leaving directory '/usr/src/linux-headers-4.14.10-041410-generic'
Makefile:81: recipe for target 'modules' failed
make: *** [modules] Error 2

#1
Posted 12/30/2017 04:49 PM   
last usable kernel was 4.14.8
last usable kernel was 4.14.8

#2
Posted 12/30/2017 04:52 PM   
nevermind, this was resolved upgrading to 387.34 Kernel 4.14.10 installs just fine now,
nevermind, this was resolved upgrading to 387.34 Kernel 4.14.10 installs just fine now,

#3
Posted 12/30/2017 05:34 PM   
Got the same ... this happens when in the 4.14.10 some kernel parameters was changed for Nvidia. i found no working fix for it but you can install the driver without CUDA support with ./NVIDIA-*.run --no-unified-memory this should install zthe driver now and you can wait on Nvidia fixing the problem. Greets John.
Got the same ...

this happens when in the 4.14.10 some kernel parameters was changed for Nvidia.

i found no working fix for it but you can install the driver without CUDA support

with ./NVIDIA-*.run --no-unified-memory

this should install zthe driver now and you can wait on Nvidia fixing the problem.

Greets John.

#4
Posted 01/01/2018 07:21 PM   
Scroll To Top

Add Reply