How to set Fan Speed for GTX 1080 Ti none use Monitor
Hi. I use one server run to render video, but i not connection monitor. I use remote via network LAN. How to set speed for FAN for VGA ? I use commands share on website, but is it need one connect Monitor. Thank!
Hi.

I use one server run to render video, but i not connection monitor. I use remote via network LAN.
How to set speed for FAN for VGA ? I use commands share on website, but is it need one connect Monitor.

Thank!

#1
Posted 01/09/2018 05:48 PM   
use Option "AllowEmptyInitialConfiguration" in xorg.conf to start an X server without monitor attached.
use
Option "AllowEmptyInitialConfiguration"
in xorg.conf to start an X server without monitor attached.

#2
Posted 01/09/2018 08:10 PM   
I user coinfig Xorg: [code]# nvidia-xconfig: X configuration file generated by nvidia-xconfig # nvidia-xconfig: version 384.111 (buildmeister@swio-display-x86-rhel47-01) Wed Dec 20 00:05:28 PST 2017 Section "ServerLayout" Identifier "Layout0" Screen 0 "Screen0" 0 0 Screen 1 "Screen0 (1)" RightOf "Screen0" Screen 2 "Screen0 (2)" RightOf "Screen0 (1)" Screen 3 "Screen0 (3)" RightOf "Screen0 (2)" InputDevice "Keyboard0" "CoreKeyboard" InputDevice "Mouse0" "CorePointer" EndSection Section "Files" FontPath "/usr/share/fonts/default/Type1" EndSection Section "InputDevice" # generated from default Identifier "Mouse0" Driver "mouse" Option "Protocol" "auto" Option "Device" "/dev/input/mice" Option "Emulate3Buttons" "no" Option "ZAxisMapping" "4 5" EndSection Section "InputDevice" # generated from default Identifier "Keyboard0" Driver "kbd" EndSection Section "Monitor" Identifier "Monitor0" VendorName "Unknown" ModelName "Unknown" HorizSync 28.0 - 33.0 VertRefresh 43.0 - 72.0 Option "DPMS" EndSection Section "Device" Identifier "Device0" Driver "nvidia" VendorName "NVIDIA Corporation" BoardName "GeForce GTX 1080 Ti" BusID "PCI:1:0:0" Screen 0 EndSection Section "Device" Identifier "Device0 (1)" Driver "nvidia" VendorName "NVIDIA Corporation" BoardName "GeForce GTX 1080 Ti" BusID "PCI:1:0:0" Screen 1 EndSection Section "Device" Identifier "Device0 (2)" Driver "nvidia" VendorName "NVIDIA Corporation" BoardName "GeForce GTX 1080 Ti" BusID "PCI:1:0:0" Screen 2 EndSection Section "Device" Identifier "Device0 (3)" Driver "nvidia" VendorName "NVIDIA Corporation" BoardName "GeForce GTX 1080 Ti" BusID "PCI:1:0:0" Screen 3 EndSection Section "Screen" Identifier "Screen0" Device "Device0" Monitor "Monitor0" DefaultDepth 24 Option "AllowEmptyInitialConfiguration" "True" SubSection "Display" Depth 24 EndSubSection EndSection Section "Screen" Identifier "Screen0 (1)" Device "Device0 (1)" Monitor "Monitor0" DefaultDepth 24 Option "AllowEmptyInitialConfiguration" "True" SubSection "Display" Depth 24 EndSubSection EndSection Section "Screen" Identifier "Screen0 (2)" Device "Device0 (2)" Monitor "Monitor0" DefaultDepth 24 Option "AllowEmptyInitialConfiguration" "True" SubSection "Display" Depth 24 EndSubSection EndSection Section "Screen" Identifier "Screen0 (3)" Device "Device0 (3)" Monitor "Monitor0" DefaultDepth 24 Option "AllowEmptyInitialConfiguration" "True" SubSection "Display" Depth 24 EndSubSection EndSection [/code] But command not work: [code]nvidia-settings -a "[fan:0]/GPUTargetFanSpeed=100" ERROR: The control display is undefined; please run `nvidia-settings --help` for usage information.[/code]
I user coinfig Xorg:
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 384.111 (buildmeister@swio-display-x86-rhel47-01) Wed Dec 20 00:05:28 PST 2017


Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
Screen 1 "Screen0 (1)" RightOf "Screen0"
Screen 2 "Screen0 (2)" RightOf "Screen0 (1)"
Screen 3 "Screen0 (3)" RightOf "Screen0 (2)"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Files"
FontPath "/usr/share/fonts/default/Type1"
EndSection

Section "InputDevice"

# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/input/mice"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Unknown"
HorizSync 28.0 - 33.0
VertRefresh 43.0 - 72.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce GTX 1080 Ti"
BusID "PCI:1:0:0"
Screen 0
EndSection

Section "Device"
Identifier "Device0 (1)"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce GTX 1080 Ti"
BusID "PCI:1:0:0"
Screen 1
EndSection

Section "Device"
Identifier "Device0 (2)"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce GTX 1080 Ti"
BusID "PCI:1:0:0"
Screen 2
EndSection

Section "Device"
Identifier "Device0 (3)"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce GTX 1080 Ti"
BusID "PCI:1:0:0"
Screen 3
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "AllowEmptyInitialConfiguration" "True"
SubSection "Display"
Depth 24
EndSubSection
EndSection

Section "Screen"
Identifier "Screen0 (1)"
Device "Device0 (1)"
Monitor "Monitor0"
DefaultDepth 24
Option "AllowEmptyInitialConfiguration" "True"
SubSection "Display"
Depth 24
EndSubSection
EndSection

Section "Screen"
Identifier "Screen0 (2)"
Device "Device0 (2)"
Monitor "Monitor0"
DefaultDepth 24
Option "AllowEmptyInitialConfiguration" "True"
SubSection "Display"
Depth 24
EndSubSection
EndSection

Section "Screen"
Identifier "Screen0 (3)"
Device "Device0 (3)"
Monitor "Monitor0"
DefaultDepth 24
Option "AllowEmptyInitialConfiguration" "True"
SubSection "Display"
Depth 24
EndSubSection
EndSection


But command not work:
nvidia-settings -a "[fan:0]/GPUTargetFanSpeed=100"

ERROR: The control display is undefined; please run `nvidia-settings --help` for usage information.

#3
Posted 01/10/2018 04:32 AM   
Why are you opening four screens on the same gpu? Please run nvidia-bug-report.sh and attach the tar.gz file it creates to your post.
Why are you opening four screens on the same gpu? Please run nvidia-bug-report.sh and attach the tar.gz file it creates to your post.

#4
Posted 01/10/2018 07:13 PM   
[b]ERROR: The control display is undefined; please run `nvidia-settings --help` for usage information. [/b] Have you tried doing what it tells you to do??? Spoiler: [code]nvidia-settings -c :0 -a "[fan:0]/GPUTargetFanSpeed=100" [/code] If that doesnt work, use [b]pgrep -a Xorg[/b] to find whichever display you are using. [code]# pgrep -a Xorg 368 /usr/libexec/Xorg -nolisten tcp [b]:0[/b] -auth /home/user/.serverauth.351 vt8 [/code]
ERROR: The control display is undefined; please run `nvidia-settings --help` for usage information.


Have you tried doing what it tells you to do???

Spoiler:

nvidia-settings -c :0 -a "[fan:0]/GPUTargetFanSpeed=100"


If that doesnt work, use pgrep -a Xorg to find whichever display you are using.

# pgrep -a Xorg
368 /usr/libexec/Xorg -nolisten tcp :0 -auth /home/user/.serverauth.351 vt8

#5
Posted 01/10/2018 10:19 PM   
Firstly I thank you for taking the precious time to help me! Yes. Due to my mistake to leave Nvidia default configuration should generate 4 screens in the config file. I deleted the other screen leaving only 1, but it still generates error, now the error is: [code]ERROR: Error assigning value 100 to attribute 'GPUTargetFanSpeed' (localhost.localdomain: 0 [fan: 0]) as specified in assignment        '[fan: 0] / GPUTargetFanSpeed = 100' (Unknown Error). [/code] Xorg Config new: [code]# nvidia-xconfig: X configuration file generated by nvidia-xconfig # nvidia-xconfig: version 384.111 (buildmeister@swio-display-x86-rhel47-01) Wed Dec 20 00:05:28 PST 2017 Section "ServerLayout" Identifier "Layout0" Screen 0 "Screen0" InputDevice "Keyboard0" "CoreKeyboard" InputDevice "Mouse0" "CorePointer" EndSection Section "Files" FontPath "/usr/share/fonts/default/Type1" EndSection Section "InputDevice" # generated from default Identifier "Mouse0" Driver "mouse" Option "Protocol" "auto" Option "Device" "/dev/input/mice" Option "Emulate3Buttons" "no" Option "ZAxisMapping" "4 5" EndSection Section "InputDevice" # generated from default Identifier "Keyboard0" Driver "kbd" EndSection Section "Monitor" Identifier "Monitor0" VendorName "Unknown" ModelName "Unknown" HorizSync 28.0 - 33.0 VertRefresh 43.0 - 72.0 Option "DPMS" EndSection Section "Device" Identifier "Device0" Driver "nvidia" VendorName "NVIDIA Corporation" BoardName "GeForce GTX 1080 Ti" BusID "PCI:1:0:0" Screen 0 EndSection Section "Screen" Identifier "Screen0" Device "Device0" Monitor "Monitor0" DefaultDepth 24 Option "AllowEmptyInitialConfiguration" "True" SubSection "Display" Depth 24 EndSubSection EndSection [/code]
Firstly I thank you for taking the precious time to help me!

Yes.
Due to my mistake to leave Nvidia default configuration should generate 4 screens in the config file. I deleted the other screen leaving only 1, but it still generates error, now the error is:
ERROR: Error assigning value 100 to attribute 'GPUTargetFanSpeed' (localhost.localdomain: 0 [fan: 0]) as specified in assignment        '[fan: 0] / GPUTargetFanSpeed = 100' (Unknown Error).


Xorg Config new:
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 384.111 (buildmeister@swio-display-x86-rhel47-01) Wed Dec 20 00:05:28 PST 2017


Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Files"
FontPath "/usr/share/fonts/default/Type1"
EndSection

Section "InputDevice"

# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/input/mice"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Unknown"
HorizSync 28.0 - 33.0
VertRefresh 43.0 - 72.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce GTX 1080 Ti"
BusID "PCI:1:0:0"
Screen 0
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "AllowEmptyInitialConfiguration" "True"
SubSection "Display"
Depth 24
EndSubSection
EndSection

#6
Posted 01/11/2018 01:50 AM   
You have to define the Coolbits option according to what you want to control, see: [url]https://download.nvidia.com/XFree86/Linux-x86_64/384.98/README/xconfigoptions.html[/url]
You have to define the Coolbits option according to what you want to control, see:
https://download.nvidia.com/XFree86/Linux-x86_64/384.98/README/xconfigoptions.html

#7
Posted 01/11/2018 07:37 AM   
And after he/she figures out how to do that, here is solution to his/hers next and hopefully final problem: [code]nvidia-settings -a '[gpu:0]/GPUFanControlState=1' -a '[fan: 0]/GPUTargetFanSpeed=100'[/code] Because you can't set TargetFanSpeed unless you enable manual control state, which is toggled off by default. Almost wanna put their X extension into IDA Pro and write an non X-org wrapper around this crap, not sure why Nvidia haven't done that already, probably some really clever reason like setting performance levels based on foreground tasks, something that is present on windows and has to be emulated via xorg on linux. [size="S"][s]Or they are just lazy (by the way, have you finally merged debian reproducible build patches?)[/s][/size]
And after he/she figures out how to do that, here is solution to his/hers next and hopefully final problem:

nvidia-settings -a '[gpu:0]/GPUFanControlState=1' -a '[fan: 0]/GPUTargetFanSpeed=100'


Because you can't set TargetFanSpeed unless you enable manual control state, which is toggled off by default.

Almost wanna put their X extension into IDA Pro and write an non X-org wrapper around this crap, not sure why Nvidia haven't done that already, probably some really clever reason like setting performance levels based on foreground tasks, something that is present on windows and has to be emulated via xorg on linux.

Or they are just lazy (by the way, have you finally merged debian reproducible build patches?)

#8
Posted 01/13/2018 01:45 AM   
Thank you for your help. I have found a solution to this problem. I used the script: https://github.com/allenwq/nvidia-fan-control Or run the command: [code]nvidia-settings -c :0 -a "[fan:0]/GPUTargetFanSpeed=100"[/code]
Thank you for your help.
I have found a solution to this problem.
I used the script: https://github.com/allenwq/nvidia-fan-control

Or run the command:
nvidia-settings -c :0 -a "[fan:0]/GPUTargetFanSpeed=100"

#9
Posted 01/13/2018 03:38 AM   
Scroll To Top

Add Reply