Google Chrome and Firefox have bad HW acceleration performance on 390.25
Hi, I'm running Fedora 27 (HP Z600 dual Xeon workstation, GTX 1060 6GB, dual monitor setup), and since upgrading to kernel 4.14.16-300.fc27.x86_64, only the 390.25 driver packaged by RPMFusion installs cleanly. It appears to perform well in general, and games like Shadow Warrior run just fine, but WebGL is slow on both Chrome 64.0.3282.140 and Firefox 58.0.1. Youtube video playback takes several seconds to become stable on Chrome (did not notice similar issue on Firefox). CPU usage does _not_ seem to spike, despite obvious program render slowdown. The video playback issues go away if disabling Chrome hardware acceleration. Curiously, the WebGL application that's slow on the browsers runs fast and without issue on nwjs 63.0.3239.132 - I'm wondering, could this have something to do with the Spectre mitigations added into the 390 drivers? Edit: just tried nwjs 64.0.3282.140, and no slowdown there, either. These issues did not manifest on the 387.22 drivers - for business reasons, I'm forced to downgrade. PS: first time poster, please try to go easy on me :) PS2: tried 390.25 packaged by negativo17; nothing changed. PS3: installed 387.34 using package from NVIDIA's site; working without issue.
Hi,

I'm running Fedora 27 (HP Z600 dual Xeon workstation, GTX 1060 6GB, dual monitor setup), and since upgrading to kernel 4.14.16-300.fc27.x86_64, only the 390.25 driver packaged by RPMFusion installs cleanly. It appears to perform well in general, and games like Shadow Warrior run just fine, but WebGL is slow on both Chrome 64.0.3282.140 and Firefox 58.0.1. Youtube video playback takes several seconds to become stable on Chrome (did not notice similar issue on Firefox). CPU usage does _not_ seem to spike, despite obvious program render slowdown. The video playback issues go away if disabling Chrome hardware acceleration.

Curiously, the WebGL application that's slow on the browsers runs fast and without issue on nwjs 63.0.3239.132 - I'm wondering, could this have something to do with the Spectre mitigations added into the 390 drivers?
Edit: just tried nwjs 64.0.3282.140, and no slowdown there, either.

These issues did not manifest on the 387.22 drivers - for business reasons, I'm forced to downgrade.


PS: first time poster, please try to go easy on me :)

PS2: tried 390.25 packaged by negativo17; nothing changed.

PS3: installed 387.34 using package from NVIDIA's site; working without issue.

#1
Posted 02/05/2018 09:46 PM   
I think you can line up here: [url]https://devtalk.nvidia.com/default/topic/1029484/linux/-linux-mint-18-3-numerous-performance-amp-rendering-issues-on-390-25/[/url] Though your xserver is 1.19.6 so the circumstances under which this bug surface are unclear.
I think you can line up here:
https://devtalk.nvidia.com/default/topic/1029484/linux/-linux-mint-18-3-numerous-performance-amp-rendering-issues-on-390-25/
Though your xserver is 1.19.6 so the circumstances under which this bug surface are unclear.

#2
Posted 02/05/2018 10:18 PM   
I looked at that thread, and while the issues are similar, [s]I did not see browser performance mentioned[/s], and the software stack is different. Hopefully, this post can stand so we can make it clear that it is not just Mint suffering from issues. Edit: durp, the same browser performance problem was mentioned in the first post. Feel free to delete/merge.
I looked at that thread, and while the issues are similar, I did not see browser performance mentioned, and the software stack is different. Hopefully, this post can stand so we can make it clear that it is not just Mint suffering from issues.

Edit: durp, the same browser performance problem was mentioned in the first post. Feel free to delete/merge.

#3
Posted 02/05/2018 10:26 PM   
Firefox under NVIDIA binary drivers is an infinite story of pain. Here's how it can be fixed to run fast. Open about:config and set these parameters: [code] user_pref("gfx.canvas.azure.accelerated", true); user_pref("gfx.xrender.enabled", true); user_pref("layers.acceleration.force-enabled", true); [/code] It took me several hours to find these parameters. And none of these options are required under nouveau. [url=https://web.archive.org/web/20120831004759/http://ie.microsoft.com/testdrive/]Demos[/url] to [url=https://web.archive.org/web/20140424025329/http://ie.microsoft.com:80/testdrive/]check[/url] the resulting [url=https://testdrive-archive.azurewebsites.net/Views/SiteMap/]performance[/url] (my results): http://www.smashcat.org/av/canvas_test/ (~150) https://testdrive-archive.azurewebsites.net/performance/psychedelicbrowsing/Default.html (1357) https://testdrive-archive.azurewebsites.net/Performance/FishIETank/Default.html (1000 fish: 24-28) https://testdrive-archive.azurewebsites.net/Performance/ParticleAcceleration/ (16, [url=https://bugzilla.mozilla.org/show_bug.cgi?id=760888]still not properly accelerated under Linux/MacOS[/url]) https://testdrive-archive.azurewebsites.net/graphics/toucheffects/ (painfully slow) https://testdrive-archive.azurewebsites.net/performance/fishbowl/ (2000 fish: 17) https://testdrive-archive.azurewebsites.net/performance/bubbles/ (21-37fps)
Firefox under NVIDIA binary drivers is an infinite story of pain. Here's how it can be fixed to run fast.

Open about:config and set these parameters:

user_pref("gfx.canvas.azure.accelerated", true);
user_pref("gfx.xrender.enabled", true);
user_pref("layers.acceleration.force-enabled", true);


It took me several hours to find these parameters. And none of these options are required under nouveau.

Demos to check the resulting performance (my results):

http://www.smashcat.org/av/canvas_test/
(~150)
https://testdrive-archive.azurewebsites.net/performance/psychedelicbrowsing/Default.html
(1357)
https://testdrive-archive.azurewebsites.net/Performance/FishIETank/Default.html
(1000 fish: 24-28)
https://testdrive-archive.azurewebsites.net/Performance/ParticleAcceleration/
(16, still not properly accelerated under Linux/MacOS)
https://testdrive-archive.azurewebsites.net/graphics/toucheffects/
(painfully slow)
https://testdrive-archive.azurewebsites.net/performance/fishbowl/
(2000 fish: 17)
https://testdrive-archive.azurewebsites.net/performance/bubbles/
(21-37fps)

Artem S. Tashkinov
Linux and Open Source advocate

#4
Posted 02/06/2018 09:43 AM   
Same situation for me on Arch Linux with xorg 1.19.6, nvidia 390.25 and kernel 4.15.1. However not only chrome, but also my chromium browser is affected. In addition to this there is also a new bug which breaks vsync as seen on vsynctester.com this makes all video including Netflix unwatchable due to stutter (60 hz instead of correct 59.95 as before). Let me know if you experience stutter (I will be starting a new thread). Hardware is in signature.
Same situation for me on Arch Linux with xorg 1.19.6, nvidia 390.25 and kernel 4.15.1. However not only chrome, but also my chromium browser is affected.

In addition to this there is also a new bug which breaks vsync as seen on vsynctester.com this makes all video including Netflix unwatchable due to stutter (60 hz instead of correct 59.95 as before). Let me know if you experience stutter (I will be starting a new thread). Hardware is in signature.

Dell Precision M4700
Intel QM77 chipset
Core i7 3940XM (with Intel HD4000 graphics)
Nvidia Quadro K2000M (Geforce GT650m equivalent)
16 GB DDR3 1600 ram
Windows 10 Pro 1709
Arch Linux with KDE Plasma

#5
Posted 02/06/2018 08:05 PM   
Scroll To Top

Add Reply