Nvidia drivers 390.77: no external display on Ubuntu 18.04 and Quadro M1000M
Done: xorg.zip
Done: xorg.zip

#16
Posted 10/12/2018 04:25 PM   
Ok, at least Prime is working now but the external outputs are not detected. I suspect this is due to gdm running in a wayland session. To check, please modify the file /lib/modprobe.d/nvidia-kms.conf and set options nvidia-drm modeset=0 then run sudo update-initramfs -u and reboot
Answer Accepted by Original Poster
Ok, at least Prime is working now but the external outputs are not detected. I suspect this is due to gdm running in a wayland session. To check, please modify the file
/lib/modprobe.d/nvidia-kms.conf
and set
options nvidia-drm modeset=0
then run
sudo update-initramfs -u and reboot

#17
Posted 10/12/2018 06:04 PM   
"options nvidia-drm modeset" was set to 1. After setting it to 0 and rebooting, my external monitor is back online! I've checked at login screen and I use X session, not Wayland. How could gdm be running in Wayland? Thank you so much, generix!
"options nvidia-drm modeset" was set to 1. After setting it to 0 and rebooting, my external monitor is back online!

I've checked at login screen and I use X session, not Wayland. How could gdm be running in Wayland?

Thank you so much, generix!

#18
Posted 10/15/2018 07:15 AM   
I've read about KMS/DRM. So, it should be 1. And setting it to 0 doesn't solve the problem, right?
I've read about KMS/DRM. So, it should be 1. And setting it to 0 doesn't solve the problem, right?

#19
Posted 10/15/2018 07:40 AM   
nvidia-drm modeset=1 is needed for tear-free display but since this is enabling linux kms for the nvidia driver, gdm thinks it can use wayland. Having a parallel wayland session makes it somehow impossible for X to detect any outputs on the nvidia gpu. Can drive people insane. See if it helps to disable wayland for gdm: [url]https://askubuntu.com/questions/975094/how-to-disable-wayland-in-17-10-in-gdm3-login-screen[/url] and then set nvidia-drm modeset=1 again to have a tear-free display.
nvidia-drm modeset=1 is needed for tear-free display but since this is enabling linux kms for the nvidia driver, gdm thinks it can use wayland. Having a parallel wayland session makes it somehow impossible for X to detect any outputs on the nvidia gpu. Can drive people insane.
See if it helps to disable wayland for gdm:
https://askubuntu.com/questions/975094/how-to-disable-wayland-in-17-10-in-gdm3-login-screen
and then set nvidia-drm modeset=1 again to have a tear-free display.

#20
Posted 10/15/2018 07:40 AM   
That nvidia kms/gdm issue has been a nuisance for quite some time, so many people instead use lightdm and [url]https://github.com/timrichardson/Prime-Ubuntu-18.04[/url] because of [url]https://devtalk.nvidia.com/default/topic/1032482/linux/optimus-on-ubuntu-18-04-is-a-step-backwards-but-i-found-the-first-good-solution/1[/url]
That nvidia kms/gdm issue has been a nuisance for quite some time, so many people instead use lightdm and https://github.com/timrichardson/Prime-Ubuntu-18.04 because of https://devtalk.nvidia.com/default/topic/1032482/linux/optimus-on-ubuntu-18-04-is-a-step-backwards-but-i-found-the-first-good-solution/1

#21
Posted 10/15/2018 07:54 AM   
Uncommenting "WaylandEnable=false" doesn't help. After enabling modsetting my external screen goes off.
Uncommenting "WaylandEnable=false" doesn't help. After enabling modsetting my external screen goes off.

#22
Posted 10/15/2018 08:15 AM   
I was on 18.04 right from the release and never had a problem with this until up now.
I was on 18.04 right from the release and never had a problem with this until up now.

#23
Posted 10/15/2018 08:18 AM   
The default for nvidia-drm modeset was 0 before, so only people who set that manually had this problem. With the last Ubuntu update, they changed the default from 0 to 1, so now you have it, too without doing anything yourself.
The default for nvidia-drm modeset was 0 before, so only people who set that manually had this problem. With the last Ubuntu update, they changed the default from 0 to 1, so now you have it, too without doing anything yourself.

#24
Posted 10/15/2018 08:20 AM   
Scroll To Top

Add Reply