could not open the device file /dev/nvidiactl
Hi,
I'm new on cuda..I'm trying to install it on my ubuntu 8.04 64bit-distro with a gf8800 using the nvidia driver 64-180.06 .. after the installation steps , without problems, i tried to run NVIDIA_CUDA_SDK/bin/linux/release/deviceQuery as user and as root but i get the message:
[quote]NVIDIA: could not open the device file /dev/nvidiactl (Permission denied).
There is no device supporting CUDA.[/quote]

I've checked the /dev/nv* permissions:

[quote]crw-rw---- 1 root video 195, 0 2008-11-25 13:10 /dev/nvidia0
crw-rw---- 1 root video 195, 255 2008-11-25 13:10 /dev/nvidiactl[/quote]

Any ideas?
thanks :)
Hi,

I'm new on cuda..I'm trying to install it on my ubuntu 8.04 64bit-distro with a gf8800 using the nvidia driver 64-180.06 .. after the installation steps , without problems, i tried to run NVIDIA_CUDA_SDK/bin/linux/release/deviceQuery as user and as root but i get the message:

NVIDIA: could not open the device file /dev/nvidiactl (Permission denied).

There is no device supporting CUDA.




I've checked the /dev/nv* permissions:



crw-rw---- 1 root video 195, 0 2008-11-25 13:10 /dev/nvidia0

crw-rw---- 1 root video 195, 255 2008-11-25 13:10 /dev/nvidiactl




Any ideas?

thanks :)

#1
Posted 11/25/2008 01:36 PM   
You listed the permission. Only root and the video group can access the card. Add your user to the video group and all should be well.
You listed the permission. Only root and the video group can access the card. Add your user to the video group and all should be well.

#2
Posted 11/25/2008 02:12 PM   
i've added myself (raffo) to the video group
[quote]grep video /etc/group
video:x:44:andrea,raffo[/quote]
but the message is still the same..
i've added myself (raffo) to the video group

grep video /etc/group

video:x:44:andrea,raffo


but the message is still the same..

#3
Posted 11/25/2008 02:23 PM   
Does this problem go away if you start X?
Does this problem go away if you start X?

#4
Posted 11/25/2008 02:56 PM   
no, the problem remain. I can't understand what is going wrong..i've spent all morning on this..
no, the problem remain. I can't understand what is going wrong..i've spent all morning on this..

#5
Posted 11/25/2008 03:30 PM   
easy way: sudo chmod 0666 /dev/nvidia*
easy way: sudo chmod 0666 /dev/nvidia*

#6
Posted 11/25/2008 07:52 PM   
Another something simple. Did you log out and back in after adding yourself to the group?
Another something simple. Did you log out and back in after adding yourself to the group?

#7
Posted 11/25/2008 10:47 PM   
i've modified the permissions on the device using chmod but nothing happened. Log-off, x-server and system restart are useless..I worked around udev rules without results..
i've modified the permissions on the device using chmod but nothing happened. Log-off, x-server and system restart are useless..I worked around udev rules without results..

#8
Posted 11/26/2008 08:06 AM   
[quote name='eritema' post='468810' date='Nov 26 2008, 09:06 AM']i've modified the permissions on the device using chmod but nothing happened. Log-off, x-server and system restart are useless..I worked around udev rules without results..[/quote]

I had the same issue some time ago. I took the "easy way" pointed out by tmurray.

sudo chmod 666 /dev/nvidia*

It was working for me, but you have to repeat it after every reboot

make sure that you are actually chamging the permissions after chmod. Maybe a wrong sudo password or something can avoid them to be changed

another possibility to try is to directly run the executable using sudo

sudo ./your_program

Regards
[quote name='eritema' post='468810' date='Nov 26 2008, 09:06 AM']i've modified the permissions on the device using chmod but nothing happened. Log-off, x-server and system restart are useless..I worked around udev rules without results..



I had the same issue some time ago. I took the "easy way" pointed out by tmurray.



sudo chmod 666 /dev/nvidia*



It was working for me, but you have to repeat it after every reboot



make sure that you are actually chamging the permissions after chmod. Maybe a wrong sudo password or something can avoid them to be changed



another possibility to try is to directly run the executable using sudo



sudo ./your_program



Regards

#9
Posted 11/26/2008 10:13 AM   
i had tried everything but nothing worked for me..i solved my problems simply replacing the new 64-180.06 driver with the older 64-177.67 and downgrading cuda to 2.0.. all seems to be ok now without additional "tuning" phase

thanks to all :)
i had tried everything but nothing worked for me..i solved my problems simply replacing the new 64-180.06 driver with the older 64-177.67 and downgrading cuda to 2.0.. all seems to be ok now without additional "tuning" phase



thanks to all :)

#10
Posted 11/26/2008 11:36 AM   
absolutely do not use 177.67. use 177.73 or 177.80 if you're going to use a 177.xx driver.
absolutely do not use 177.67. use 177.73 or 177.80 if you're going to use a 177.xx driver.

#11
Posted 11/26/2008 12:05 PM   
ok, now i'm using a 177.82 driver, thanks
ok, now i'm using a 177.82 driver, thanks

#12
Posted 11/26/2008 01:34 PM   
Try adding the following section to xorg.conf:
Code:

Section "DRI"
Mode 0666
EndSection

It worked for me!
Try adding the following section to xorg.conf:

Code:



Section "DRI"

Mode 0666

EndSection



It worked for me!

#13
Posted 03/14/2012 09:28 AM   
I had exactly the same issues with the driver 340.29. Tried changing permissions: chmod 666 /dev/nvidia* nvidia-smi was working for root but not for any other user. so eventually I had to modify /etc/modprobe.d/50-nvidia.conf options nvidia NVreg_DeviceFileUID=0 NVreg_DeviceFileGID=33 NVreg_DeviceFileMode=0666 NVreg_ModifyDeviceFiles=1 The problem was resolved with the last variable. Remember to delete the files /dev/nvidia* Then it works for all users
I had exactly the same issues with the driver 340.29.

Tried changing permissions:

chmod 666 /dev/nvidia*

nvidia-smi was working for root but not for any other user. so eventually I had to modify /etc/modprobe.d/50-nvidia.conf

options nvidia NVreg_DeviceFileUID=0 NVreg_DeviceFileGID=33 NVreg_DeviceFileMode=0666 NVreg_ModifyDeviceFiles=1

The problem was resolved with the last variable.

Remember to delete the files /dev/nvidia*

Then it works for all users

#14
Posted 02/17/2015 11:04 AM   
Scroll To Top