weird error about linking to 'cutil_inline.h'
I was playing around with a sample project (template) provided with CUDA SDK.

It could be compiled and run w/o any problems in its original location. But it gave the following error when I copied the project to another location.

MyVectorAdd.cu(48) : fatal error C1083: Cannot open include file: 'cutil_inline.h': No such file or directory


Any idea?
I was playing around with a sample project (template) provided with CUDA SDK.



It could be compiled and run w/o any problems in its original location. But it gave the following error when I copied the project to another location.



MyVectorAdd.cu(48) : fatal error C1083: Cannot open include file: 'cutil_inline.h': No such file or directory





Any idea?

#1
Posted 05/07/2009 10:30 PM   
cutil_inline.h is located somewhere within the common subdirectory (common/inc, maybe?), so you're breaking that path.
cutil_inline.h is located somewhere within the common subdirectory (common/inc, maybe?), so you're breaking that path.

#2
Posted 05/07/2009 10:46 PM   
thanks for your response.

I found where cutil_inline.h is
C:\ProgramData\NVIDIA Corporation\NVIDIA CUDA SDK\common\inc

and put the path into Configuration Properties → C/C++ → General:->Additional Include Directories

but still doesn't work

[quote name='tmurray' post='538604' date='May 7 2009, 10:46 PM']cutil_inline.h is located somewhere within the common subdirectory (common/inc, maybe?), so you're breaking that path.[/quote]
thanks for your response.



I found where cutil_inline.h is

C:\ProgramData\NVIDIA Corporation\NVIDIA CUDA SDK\common\inc



and put the path into Configuration Properties → C/C++ → General:->Additional Include Directories



but still doesn't work



[quote name='tmurray' post='538604' date='May 7 2009, 10:46 PM']cutil_inline.h is located somewhere within the common subdirectory (common/inc, maybe?), so you're breaking that path.

#3
Posted 05/08/2009 04:18 AM   
The original path in the command line for compiling is
-I../../common/inc
Now I changed to
-I“$(NVSDKCUDA_ROOT)\common\inc”

it works now

But it's ridiculous, I did everything exactly according to official document "Creating Your Own CUDA Program" in CUDA_SDK_release_notes_windows.txt (CUDA SDK 2.2)
No one test them before releasing?????
The original path in the command line for compiling is

-I../../common/inc

Now I changed to

-I“$(NVSDKCUDA_ROOT)\common\inc”



it works now



But it's ridiculous, I did everything exactly according to official document "Creating Your Own CUDA Program" in CUDA_SDK_release_notes_windows.txt (CUDA SDK 2.2)

No one test them before releasing?????

#4
Posted 05/08/2009 03:35 PM   
I now encountered the same problem.
However, I am unable to edit the command line options which are greyed out. This is the case for all the SDK samples.
I'm using SDK 2.2 WinXP VS2005
Did you have the same problem? And if so, how did you get around it?
Thanks in advance.

[quote name='hitheng' post='538823' date='May 8 2009, 04:35 PM']The original path in the command line for compiling is
-I../../common/inc
Now I changed to
-I“$(NVSDKCUDA_ROOT)\common\inc”[/quote]
I now encountered the same problem.

However, I am unable to edit the command line options which are greyed out. This is the case for all the SDK samples.

I'm using SDK 2.2 WinXP VS2005

Did you have the same problem? And if so, how did you get around it?

Thanks in advance.



[quote name='hitheng' post='538823' date='May 8 2009, 04:35 PM']The original path in the command line for compiling is

-I../../common/inc

Now I changed to

-I“$(NVSDKCUDA_ROOT)\common\inc”

#5
Posted 07/20/2009 09:30 AM   
[quote name='hitheng' post='538823' date='May 8 2009, 04:35 PM']The original path in the command line for compiling is
-I../../common/inc
Now I changed to
-I“$(NVSDKCUDA_ROOT)\common\inc”

it works now

But it's ridiculous, I did everything exactly according to official document "Creating Your Own CUDA Program" in CUDA_SDK_release_notes_windows.txt (CUDA SDK 2.2)
No one test them before releasing?????[/quote]

Thanks alot for spelling this out. It helped me eliminate a few errors.
[quote name='hitheng' post='538823' date='May 8 2009, 04:35 PM']The original path in the command line for compiling is

-I../../common/inc

Now I changed to

-I“$(NVSDKCUDA_ROOT)\common\inc”



it works now



But it's ridiculous, I did everything exactly according to official document "Creating Your Own CUDA Program" in CUDA_SDK_release_notes_windows.txt (CUDA SDK 2.2)

No one test them before releasing?????



Thanks alot for spelling this out. It helped me eliminate a few errors.

#6
Posted 12/26/2009 02:38 AM   
[quote name='lulach' post='567518' date='Jul 20 2009, 10:30 AM']I now encountered the same problem.
However, I am unable to edit the command line options which are greyed out. This is the case for all the SDK samples.
I'm using SDK 2.2 WinXP VS2005
Did you have the same problem? And if so, how did you get around it?
Thanks in advance.[/quote]

i had the same problem
u should add the "..\common\inc" direcotry into the additional include directories under CUDA BUild Rule, which u have embeded in MS Visual Studio.
[quote name='lulach' post='567518' date='Jul 20 2009, 10:30 AM']I now encountered the same problem.

However, I am unable to edit the command line options which are greyed out. This is the case for all the SDK samples.

I'm using SDK 2.2 WinXP VS2005

Did you have the same problem? And if so, how did you get around it?

Thanks in advance.



i had the same problem

u should add the "..\common\inc" direcotry into the additional include directories under CUDA BUild Rule, which u have embeded in MS Visual Studio.

#7
Posted 01/22/2010 03:18 PM   
The location of cutil_inline.h was, for me, in the hidden folder ProgramData and as follow : C:\ProgramData\NVIDIA Corporation\NVIDIA GPU Computing SDK 4.2\C\common\inc I fixed the C1083 issue doing this : Right click on your project (vs8) > Properties Custom build step Command line > adding this : -I"C:\ProgramData\NVIDIA Corporation\NVIDIA GPU Computing SDK 4.2\C\common\inc" Hope this can help you..
The location of cutil_inline.h was, for me, in the hidden folder ProgramData and as follow :

C:\ProgramData\NVIDIA Corporation\NVIDIA GPU Computing SDK 4.2\C\common\inc

I fixed the C1083 issue doing this :
Right click on your project (vs8) > Properties
Custom build step
Command line > adding this : -I"C:\ProgramData\NVIDIA Corporation\NVIDIA GPU Computing SDK 4.2\C\common\inc"

Hope this can help you..

#8
Posted 06/25/2013 04:15 PM   
Scroll To Top