Cuda syntax highlighting..
EDIT: Problem solved. The usertype.dat file must go in the x86 version's folder:
C:\Program Files (x86)\Microsoft Visual Studio 9.0\Common7\IDE

I've download and installed CUDA 2.2 for Windows Vista x64.

I found the readme file located in the CUDA SDK files that explains how to get syntax highlighting for .cu files.

I followed the instructions in the readme, placing the usertype.dat file into:

C:\Program Files\Microsoft Visual Studio 9.0\Common7\IDE

I then made the proper settings to apply this to .cu files in the IDE. I'm providing a screenshot just to prove I did it right..

[img]http://img4.imageshack.us/img4/2015/cuset.gif[/img]

Then I restarted visual studio. I now get syntax highlighting for "C" keywords only...none of the keywords in usertype.dat are applied.

Does anyone else have this issue? I know at least one other person did.

My version info:
[quote]Microsoft Visual Studio 2008
Version 9.0.21022.8 RTM
Microsoft .NET Framework
Version 3.5 SP1

Installed Edition: Professional

Microsoft Visual C# 2008 91605-270-3013833-60765
Microsoft Visual C# 2008

Microsoft Visual C++ 2008 91605-270-3013833-60765
Microsoft Visual C++ 2008

Microsoft Visual Studio 2008 Tools for Office 91605-270-3013833-60765
Microsoft Visual Studio 2008 Tools for Office[/quote]
EDIT: Problem solved. The usertype.dat file must go in the x86 version's folder:

C:\Program Files (x86)\Microsoft Visual Studio 9.0\Common7\IDE



I've download and installed CUDA 2.2 for Windows Vista x64.



I found the readme file located in the CUDA SDK files that explains how to get syntax highlighting for .cu files.



I followed the instructions in the readme, placing the usertype.dat file into:



C:\Program Files\Microsoft Visual Studio 9.0\Common7\IDE



I then made the proper settings to apply this to .cu files in the IDE. I'm providing a screenshot just to prove I did it right..



Image



Then I restarted visual studio. I now get syntax highlighting for "C" keywords only...none of the keywords in usertype.dat are applied.



Does anyone else have this issue? I know at least one other person did.



My version info:

Microsoft Visual Studio 2008

Version 9.0.21022.8 RTM

Microsoft .NET Framework

Version 3.5 SP1



Installed Edition: Professional



Microsoft Visual C# 2008 91605-270-3013833-60765

Microsoft Visual C# 2008



Microsoft Visual C++ 2008 91605-270-3013833-60765

Microsoft Visual C++ 2008



Microsoft Visual Studio 2008 Tools for Office 91605-270-3013833-60765

Microsoft Visual Studio 2008 Tools for Office

#1
Posted 06/20/2009 07:24 PM   
I had the same trouble after adding the cu extension editor. If you are like me you probably just added the extension editor and didn't click on it again in the menu and select apply. The add button apparently does not apply the new rule too. After clicking the apply button I am experiencing the promised syntax highlighting.
I had the same trouble after adding the cu extension editor. If you are like me you probably just added the extension editor and didn't click on it again in the menu and select apply. The add button apparently does not apply the new rule too. After clicking the apply button I am experiencing the promised syntax highlighting.

#2
Posted 09/11/2009 06:14 PM   
Currently, I am with CUDA 3.2 + VS 2008
You should copy usertype.dat to this fold:
C:\Program Files (x86)\Microsoft Visual Studio 9.0\Common7\IDE
It's verified by testing.
Currently, I am with CUDA 3.2 + VS 2008

You should copy usertype.dat to this fold:

C:\Program Files (x86)\Microsoft Visual Studio 9.0\Common7\IDE

It's verified by testing.

#3
Posted 01/27/2011 06:06 AM   
Scroll To Top

Add Reply