cuFFT - error in cufftComplex memory assignment
Hi there!

I am getting a memory error when assigning cufftComplex memory as follows (All variables are declared and set properly prior through function call).

[codebox]
float *device_proj;
cufftComplex* kernel;
cufftComplex* twice_image_vect;

int size=2*u_ext;

cudaMalloc(reinterpret_cast<void **>(&device_proj), u_ext*v_ext*sizeof(float));
cudaMemcpy(device_proj, in, u_ext*v_ext*sizeof(float), cudaMemcpyHostToDevice);

cudaMalloc(reinterpret_cast<void **>(&twice_image_vect), size*sizeof(cufftComplex));
cudaMalloc(reinterpret_cast<void **>(&kernel), size*sizeof(cufftComplex));[/codebox]

The error is displayed by VS9 as: First-chance exception at 0x7c812afb in 122209_cufft_test.exe: Microsoft C++ exception: cudaError_enum at memory location 0x0012fa18

Which is to my understanding wrong memory assessment. I am using VS9, Cuda 2.3. and a Quadro FX1700 (I think the card is the problem).

On the other hand, continuing with the program. Assigning values to kernel and doing the FFT returns "good" values, I just don't like the error invocation.

Anyone ever had the same problem???

Thanks for your help,

Sebastian
Hi there!



I am getting a memory error when assigning cufftComplex memory as follows (All variables are declared and set properly prior through function call).



[codebox]

float *device_proj;

cufftComplex* kernel;

cufftComplex* twice_image_vect;



int size=2*u_ext;



cudaMalloc(reinterpret_cast<void **>(&device_proj), u_ext*v_ext*sizeof(float));

cudaMemcpy(device_proj, in, u_ext*v_ext*sizeof(float), cudaMemcpyHostToDevice);



cudaMalloc(reinterpret_cast<void **>(&twice_image_vect), size*sizeof(cufftComplex));

cudaMalloc(reinterpret_cast<void **>(&kernel), size*sizeof(cufftComplex));[/codebox]



The error is displayed by VS9 as: First-chance exception at 0x7c812afb in 122209_cufft_test.exe: Microsoft C++ exception: cudaError_enum at memory location 0x0012fa18



Which is to my understanding wrong memory assessment. I am using VS9, Cuda 2.3. and a Quadro FX1700 (I think the card is the problem).



On the other hand, continuing with the program. Assigning values to kernel and doing the FFT returns "good" values, I just don't like the error invocation.



Anyone ever had the same problem???



Thanks for your help,



Sebastian

#1
Posted 12/22/2009 07:19 PM   
Hi,

I have the same problem. Could you fix it?
Hi,



I have the same problem. Could you fix it?

#2
Posted 03/02/2012 03:13 PM   
Scroll To Top