CUDA 4.0 on Win7 x64
Hello, why after cuda toolkit 4.0 (and comput SDK) installation i have no such directories [b]C:/...NVIDIA GPU Computing SDK 4.0\C\common\inc[/b] and so on. So in every manual i see the advices to build cutil_vs2010.sln from [b]C:\ProgramData\NVIDIA Corporation\NVIDIA GPU Computing SDK 4.0\C\common[/b] to solve [i]can't find my cutil64d.lib error[/i], but i just haven't such directory. The same thing with syntax highlighting and usertype.dat. There are no directories where this documents should be.
Hello, why after cuda toolkit 4.0 (and comput SDK) installation i have no such directories C:/...NVIDIA GPU Computing SDK 4.0\C\common\inc and so on. So in every manual i see the advices to build cutil_vs2010.sln from C:\ProgramData\NVIDIA Corporation\NVIDIA GPU Computing SDK 4.0\C\common to solve can't find my cutil64d.lib error, but i just haven't such directory. The same thing with syntax highlighting and usertype.dat. There are no directories where this documents should be.

#1
Posted 08/06/2011 07:49 AM   
The usertype.dat file is located in: "C:\ProgramData\NVIDIA Corporation\NVIDIA GPU Computing SDK 4.0\C\doc\syntax_highlighting\visual_studio_8"

I am also running CUDA 4.0 on Win7 x64. I copied the "usertype.dat" file into the "C:\Program Files (x86)\Microsoft Visual Studio 10.0\Common7\IDE" directory.

You then have to go into Tools--Options--Text Editor--File Extension and add "cu" for Visual C++ in Visual Studio. After you restart your VS you should have syntax highlighting.

Hope this helps!
The usertype.dat file is located in: "C:\ProgramData\NVIDIA Corporation\NVIDIA GPU Computing SDK 4.0\C\doc\syntax_highlighting\visual_studio_8"



I am also running CUDA 4.0 on Win7 x64. I copied the "usertype.dat" file into the "C:\Program Files (x86)\Microsoft Visual Studio 10.0\Common7\IDE" directory.



You then have to go into Tools--Options--Text Editor--File Extension and add "cu" for Visual C++ in Visual Studio. After you restart your VS you should have syntax highlighting.



Hope this helps!

#2
Posted 08/06/2011 04:47 PM   
I think I have the same problem:

Inside my
C:\ProgramData\NVIDIA Corporation
folder is only another folder called "Drs"
Altough, according to most users here there should be a folder called "NVIDIA GPU Computing SDK 4.0"

Thus I do not have (for example) cutil_2010.sln or similar files...

Edit:
_________________________________________________________________

Found out what it was: The Files weren't installed to C:\ProgramData\NVIDIA Corporation\NVIDIA GPU Computing SDK 4.0\ but rather C:\Users\[MyUsername]\AppData\Local\NVIDIA Corporation\NVIDIA GPU Computing SDK 4.0\
I think I have the same problem:



Inside my

C:\ProgramData\NVIDIA Corporation

folder is only another folder called "Drs"

Altough, according to most users here there should be a folder called "NVIDIA GPU Computing SDK 4.0"



Thus I do not have (for example) cutil_2010.sln or similar files...



Edit:

_________________________________________________________________



Found out what it was: The Files weren't installed to C:\ProgramData\NVIDIA Corporation\NVIDIA GPU Computing SDK 4.0\ but rather C:\Users\[MyUsername]\AppData\Local\NVIDIA Corporation\NVIDIA GPU Computing SDK 4.0\

#3
Posted 08/11/2011 12:04 PM   
Scroll To Top