CUDA initialize failure CUDA 4 fails to be initialized each time rebooting
Using Mac OSX 10.7.1 with Mathematica 8. Loaded CUDA 4.0.50 along with suitable CUDA Resources for Mathematica and they works fine.
But each time reboot Mac, CUDA seems to fail to be initialized. Reinstall of Driver fix this temporally, but cannot be initialized again after reboot.
I checked "System/Library/" and found "CUDA.kext" and "CUDA" seem to be missing each in "StartupItems" and "Extensions". It will be very
appreciated if anyone advise me a fix. Thanks
Using Mac OSX 10.7.1 with Mathematica 8. Loaded CUDA 4.0.50 along with suitable CUDA Resources for Mathematica and they works fine.

But each time reboot Mac, CUDA seems to fail to be initialized. Reinstall of Driver fix this temporally, but cannot be initialized again after reboot.

I checked "System/Library/" and found "CUDA.kext" and "CUDA" seem to be missing each in "StartupItems" and "Extensions". It will be very

appreciated if anyone advise me a fix. Thanks

#1
Posted 09/13/2011 04:45 AM   
[quote name='yanch' date='13 September 2011 - 05:45 AM' timestamp='1315889124' post='1292138']
Using Mac OSX 10.7.1 with Mathematica 8. Loaded CUDA 4.0.50 along with suitable CUDA Resources for Mathematica and they works fine.
But each time reboot Mac, CUDA seems to fail to be initialized. Reinstall of Driver fix this temporally, but cannot be initialized again after reboot.
I checked "System/Library/" and found "CUDA.kext" and "CUDA" seem to be missing each in "StartupItems" and "Extensions". It will be very
appreciated if anyone advise me a fix. Thanks
[/quote]

it might be because osx defaults to a low end video card (such as intel) which may not support cuda. you might want to download gfxCardStatus (http://codykrieger.com/gfxCardStatus) and choose to use an NVIDIA card.
[quote name='yanch' date='13 September 2011 - 05:45 AM' timestamp='1315889124' post='1292138']

Using Mac OSX 10.7.1 with Mathematica 8. Loaded CUDA 4.0.50 along with suitable CUDA Resources for Mathematica and they works fine.

But each time reboot Mac, CUDA seems to fail to be initialized. Reinstall of Driver fix this temporally, but cannot be initialized again after reboot.

I checked "System/Library/" and found "CUDA.kext" and "CUDA" seem to be missing each in "StartupItems" and "Extensions". It will be very

appreciated if anyone advise me a fix. Thanks





it might be because osx defaults to a low end video card (such as intel) which may not support cuda. you might want to download gfxCardStatus (http://codykrieger.com/gfxCardStatus) and choose to use an NVIDIA card.

#2
Posted 10/07/2011 02:30 PM   
Thanks for your reply to my "Ask for Help". I found that I misunderstood nature of my problem. All the files etc for CUDA driver and or Resources
are confirmed to be properly installed where they should be. But CUDA.kext is unable to be loaded at each boot time. I posted this in this FORUM
as "Is there any good way to load CUDA.kext at boot". I appreciate if you refer that post and advise me further. Sorry for bother you due to my
insufficient understanding. Thank you very much for your response.
Thanks for your reply to my "Ask for Help". I found that I misunderstood nature of my problem. All the files etc for CUDA driver and or Resources

are confirmed to be properly installed where they should be. But CUDA.kext is unable to be loaded at each boot time. I posted this in this FORUM

as "Is there any good way to load CUDA.kext at boot". I appreciate if you refer that post and advise me further. Sorry for bother you due to my

insufficient understanding. Thank you very much for your response.

#3
Posted 10/10/2011 03:20 AM   
Scroll To Top