Win7 TDR (Driver Timeout Detection & Recovery)
Running Win 7 with latest driver (280.26). Developing cuda algorithms.

Getting Driver Timeout etc. (dont remember getting this with previous driver, same program).

found many discussions online that lead to [url="http://msdn.microsoft.com/en-us/windows/hardware/gg487368.aspx"]http://msdn.microsoft.com/en-us/windows/hardware/gg487368.aspx[/url] which describes registry tweak for XP and Vista.

BUT THE REGISTRY ENTRIES DESCRIBED DO NOT EXIST IN WINDOWS 7 which is what I am running.

Does anyone know how to fix the time delay constant in Win7 ??
Running Win 7 with latest driver (280.26). Developing cuda algorithms.



Getting Driver Timeout etc. (dont remember getting this with previous driver, same program).



found many discussions online that lead to http://msdn.microsoft.com/en-us/windows/hardware/gg487368.aspx which describes registry tweak for XP and Vista.



BUT THE REGISTRY ENTRIES DESCRIBED DO NOT EXIST IN WINDOWS 7 which is what I am running.



Does anyone know how to fix the time delay constant in Win7 ??

#1
Posted 09/14/2011 09:33 PM   
Google for tdrdelay and tdrlevel ... also take a look at this article...

http://forums.nvidia.com/index.php?showtopic=176465
Google for tdrdelay and tdrlevel ... also take a look at this article...



http://forums.nvidia.com/index.php?showtopic=176465

#2
Posted 09/14/2011 09:46 PM   
I ran into this problem a while ago (I'm on win7 too) but instead of disabling the watchdog timer, I changed my algorithm to be ran over multiple kernel invocations instead of doing it all in 1. What manner of application are you running that goes over the timeout limit?
Alternately, if you have another CUDA-enabled card, you could just have it drive your display and have your CUDA card running the computations be headless. This will remove the timeout period on the headless card.

Generally having the display not freeze is pretty nice. I'd propose considering alternative venues for circumventing the display timeout before just outright disabling it
I ran into this problem a while ago (I'm on win7 too) but instead of disabling the watchdog timer, I changed my algorithm to be ran over multiple kernel invocations instead of doing it all in 1. What manner of application are you running that goes over the timeout limit?

Alternately, if you have another CUDA-enabled card, you could just have it drive your display and have your CUDA card running the computations be headless. This will remove the timeout period on the headless card.



Generally having the display not freeze is pretty nice. I'd propose considering alternative venues for circumventing the display timeout before just outright disabling it

#3
Posted 09/14/2011 09:52 PM   
jpaulorio & alrikai
--thanks for the quick response.
* I think what the guys are saying is that even though those entries dont exist in the Win7 registry that one should go ahead and enter them anyway?
* I did go the route of reducing the size of the data set; helped somewhat. thing is i didnt get these timeouts in previous driver.
* I do have a 2nd graphics board to add; i had it in a while back but was getting system freezes and cuda runtime nonsense so i pulled the second board without troubleshooting why. i may have to revisit.
* i have a posting on MS win 7 forum; i will see what they can say
jpaulorio & alrikai

--thanks for the quick response.

* I think what the guys are saying is that even though those entries dont exist in the Win7 registry that one should go ahead and enter them anyway?

* I did go the route of reducing the size of the data set; helped somewhat. thing is i didnt get these timeouts in previous driver.

* I do have a 2nd graphics board to add; i had it in a while back but was getting system freezes and cuda runtime nonsense so i pulled the second board without troubleshooting why. i may have to revisit.

* i have a posting on MS win 7 forum; i will see what they can say

#4
Posted 09/14/2011 10:18 PM   
I've just resolved this issue on my work PC - was getting driver Timeout and Detection Recovery when logging on to my work PC remotely, probably because of the longer response times for the GPU to update when using the remote connection.

I did the following to resolve it:

Resolve Timeout Detection and Recovery - WINDOWS 7 (32/64 bit)

Create a registry key in Windows to change the TDR settings to a higher amount, so that
Windows will allow for a longer delay before TDR process starts.

Open Regedit from Run or DOS.

In Windows 7 navigate to the correct registry key area, to create the new key:

HKEY_LOCAL_MACHINE>SYSTEM>CurrentControlSet>Control>GraphicsDrivers.

There will probably one key in there called DxgKrnlVersion there as a DWord.

Right click and select to create a new key REG_DWORD, and name it TdrDelay. The value assigned to it is the number
of seconds before TDR kicks in - it is currently 2 automatically in Windows (even though the reg. key value
doesn't exist until you create it). Assign it with a new value (I tried 4
seconds), which doubles the time before TDR. Then restart PC. You need to restart the PC before the value will work.
I've just resolved this issue on my work PC - was getting driver Timeout and Detection Recovery when logging on to my work PC remotely, probably because of the longer response times for the GPU to update when using the remote connection.



I did the following to resolve it:



Resolve Timeout Detection and Recovery - WINDOWS 7 (32/64 bit)



Create a registry key in Windows to change the TDR settings to a higher amount, so that

Windows will allow for a longer delay before TDR process starts.



Open Regedit from Run or DOS.



In Windows 7 navigate to the correct registry key area, to create the new key:



HKEY_LOCAL_MACHINE>SYSTEM>CurrentControlSet>Control>GraphicsDrivers.



There will probably one key in there called DxgKrnlVersion there as a DWord.



Right click and select to create a new key REG_DWORD, and name it TdrDelay. The value assigned to it is the number

of seconds before TDR kicks in - it is currently 2 automatically in Windows (even though the reg. key value

doesn't exist until you create it). Assign it with a new value (I tried 4

seconds), which doubles the time before TDR. Then restart PC. You need to restart the PC before the value will work.

#5
Posted 09/17/2011 05:59 PM   
Scroll To Top