[BEGINNER] CUDA under QtCreator
Hi!

I have to use CUDA in my scientific work but my project is already written under QtCreator.
I added .cu files to the project but now cannot build it.
Could you please answer, how can I do it? What files should I configure?
Asking Google didn't bring me any success (the most given info is for linux). I installed drivers, CUDA Toolkit and CUDA SDK from the official site. After that I wrote a simple program which performs the addition of two vectors (wothout QT, in a notepad++), launched it with a command prompt - and it worked. So, as I can see, the problem is in QtCreator configuration.

Please, help. It is very important for me.

P.S. My OS is Windows 7 (topic is here because I didn't find Win 7 forum), Graphic Card is GeForce GTS 450.
And sorry for bad English)))
Hi!



I have to use CUDA in my scientific work but my project is already written under QtCreator.

I added .cu files to the project but now cannot build it.

Could you please answer, how can I do it? What files should I configure?

Asking Google didn't bring me any success (the most given info is for linux). I installed drivers, CUDA Toolkit and CUDA SDK from the official site. After that I wrote a simple program which performs the addition of two vectors (wothout QT, in a notepad++), launched it with a command prompt - and it worked. So, as I can see, the problem is in QtCreator configuration.



Please, help. It is very important for me.



P.S. My OS is Windows 7 (topic is here because I didn't find Win 7 forum), Graphic Card is GeForce GTS 450.

And sorry for bad English)))

#1
Posted 01/12/2012 02:42 PM   
Hi!

I have to use CUDA in my scientific work but my project is already written under QtCreator.
I added .cu files to the project but now cannot build it.
Could you please answer, how can I do it? What files should I configure?
Asking Google didn't bring me any success (the most given info is for linux). I installed drivers, CUDA Toolkit and CUDA SDK from the official site. After that I wrote a simple program which performs the addition of two vectors (wothout QT, in a notepad++), launched it with a command prompt - and it worked. So, as I can see, the problem is in QtCreator configuration.

Please, help. It is very important for me.

P.S. My OS is Windows 7 (topic is here because I didn't find Win 7 forum), Graphic Card is GeForce GTS 450.
And sorry for bad English)))
Hi!



I have to use CUDA in my scientific work but my project is already written under QtCreator.

I added .cu files to the project but now cannot build it.

Could you please answer, how can I do it? What files should I configure?

Asking Google didn't bring me any success (the most given info is for linux). I installed drivers, CUDA Toolkit and CUDA SDK from the official site. After that I wrote a simple program which performs the addition of two vectors (wothout QT, in a notepad++), launched it with a command prompt - and it worked. So, as I can see, the problem is in QtCreator configuration.



Please, help. It is very important for me.



P.S. My OS is Windows 7 (topic is here because I didn't find Win 7 forum), Graphic Card is GeForce GTS 450.

And sorry for bad English)))

#2
Posted 01/12/2012 02:42 PM   
Scroll To Top