linking to cublas.lib makes everything crash
I am working on a fairly large project.
I have cuda 4.0
I am trying to use cublas but every time I link with cublas.lib any cuda call makes the program crash.
I get cudaError_enum at memory location 0x1011c360.

The little sdk example works just fine.
My GPU device has 16 Multi-Processors, SM 1.1 compute capabilities.
I have tried everything and run out of ideas.



Thanks
I am working on a fairly large project.

I have cuda 4.0

I am trying to use cublas but every time I link with cublas.lib any cuda call makes the program crash.

I get cudaError_enum at memory location 0x1011c360.



The little sdk example works just fine.

My GPU device has 16 Multi-Processors, SM 1.1 compute capabilities.

I have tried everything and run out of ideas.







Thanks

#1
Posted 01/19/2012 02:19 AM   
I just ran into the same problem. Unfortunately also I ran out of ideas =/
But maybe I can clarify that (at least for me) any call to cudaMalloc will cause the cudaError_enum-exception when linking with cublas.lib (and using at least a single function to it in the code such as cublas-context-creation, which doesn't even need to be executed).
When not linking against cublas.lib everything runs like a charm.

I'm compiling a 32bit binary, have the 32bit CUDA Toolkit 4.1 and use the 64bit driver on a 64bit win7.
I just ran into the same problem. Unfortunately also I ran out of ideas =/

But maybe I can clarify that (at least for me) any call to cudaMalloc will cause the cudaError_enum-exception when linking with cublas.lib (and using at least a single function to it in the code such as cublas-context-creation, which doesn't even need to be executed).

When not linking against cublas.lib everything runs like a charm.



I'm compiling a 32bit binary, have the 32bit CUDA Toolkit 4.1 and use the 64bit driver on a 64bit win7.

#2
Posted 02/19/2012 08:14 PM   
[quote name='xortdsc' date='19 February 2012 - 10:14 PM' timestamp='1329682479' post='1371482']
I just ran into the same problem. Unfortunately also I ran out of ideas =/
But maybe I can clarify that (at least for me) any call to cudaMalloc will cause the cudaError_enum-exception when linking with cublas.lib (and using at least a single function to it in the code such as cublas-context-creation, which doesn't even need to be executed).
When not linking against cublas.lib everything runs like a charm.

I'm compiling a 32bit binary, have the 32bit CUDA Toolkit 4.1 and use the 64bit driver on a 64bit win7.
[/quote]

i think i "solved" the problem by not taking FCE seriously anymore. i had a situation where cudaMalloc was returning NULL as well, but i cannot repro anymore. seems to work fine now...
[quote name='xortdsc' date='19 February 2012 - 10:14 PM' timestamp='1329682479' post='1371482']

I just ran into the same problem. Unfortunately also I ran out of ideas =/

But maybe I can clarify that (at least for me) any call to cudaMalloc will cause the cudaError_enum-exception when linking with cublas.lib (and using at least a single function to it in the code such as cublas-context-creation, which doesn't even need to be executed).

When not linking against cublas.lib everything runs like a charm.



I'm compiling a 32bit binary, have the 32bit CUDA Toolkit 4.1 and use the 64bit driver on a 64bit win7.





i think i "solved" the problem by not taking FCE seriously anymore. i had a situation where cudaMalloc was returning NULL as well, but i cannot repro anymore. seems to work fine now...

#3
Posted 02/21/2012 12:26 AM   
I have the same problem, when I try to use any cublas function(in my cod taht I wrote in SDK template)my code crash and no longer works, vs when I try to use CUDA kernels in one of my code which contains cublas function( I wrote it in SDK simplecublas) and works well, again it crash and there is a link error.
Does anyone know what I have to do?
I have the same problem, when I try to use any cublas function(in my cod taht I wrote in SDK template)my code crash and no longer works, vs when I try to use CUDA kernels in one of my code which contains cublas function( I wrote it in SDK simplecublas) and works well, again it crash and there is a link error.

Does anyone know what I have to do?

#4
Posted 06/12/2012 12:21 AM   
Scroll To Top