No CUDA on EVGA 460 GTX 2WIN? Unable to find cuda device with EVGA 460 GTX 2WIN???
Hello,

I recently upgraded my graphic card to EVGA 460 GTX 2WIN, but my program can not find any CUDA devices now. I've swapped my old 250 card back in and it can recognise it, so clearly it's a problem with the card. My motherboard does support SLI, so that's not the problem. Anyone have a clue what's going on? Also nvidia-settings does see not the second GPU.


Here's what lspci gives me:
[code]01:00.0 PCI bridge: nVidia Corporation NF200 PCIe 2.0 switch for Quadro Plex S4 / Tesla S870 / Tesla S1070 / Tesla S2050 (rev a3)
02:00.0 PCI bridge: nVidia Corporation NF200 PCIe 2.0 switch for Quadro Plex S4 / Tesla S870 / Tesla S1070 / Tesla S2050 (rev a3)
02:02.0 PCI bridge: nVidia Corporation NF200 PCIe 2.0 switch for Quadro Plex S4 / Tesla S870 / Tesla S1070 / Tesla S2050 (rev a3)
03:00.0 VGA compatible controller: nVidia Corporation GF104 [GeForce GTX 460] (rev a1)
03:00.1 Audio device: nVidia Corporation GF104 High Definition Audio Controller (rev a1)
04:00.0 VGA compatible controller: nVidia Corporation GF104 [GeForce GTX 460] (rev a1)
04:00.1 Audio device: nVidia Corporation GF104 High Definition Audio Controller (rev a1)[/code]

Here's what I have for my xorg.conf:
[code]Section "Monitor"

# HorizSync source: edid, VertRefresh source: edid
Identifier "Monitor0"
VendorName "Unknown"
ModelName "DELL 2005FPW"
HorizSync 30.0 - 83.0
VertRefresh 56.0 - 75.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce GTX 460"
EndSection

Section "Device"
Identifier "Device1"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce GTX 460"
BusID "PCI:3:0:0"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "TwinView" "0"
Option "metamodes" "nvidia-auto-select +0+0"
Option "SLI" "On"
SubSection "Display"
Depth 24
EndSubSection
EndSection[/code]

A few more things to note about my xorg.conf. Adding BusID to device 0 causes xorg to fail and go to terminal. I've tried swapping between PCI 3 and 4 and device 0 and 1 with no luck.
Hello,



I recently upgraded my graphic card to EVGA 460 GTX 2WIN, but my program can not find any CUDA devices now. I've swapped my old 250 card back in and it can recognise it, so clearly it's a problem with the card. My motherboard does support SLI, so that's not the problem. Anyone have a clue what's going on? Also nvidia-settings does see not the second GPU.





Here's what lspci gives me:

01:00.0 PCI bridge: nVidia Corporation NF200 PCIe 2.0 switch for Quadro Plex S4 / Tesla S870 / Tesla S1070 / Tesla S2050 (rev a3)

02:00.0 PCI bridge: nVidia Corporation NF200 PCIe 2.0 switch for Quadro Plex S4 / Tesla S870 / Tesla S1070 / Tesla S2050 (rev a3)

02:02.0 PCI bridge: nVidia Corporation NF200 PCIe 2.0 switch for Quadro Plex S4 / Tesla S870 / Tesla S1070 / Tesla S2050 (rev a3)

03:00.0 VGA compatible controller: nVidia Corporation GF104 [GeForce GTX 460] (rev a1)

03:00.1 Audio device: nVidia Corporation GF104 High Definition Audio Controller (rev a1)

04:00.0 VGA compatible controller: nVidia Corporation GF104 [GeForce GTX 460] (rev a1)

04:00.1 Audio device: nVidia Corporation GF104 High Definition Audio Controller (rev a1)




Here's what I have for my xorg.conf:

Section "Monitor"



# HorizSync source: edid, VertRefresh source: edid

Identifier "Monitor0"

VendorName "Unknown"

ModelName "DELL 2005FPW"

HorizSync 30.0 - 83.0

VertRefresh 56.0 - 75.0

Option "DPMS"

EndSection



Section "Device"

Identifier "Device0"

Driver "nvidia"

VendorName "NVIDIA Corporation"

BoardName "GeForce GTX 460"

EndSection



Section "Device"

Identifier "Device1"

Driver "nvidia"

VendorName "NVIDIA Corporation"

BoardName "GeForce GTX 460"

BusID "PCI:3:0:0"

EndSection



Section "Screen"

Identifier "Screen0"

Device "Device0"

Monitor "Monitor0"

DefaultDepth 24

Option "TwinView" "0"

Option "metamodes" "nvidia-auto-select +0+0"

Option "SLI" "On"

SubSection "Display"

Depth 24

EndSubSection

EndSection




A few more things to note about my xorg.conf. Adding BusID to device 0 causes xorg to fail and go to terminal. I've tried swapping between PCI 3 and 4 and device 0 and 1 with no luck.

#1
Posted 01/28/2012 04:59 AM   
What does "ls -l /dev/nvidia*" show?
What does "ls -l /dev/nvidia*" show?

#2
Posted 01/28/2012 08:01 PM   
Try updating the driver - it may be too old to support the GTX 460.
Try updating the driver - it may be too old to support the GTX 460.

Always check return codes of CUDA calls for errors. Do not use __syncthreads() in conditional code unless the condition is guaranteed to evaluate identically for all threads of each block. Run your program under cuda-memcheck to detect stray memory accesses. If your kernel dies for larger problem sizes, it might exceed the runtime limit and trigger the watchdog timer.

#3
Posted 01/28/2012 08:34 PM   
[quote name='seibert' date='28 January 2012 - 08:01 PM' timestamp='1327780891' post='1361961']
What does "ls -l /dev/nvidia*" show?
[/quote]

Can't find it:
[code]$ ls -l /dev/nvidia
ls: cannot access /dev/nvidia: No such file or directory
[/code]
But there is:
[code]$ ls -l /dev/nvidia0
crw-rw-rw- 1 root root 195, 0 2012-01-28 16:33 /dev/nvidia0
$ ls -l /dev/nvidia1
crw-rw-rw- 1 root root 195, 1 2012-01-28 16:33 /dev/nvidia1
$ ls -l /dev/nvidiactl
crw-rw-rw- 1 root root 195, 255 2012-01-28 16:33 /dev/nvidiactl
[/code]

Looks like you may be on to something, but I don't know how to get nvidia0 & nvidia1 to just nvidia


[quote name='tera' date='28 January 2012 - 08:34 PM' timestamp='1327782868' post='1361974']
Try updating the driver - it may be too old to support the GTX 460.
[/quote]

Did that:
file: devdriver_4.1_linux_32_285.05.32.run
[quote name='seibert' date='28 January 2012 - 08:01 PM' timestamp='1327780891' post='1361961']

What does "ls -l /dev/nvidia*" show?





Can't find it:

$ ls -l /dev/nvidia

ls: cannot access /dev/nvidia: No such file or directory


But there is:

$ ls -l /dev/nvidia0

crw-rw-rw- 1 root root 195, 0 2012-01-28 16:33 /dev/nvidia0

$ ls -l /dev/nvidia1

crw-rw-rw- 1 root root 195, 1 2012-01-28 16:33 /dev/nvidia1

$ ls -l /dev/nvidiactl

crw-rw-rw- 1 root root 195, 255 2012-01-28 16:33 /dev/nvidiactl




Looks like you may be on to something, but I don't know how to get nvidia0 & nvidia1 to just nvidia





[quote name='tera' date='28 January 2012 - 08:34 PM' timestamp='1327782868' post='1361974']

Try updating the driver - it may be too old to support the GTX 460.





Did that:

file: devdriver_4.1_linux_32_285.05.32.run

#4
Posted 01/29/2012 12:43 AM   
Solved!

Thanks for the big hint seibert!

I googled /dev/nvidia and came across this:
http://ubuntuforums.org/showthread.php?t=1684460

Anyway for those having the same problem, short answer is:

sudo gedit /etc/default/grub

and edit GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" to GRUB_CMDLINE_LINUX_DEFAULT="quiet splash vmalloc=256M"
Solved!



Thanks for the big hint seibert!



I googled /dev/nvidia and came across this:

http://ubuntuforums.org/showthread.php?t=1684460



Anyway for those having the same problem, short answer is:



sudo gedit /etc/default/grub



and edit GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" to GRUB_CMDLINE_LINUX_DEFAULT="quiet splash vmalloc=256M"

#5
Posted 01/29/2012 01:14 AM   
Scroll To Top