Gnome-shell crash error in libnvidia-tls.so
Hi all

I have a bug with debian SID. I use gnome-shell but when i want search an application gnome-shell crash. In /var/log/syslog i have :

[quote]Feb 18 12:28:13 debian kernel: [ 6663.486863] gnome-shell[4533]: segfault at 10 ip 00007f2afd693c0f sp 00007f2ad4df4658 error 6 in libnvidia-tls.so.295.20[7f2afd693000+3000]

Feb 18 12:28:13 debian gnome-session[2540]: WARNING: Application 'gnome-shell.desktop' killed by signal[/quote]

i use debian sid and propriotary driver nvidia with my nvidia geforce 9600gt


[quote]Paquet : nvidia-glx
Nouveau: oui
État: installé
Automatiquement installé: non
Version : 295.20-1
Priorité : optionnel
Section : non-free/x11
Responsable : Debian NVIDIA Maintainers <pkg-nvidia-devel@lists.alioth.debian.org>
Taille décompressée : 824 k
Dépend: libgl1-nvidia-glx (= 295.20-1), xserver-xorg-video-nvidia (= 295.20-1), nvidia-vdpau-driver (= 295.20-1), nvidia-alternative (=
295.20-1), nvidia-kernel-295.20, nvidia-support
Pré-dépend: dpkg (>= 1.15.7.2), nvidia-installer-cleanup
Suggère: nvidia-settings, nvidia-kernel-dkms (>= 295.20) | nvidia-kernel-source (>= 295.20)
Fournit: nvidia-glx-any
[/quote]

[quote]Paquet : nvidia-settings
Nouveau: oui
État: installé
Automatiquement installé: non
Version : 295.20-1
Priorité : optionnel
Section : contrib/x11
Responsable : Debian NVIDIA Maintainers <pkg-nvidia-devel@lists.alioth.debian.org>
Taille décompressée : 1 845 k
Dépend: pkg-config, libc6 (>= 2.7), libgdk-pixbuf2.0-0 (>= 2.22.0), libglib2.0-0 (>= 2.12.0), libgtk2.0-0 (>= 2.8.0), libpango1.0-0 (>=
1.14.0), libx11-6, libxext6, libxxf86vm1
Pré-dépend: nvidia-installer-cleanup
Recommande: libgl1-nvidia-glx-any
Description : Tool for configuring the NVIDIA graphics driver
The nvidia-settings utility is a tool for configuring the NVIDIA Linux graphics driver. It operates by communicating with the NVIDIA X
driver, querying and updating state as appropriate. This communication is done with the NV-CONTROL X extension.

[/quote]

[quote]Paquet : nvidia-kernel-dkms
Nouveau: oui
État: installé
Automatiquement installé: oui
Version : 295.20-1
Priorité : optionnel
Section : non-free/kernel
Responsable : Debian NVIDIA Maintainers <pkg-nvidia-devel@lists.alioth.debian.org>
Taille décompressée : 30,1 M
Dépend: dkms (>= 2.1.0.0), nvidia-kernel-common (>= 20110213)
Pré-dépend: nvidia-installer-cleanup
Recommande: nvidia-glx (>= 295.20)
Est en conflit: nvidia-kernel-dkms
Casse: make (= 3.82-1)
Fournit: nvidia-kernel-295.20
Fourni par : nvidia-kernel-legacy-173xx-dkms, nvidia-kernel-legacy-71xx-dkms, nvidia-kernel-legacy-96xx-dkms
Description : NVIDIA binary kernel module DKMS source
This package builds the NVIDIA Xorg binary kernel module needed by nvidia-glx, using DKMS. Provided that you have the kernel header
packages installed, the kernel module will be built for your running kernel and automatically rebuilt for any new kernel headers that are
installed. The NVIDIA binary drivers provide optimized hardware acceleration of OpenGL applications via a direct-rendering X Server for
graphics cards using NVIDIA chip sets. AGP, PCIe, SLI, TV-out and flat panel displays are also supported.

This version only supports GeForce 6xxx and higher of the Geforce GPUs plus complimentary Quadros and nforce. Look at the legacy packages
for older cards.
[/quote]

[quote]Paquet : gnome-desktop-environment
État: installé
Automatiquement installé: non
Version : 1:3.0+7
Priorité : optionnel
Section : gnome
Responsable : Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>
Taille décompressée : 43,0 k
Dépend: gnome (>= 1:3.0+7)
Description : The GNOME Desktop Environment - transitional package
This is the GNOME Desktop environment, an intuitive and attractive desktop.

This meta-package is obsolete and has been replaced by “gnome”.
[/quote]

[quote]Paquet : gnome-desktop-data
État: installé
Automatiquement installé: non
Version : 2.32.1-1
Priorité : optionnel
Section : gnome
Responsable : Josselin Mouette <joss@debian.org>
Taille décompressée : 3 830 k
Description : Common files for GNOME desktop apps
This package includes some files that are shared between several GNOME apps (Pixmaps, .desktop files and internationalization files).

[/quote]

someone can help me please ?

Thank you /wink.gif' class='bbc_emoticon' alt=';)' />
Hi all



I have a bug with debian SID. I use gnome-shell but when i want search an application gnome-shell crash. In /var/log/syslog i have :



Feb 18 12:28:13 debian kernel: [ 6663.486863] gnome-shell[4533]: segfault at 10 ip 00007f2afd693c0f sp 00007f2ad4df4658 error 6 in libnvidia-tls.so.295.20[7f2afd693000+3000]



Feb 18 12:28:13 debian gnome-session[2540]: WARNING: Application 'gnome-shell.desktop' killed by signal




i use debian sid and propriotary driver nvidia with my nvidia geforce 9600gt





Paquet : nvidia-glx

Nouveau: oui

État: installé

Automatiquement installé: non

Version : 295.20-1

Priorité : optionnel

Section : non-free/x11

Responsable : Debian NVIDIA Maintainers <pkg-nvidia-devel@lists.alioth.debian.org>

Taille décompressée : 824 k

Dépend: libgl1-nvidia-glx (= 295.20-1), xserver-xorg-video-nvidia (= 295.20-1), nvidia-vdpau-driver (= 295.20-1), nvidia-alternative (=

295.20-1), nvidia-kernel-295.20, nvidia-support

Pré-dépend: dpkg (>= 1.15.7.2), nvidia-installer-cleanup

Suggère: nvidia-settings, nvidia-kernel-dkms (>= 295.20) | nvidia-kernel-source (>= 295.20)

Fournit: nvidia-glx-any





Paquet : nvidia-settings

Nouveau: oui

État: installé

Automatiquement installé: non

Version : 295.20-1

Priorité : optionnel

Section : contrib/x11

Responsable : Debian NVIDIA Maintainers <pkg-nvidia-devel@lists.alioth.debian.org>

Taille décompressée : 1 845 k

Dépend: pkg-config, libc6 (>= 2.7), libgdk-pixbuf2.0-0 (>= 2.22.0), libglib2.0-0 (>= 2.12.0), libgtk2.0-0 (>= 2.8.0), libpango1.0-0 (>=

1.14.0), libx11-6, libxext6, libxxf86vm1

Pré-dépend: nvidia-installer-cleanup

Recommande: libgl1-nvidia-glx-any

Description : Tool for configuring the NVIDIA graphics driver

The nvidia-settings utility is a tool for configuring the NVIDIA Linux graphics driver. It operates by communicating with the NVIDIA X

driver, querying and updating state as appropriate. This communication is done with the NV-CONTROL X extension.







Paquet : nvidia-kernel-dkms

Nouveau: oui

État: installé

Automatiquement installé: oui

Version : 295.20-1

Priorité : optionnel

Section : non-free/kernel

Responsable : Debian NVIDIA Maintainers <pkg-nvidia-devel@lists.alioth.debian.org>

Taille décompressée : 30,1 M

Dépend: dkms (>= 2.1.0.0), nvidia-kernel-common (>= 20110213)

Pré-dépend: nvidia-installer-cleanup

Recommande: nvidia-glx (>= 295.20)

Est en conflit: nvidia-kernel-dkms

Casse: make (= 3.82-1)

Fournit: nvidia-kernel-295.20

Fourni par : nvidia-kernel-legacy-173xx-dkms, nvidia-kernel-legacy-71xx-dkms, nvidia-kernel-legacy-96xx-dkms

Description : NVIDIA binary kernel module DKMS source

This package builds the NVIDIA Xorg binary kernel module needed by nvidia-glx, using DKMS. Provided that you have the kernel header

packages installed, the kernel module will be built for your running kernel and automatically rebuilt for any new kernel headers that are

installed. The NVIDIA binary drivers provide optimized hardware acceleration of OpenGL applications via a direct-rendering X Server for

graphics cards using NVIDIA chip sets. AGP, PCIe, SLI, TV-out and flat panel displays are also supported.



This version only supports GeForce 6xxx and higher of the Geforce GPUs plus complimentary Quadros and nforce. Look at the legacy packages

for older cards.





Paquet : gnome-desktop-environment

État: installé

Automatiquement installé: non

Version : 1:3.0+7

Priorité : optionnel

Section : gnome

Responsable : Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>

Taille décompressée : 43,0 k

Dépend: gnome (>= 1:3.0+7)

Description : The GNOME Desktop Environment - transitional package

This is the GNOME Desktop environment, an intuitive and attractive desktop.



This meta-package is obsolete and has been replaced by “gnome”.





Paquet : gnome-desktop-data

État: installé

Automatiquement installé: non

Version : 2.32.1-1

Priorité : optionnel

Section : gnome

Responsable : Josselin Mouette <joss@debian.org>

Taille décompressée : 3 830 k

Description : Common files for GNOME desktop apps

This package includes some files that are shared between several GNOME apps (Pixmaps, .desktop files and internationalization files).







someone can help me please ?



Thank you /wink.gif' class='bbc_emoticon' alt=';)' />

#1
Posted 02/18/2012 11:43 AM   
Confirmed, I'm seeing the same on Gentoo ~amd64. gnome-shell 3.2.2.1 crashes while doing a search with nvidia-drivers 295.20 installed (backtrace is in libnvidia-tls.so). Downgrading to nvidia-drivers 290.10 resolves the issue, so it is a problem with the drivers.

GPU info:
[ 22.309] (II) NVIDIA(0): NVIDIA GPU GeForce GTX 570 (GF110) at PCI:3:0:0 (GPU-0)
[ 22.309] (--) NVIDIA(0): Memory: 1310720 kBytes
[ 22.309] (II) NVIDIA(0): Board ID: 0xd00f
[ 22.309] (II) NVIDIA(0): Chip SKU: 275
[ 22.309] (II) NVIDIA(0): Chip SKU Mod: 0
[ 22.309] (II) NVIDIA(0): Project: 1261
[ 22.309] (II) NVIDIA(0): Project SKU: 0005
[ 22.309] (II) NVIDIA(0): GPU RAM Type: GDDR5
[ 22.309] (--) NVIDIA(0): VideoBIOS: 70.10.17.00.70
Confirmed, I'm seeing the same on Gentoo ~amd64. gnome-shell 3.2.2.1 crashes while doing a search with nvidia-drivers 295.20 installed (backtrace is in libnvidia-tls.so). Downgrading to nvidia-drivers 290.10 resolves the issue, so it is a problem with the drivers.



GPU info:

[ 22.309] (II) NVIDIA(0): NVIDIA GPU GeForce GTX 570 (GF110) at PCI:3:0:0 (GPU-0)

[ 22.309] (--) NVIDIA(0): Memory: 1310720 kBytes

[ 22.309] (II) NVIDIA(0): Board ID: 0xd00f

[ 22.309] (II) NVIDIA(0): Chip SKU: 275

[ 22.309] (II) NVIDIA(0): Chip SKU Mod: 0

[ 22.309] (II) NVIDIA(0): Project: 1261

[ 22.309] (II) NVIDIA(0): Project SKU: 0005

[ 22.309] (II) NVIDIA(0): GPU RAM Type: GDDR5

[ 22.309] (--) NVIDIA(0): VideoBIOS: 70.10.17.00.70

#2
Posted 02/22/2012 07:44 AM   
have you the steps for downgrade please ?
have you the steps for downgrade please ?

#3
Posted 02/22/2012 10:12 PM   
I don't see a direct connection with CUDA (at least I don't recognize libnvidia-tls.so as part of the CUDA SW stack), but it seems like there may be a problem with the Linux display driver, so I would suggest filing a bug.
I don't see a direct connection with CUDA (at least I don't recognize libnvidia-tls.so as part of the CUDA SW stack), but it seems like there may be a problem with the Linux display driver, so I would suggest filing a bug.

#4
Posted 02/22/2012 10:54 PM   
i'm sorry but i didn't know where to post my topic.

because i'm french and i didn't find "bug" forum.
i'm sorry but i didn't know where to post my topic.



because i'm french and i didn't find "bug" forum.

#5
Posted 02/22/2012 11:31 PM   
CUDA bugs can be reported via the form linked from the starting page of the registered developer website, partners.nvidia.com. I am not familiar with the process of filing bugs against the display driver. Maybe a helpful forum participant can provide a pointer.
CUDA bugs can be reported via the form linked from the starting page of the registered developer website, partners.nvidia.com. I am not familiar with the process of filing bugs against the display driver. Maybe a helpful forum participant can provide a pointer.

#6
Posted 02/23/2012 09:38 AM   
Scroll To Top