Suggest a CUDA version Please suggest a CUDA development version for my computer
I have a Sony VAIO VPCCW15FG 64 bit laptop which has a GPU NVIDIA GeForce 210M. Somebody please suggest a suitable CUDA version for my system. I have downloaded and installed CUDA Development Environment 2.3 (driver, sdk and toolkit), the installation went well, but when I try to execute any of the sample programs, I'm getting into a crash ("Application has stopped working"). Why is this ?? Somebody please help...
I have a Sony VAIO VPCCW15FG 64 bit laptop which has a GPU NVIDIA GeForce 210M. Somebody please suggest a suitable CUDA version for my system. I have downloaded and installed CUDA Development Environment 2.3 (driver, sdk and toolkit), the installation went well, but when I try to execute any of the sample programs, I'm getting into a crash ("Application has stopped working"). Why is this ?? Somebody please help...
Attachments

problem.png

#1
Posted 05/05/2012 01:32 PM   
Hello,

You should always install the latest video drivers and the latest cuda toolkit. Is the deviceQuery working?
Hello,



You should always install the latest video drivers and the latest cuda toolkit. Is the deviceQuery working?

#2
Posted 05/05/2012 04:26 PM   
[quote name='pasoleatis' date='05 May 2012 - 09:56 PM' timestamp='1336235165' post='1404638']
Hello,

You should always install the latest video drivers and the latest cuda toolkit. Is the deviceQuery working?
[/quote]

I have come to know that a version that is compatible to the GPU must be installed, my GPU is of compute capability of only 1.2, and the driver of any greater versions are not being installed too.. And sorry, since I am new to CUDA, what is deviceQuery..??
[quote name='pasoleatis' date='05 May 2012 - 09:56 PM' timestamp='1336235165' post='1404638']

Hello,



You should always install the latest video drivers and the latest cuda toolkit. Is the deviceQuery working?





I have come to know that a version that is compatible to the GPU must be installed, my GPU is of compute capability of only 1.2, and the driver of any greater versions are not being installed too.. And sorry, since I am new to CUDA, what is deviceQuery..??

#3
Posted 05/05/2012 11:56 PM   
Not true. Cudatoolkit 4.2 supports all devices. I can tell you from my experience. I had toolkit 4.0 with device of cc 1.2 and had no problems. The deviceQuery is an example which is included in the SDK.
Not true. Cudatoolkit 4.2 supports all devices. I can tell you from my experience. I had toolkit 4.0 with device of cc 1.2 and had no problems. The deviceQuery is an example which is included in the SDK.

#4
Posted 05/06/2012 09:09 AM   
[quote name='pasoleatis' date='06 May 2012 - 02:39 PM' timestamp='1336295383' post='1404836']
Not true. Cudatoolkit 4.2 supports all devices. I can tell you from my experience. I had toolkit 4.0 with device of cc 1.2 and had no problems. The deviceQuery is an example which is included in the SDK.
[/quote]
I so what about the driver, when trying to install the driver with toolkit 4.0 I'm getting a "No compatible hardware found" error, cannot continue installation.
[quote name='pasoleatis' date='06 May 2012 - 02:39 PM' timestamp='1336295383' post='1404836']

Not true. Cudatoolkit 4.2 supports all devices. I can tell you from my experience. I had toolkit 4.0 with device of cc 1.2 and had no problems. The deviceQuery is an example which is included in the SDK.



I so what about the driver, when trying to install the driver with toolkit 4.0 I'm getting a "No compatible hardware found" error, cannot continue installation.

#5
Posted 05/06/2012 11:51 AM   
You have to install the latest nvidia gpu driver as well, then the latest cudatoolkit.


When you compile the programs you have to specify the compute capability of your card.
You have to install the latest nvidia gpu driver as well, then the latest cudatoolkit.





When you compile the programs you have to specify the compute capability of your card.

#6
Posted 05/06/2012 04:42 PM   
Scroll To Top