Where is "50 Hz over VGA" Support on Linux ?
hello Using a normal Flat CRT Monitor " Hyundai X96 WA " via VGA , that supports maximal resolution of 1366 768 @60 HZ in case to get free flickering videos of some mpeg2 DVB Streams via vdpau Temporal . System Ubuntu 12.04 Kernel-3.5.0-19 32 Bits Proprietary Nvidia 310.19 geforce 210 1 GB My Question : How to configure xorg.conf to get : 1366 768 @ 50 Hz xrandr output : Screen 0: minimum 8 x 8, current 1366 x 768, maximum 8192 x 8192 DVI-I-0 disconnected (normal left inverted right x axis y axis) VGA-0 connected 1366x768+0+0 (normal left inverted right x axis y axis) 430mm x 255mm 1366x768 59.8*+ 1280x720 60.0 1024x768 75.0 60.0 800x600 75.0 60.3 640x480 75.0 59.9 DVI-I-1 disconnected (normal left inverted right x axis y axis) HDMI-0 disconnected (normal left inverted right x axis y axis) Thank You .
hello
Using a normal Flat CRT Monitor " Hyundai X96 WA " via VGA , that supports maximal resolution of 1366 768 @60 HZ in case to get free flickering videos of some mpeg2 DVB Streams via vdpau Temporal .

System Ubuntu 12.04 Kernel-3.5.0-19 32 Bits
Proprietary Nvidia 310.19
geforce 210 1 GB

My Question :
How to configure xorg.conf to get : 1366 768 @ 50 Hz

xrandr output :
Screen 0: minimum 8 x 8, current 1366 x 768, maximum 8192 x 8192
DVI-I-0 disconnected (normal left inverted right x axis y axis)
VGA-0 connected 1366x768+0+0 (normal left inverted right x axis y axis) 430mm x 255mm
1366x768 59.8*+
1280x720 60.0
1024x768 75.0 60.0
800x600 75.0 60.3
640x480 75.0 59.9
DVI-I-1 disconnected (normal left inverted right x axis y axis)
HDMI-0 disconnected (normal left inverted right x axis y axis)


Thank You .

#1
Posted 11/27/2012 01:59 PM   
Your monitor doesn't support a 1366x768 @ 50 Hz mode in its EDID, so you're going to have to add one using the ModeLine option in /etc/X11/xorg.conf. Please see the xorg.conf man page and the man page for the "gtf" program for information on how to do that. Your custom 50 Hz mode might still get rejected by the monitor's EDID, so if it doesn't show up in the xrandr list, you should enable mode validation logging with "sudo nvidia-xconfig --mode-debug", restart the X server, and then check /var/log/Xorg.0.log to see why your mode was rejected.
Your monitor doesn't support a 1366x768 @ 50 Hz mode in its EDID, so you're going to have to add one using the ModeLine option in /etc/X11/xorg.conf. Please see the xorg.conf man page and the man page for the "gtf" program for information on how to do that.

Your custom 50 Hz mode might still get rejected by the monitor's EDID, so if it doesn't show up in the xrandr list, you should enable mode validation logging with "sudo nvidia-xconfig --mode-debug", restart the X server, and then check /var/log/Xorg.0.log to see why your mode was rejected.

Aaron Plattner
NVIDIA Linux Graphics

#2
Posted 11/28/2012 04:32 PM   
Thank you for the reply . I followed the instructions : The Log shows : 13671.203] (II) NVIDIA(GPU-0): Validating Mode "1368x768_50.00": [ 13671.203] (II) NVIDIA(GPU-0): 1368 x 768 @ 50 Hz [ 13671.203] (II) NVIDIA(GPU-0): Mode Source: X Configuration file ModeLine [ 13671.203] (II) NVIDIA(GPU-0): Pixel Clock : 69.92 MHz [ 13671.203] (II) NVIDIA(GPU-0): HRes, HSyncStart : 1368, 1424 [ 13671.203] (II) NVIDIA(GPU-0): HSyncEnd, HTotal : 1568, 1768 [ 13671.203] (II) NVIDIA(GPU-0): VRes, VSyncStart : 768, 769 [ 13671.203] (II) NVIDIA(GPU-0): VSyncEnd, VTotal : 772, 791 [ 13671.203] (II) NVIDIA(GPU-0): H/V Polarity : -/+ [ 13671.203] (WW) NVIDIA(GPU-0): Mode is rejected: Only EDID-provided modes are allowed on [ 13671.203] (WW) NVIDIA(GPU-0): Hitachi/HINT X96W D-SUB (CRT-1) (continuous frequence [ 13671.203] (WW) NVIDIA(GPU-0): modes not allowed). i have added the Option "ModeValidation" "NoMaxPClkCheck" on the section device . regards
Thank you for the reply . I followed the instructions : The Log shows :
13671.203] (II) NVIDIA(GPU-0): Validating Mode "1368x768_50.00":
[ 13671.203] (II) NVIDIA(GPU-0): 1368 x 768 @ 50 Hz
[ 13671.203] (II) NVIDIA(GPU-0): Mode Source: X Configuration file ModeLine
[ 13671.203] (II) NVIDIA(GPU-0): Pixel Clock : 69.92 MHz
[ 13671.203] (II) NVIDIA(GPU-0): HRes, HSyncStart : 1368, 1424
[ 13671.203] (II) NVIDIA(GPU-0): HSyncEnd, HTotal : 1568, 1768
[ 13671.203] (II) NVIDIA(GPU-0): VRes, VSyncStart : 768, 769
[ 13671.203] (II) NVIDIA(GPU-0): VSyncEnd, VTotal : 772, 791
[ 13671.203] (II) NVIDIA(GPU-0): H/V Polarity : -/+
[ 13671.203] (WW) NVIDIA(GPU-0): Mode is rejected: Only EDID-provided modes are allowed on
[ 13671.203] (WW) NVIDIA(GPU-0): Hitachi/HINT X96W D-SUB (CRT-1) (continuous frequence
[ 13671.203] (WW) NVIDIA(GPU-0): modes not allowed).
i have added the
Option "ModeValidation" "NoMaxPClkCheck" on the section device .

regards

#3
Posted 11/28/2012 05:56 PM   
You need the AllowNonEdidModes flag to override that particular check, not the NoMaxPClkCheck one.
You need the AllowNonEdidModes flag to override that particular check, not the NoMaxPClkCheck one.

Aaron Plattner
NVIDIA Linux Graphics

#4
Posted 11/28/2012 06:21 PM   
I added the AloowNonEdidModes , i restart the Xserver , the Monitor is blank and i restart the Machine and the Login show the resolution but after login , it is blank no signal . Okay, i let it with 60 Hz because the reel Problem is may be somewhere , i suspect a bug in xine-lib and vdpau that can not detect the reel fps of JSC+ Sport . this work passably with half_temporal but with temporal it is flickering . trying yadiff2 the stream works good when using vlc or mplayer . but with xine nothing to do . this Problem was already reprorted from someone on the nvnews forum . Thank you Mister.
I added the AloowNonEdidModes , i restart the Xserver , the Monitor is blank and i restart the Machine and the Login show the resolution but after login , it is blank no signal .

Okay, i let it with 60 Hz because the reel Problem is may be somewhere , i suspect a bug in xine-lib and vdpau that can not detect the reel fps of JSC+ Sport . this work passably with half_temporal but with temporal it is flickering . trying yadiff2 the stream works good when using vlc or mplayer . but with xine nothing to do .

this Problem was already reprorted from someone on the nvnews forum .

Thank you Mister.

#5
Posted 11/28/2012 07:05 PM   
It sounds like that monitor really can't handle non-EDID modes, so you'll have to live with 59.8 Hz at 1366x768. Sorry!
It sounds like that monitor really can't handle non-EDID modes, so you'll have to live with 59.8 Hz at 1366x768. Sorry!

Aaron Plattner
NVIDIA Linux Graphics

#6
Posted 11/28/2012 07:16 PM   
[ 13671.203] (II) NVIDIA(GPU-0): Validating Mode "[b][u]1368[/u][/b]x768_50.00": [ 13671.203] (II) NVIDIA(GPU-0): [b][u]1368[/u][/b] x 768 @ 50 Hz [ 13671.203] (II) NVIDIA(GPU-0): Mode Source: X Configuration file ModeLine Is there some kind of typo in your xorg.conf file or is this 1368 expected?
[ 13671.203] (II) NVIDIA(GPU-0): Validating Mode "1368x768_50.00":
[ 13671.203] (II) NVIDIA(GPU-0): 1368 x 768 @ 50 Hz
[ 13671.203] (II) NVIDIA(GPU-0): Mode Source: X Configuration file ModeLine

Is there some kind of typo in your xorg.conf file or is this 1368 expected?

#7
Posted 11/28/2012 07:32 PM   
Oh, probably not. I forgot that gtf rounds the width to a multiple of 8. I think the proper adjustment is [code] Modeline "1366x768_50.00" 69.92 1366 1423 1567 1768 768 769 772 791 -HSync +Vsync [/code] I.e., shrink the width by two and move the sync pulse over by one so the image remains centered.
Oh, probably not. I forgot that gtf rounds the width to a multiple of 8. I think the proper adjustment is
Modeline "1366x768_50.00"  69.92  1366 1423 1567 1768  768 769 772 791  -HSync +Vsync

I.e., shrink the width by two and move the sync pulse over by one so the image remains centered.

Aaron Plattner
NVIDIA Linux Graphics

#8
Posted 11/28/2012 08:01 PM   
okay; after tweaking the xorg and adding your Modeline the xrandr - g gives that : creen 0: minimum 8 x 8, current 1366 x 768, maximum 8192 x 8192 DVI-I-0 disconnected (normal left inverted right x axis y axis) VGA-0 connected 1366x768+0+0 (normal left inverted right x axis y axis) 430mm x 255mm 1366x768 59.8*+ 50.0 1920x1200 60.0 1920x1080 59.9 1680x1050 60.0 59.9 1440x900 59.9 1400x1050 74.8 70.0 60.0 1360x768 60.0 50.0 59.8 1280x1024 75.0 60.0 1280x960 60.0 1280x720 60.0 1152x864 75.0 75.0 70.0 60.0 1024x768 75.0 70.1 60.0 960x600 120.0 960x540 120.0 840x525 149.9 139.8 120.0 119.8 832x624 74.6 800x600 75.0 72.2 60.3 56.2 720x450 119.8 700x525 149.5 120.0 680x384 119.9 119.6 640x480 75.0 72.8 59.9 512x384 140.1 120.0 400x300 144.4 320x240 145.6 120.1 DVI-I-1 disconnected (normal left inverted right x axis y axis) HDMI-0 disconnected (normal left inverted right x axis y axis) the nvidia-settings does not store the 50 Hz resolution , it gives no signal when i applied 1336 768 50Hz . i tried also with root .
okay; after tweaking the xorg and adding your Modeline the xrandr - g gives that :

creen 0: minimum 8 x 8, current 1366 x 768, maximum 8192 x 8192
DVI-I-0 disconnected (normal left inverted right x axis y axis)
VGA-0 connected 1366x768+0+0 (normal left inverted right x axis y axis) 430mm x 255mm
1366x768 59.8*+ 50.0
1920x1200 60.0
1920x1080 59.9
1680x1050 60.0 59.9
1440x900 59.9
1400x1050 74.8 70.0 60.0
1360x768 60.0 50.0 59.8
1280x1024 75.0 60.0
1280x960 60.0
1280x720 60.0
1152x864 75.0 75.0 70.0 60.0
1024x768 75.0 70.1 60.0
960x600 120.0
960x540 120.0
840x525 149.9 139.8 120.0 119.8
832x624 74.6
800x600 75.0 72.2 60.3 56.2
720x450 119.8
700x525 149.5 120.0
680x384 119.9 119.6
640x480 75.0 72.8 59.9
512x384 140.1 120.0
400x300 144.4
320x240 145.6 120.1
DVI-I-1 disconnected (normal left inverted right x axis y axis)
HDMI-0 disconnected (normal left inverted right x axis y axis)
the nvidia-settings does not store the 50 Hz resolution , it gives no signal when i applied 1336 768 50Hz . i tried also with root .

#9
Posted 11/28/2012 09:00 PM   
the X log shows : DIA(GPU-0): Validating Mode "1366x768_50.00": [ 22.977] (II) NVIDIA(GPU-0): 1366 x 768 @ 50 Hz [ 22.977] (II) NVIDIA(GPU-0): Mode Source: X Configuration file ModeLine [ 22.977] (II) NVIDIA(GPU-0): Pixel Clock : 69.92 MHz [ 22.977] (II) NVIDIA(GPU-0): HRes, HSyncStart : 1366, 1423 [ 22.977] (II) NVIDIA(GPU-0): HSyncEnd, HTotal : 1567, 1768 [ 22.977] (II) NVIDIA(GPU-0): VRes, VSyncStart : 768, 769 [ 22.977] (II) NVIDIA(GPU-0): VSyncEnd, VTotal : 772, 791 [ 22.977] (II) NVIDIA(GPU-0): H/V Polarity : -/+ [ 22.978] (II) NVIDIA(GPU-0): Viewport 1366x768+0+0 [ 22.978] (II) NVIDIA(GPU-0): Horizontal Taps 0 [ 22.978] (II) NVIDIA(GPU-0): Vertical Taps 0 [ 22.978] (II) NVIDIA(GPU-0): Base SuperSample x4 [ 22.978] (II) NVIDIA(GPU-0): Base Depth 32 [ 22.978] (II) NVIDIA(GPU-0): Distributed Rendering 1 [ 22.978] (II) NVIDIA(GPU-0): Overlay Depth 32 [ 22.978] (II) NVIDIA(GPU-0): Mode is valid. But i can not set it on nvidia-settings although the modeline is stored on xorg.conf . i will add it to the subsection of screen .
the X log shows :
DIA(GPU-0): Validating Mode "1366x768_50.00":
[ 22.977] (II) NVIDIA(GPU-0): 1366 x 768 @ 50 Hz
[ 22.977] (II) NVIDIA(GPU-0): Mode Source: X Configuration file ModeLine
[ 22.977] (II) NVIDIA(GPU-0): Pixel Clock : 69.92 MHz
[ 22.977] (II) NVIDIA(GPU-0): HRes, HSyncStart : 1366, 1423
[ 22.977] (II) NVIDIA(GPU-0): HSyncEnd, HTotal : 1567, 1768
[ 22.977] (II) NVIDIA(GPU-0): VRes, VSyncStart : 768, 769
[ 22.977] (II) NVIDIA(GPU-0): VSyncEnd, VTotal : 772, 791
[ 22.977] (II) NVIDIA(GPU-0): H/V Polarity : -/+
[ 22.978] (II) NVIDIA(GPU-0): Viewport 1366x768+0+0
[ 22.978] (II) NVIDIA(GPU-0): Horizontal Taps 0
[ 22.978] (II) NVIDIA(GPU-0): Vertical Taps 0
[ 22.978] (II) NVIDIA(GPU-0): Base SuperSample x4
[ 22.978] (II) NVIDIA(GPU-0): Base Depth 32
[ 22.978] (II) NVIDIA(GPU-0): Distributed Rendering 1
[ 22.978] (II) NVIDIA(GPU-0): Overlay Depth 32
[ 22.978] (II) NVIDIA(GPU-0): Mode is valid.

But i can not set it on nvidia-settings although the modeline is stored on xorg.conf . i will add it to the subsection of screen .

#10
Posted 11/28/2012 09:17 PM   
nvidia-settings always come back to default resolution "auto" . the xorg.conf : # nvidia-settings: X configuration file generated by nvidia-settings # nvidia-settings: version 310.19 (buildmeister@swio-display-x86-rhel47-11) Thu Nov 8 00:25:56 PST 2012 # nvidia-xconfig: X configuration file generated by nvidia-xconfig # nvidia-xconfig: version 310.19 (buildmeister@swio-display-x86-rhel47-11) Thu Nov 8 00:26:06 PST 2012 Section "ServerLayout" Identifier "Default Layout" Screen 0 "Screen0" 0 0 InputDevice "Keyboard0" "CoreKeyboard" InputDevice "Mouse0" "CorePointer" Option "Xinerama" "0" EndSection Section "Files" ModulePath "/usr/lib/xorg/modules" FontPath "/usr/share/fonts/X11/misc" FontPath "/usr/share/fonts/X11/cyrillic" FontPath "/usr/share/fonts/X11/100dpi/:unscaled" FontPath "/usr/share/fonts/X11/75dpi/:unscaled" FontPath "/usr/share/fonts/X11/Type1" FontPath "/usr/share/fonts/X11/100dpi" FontPath "/usr/share/fonts/X11/75dpi" FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType" FontPath "built-ins" EndSection Section "Module" Load "record" Load "extmod" Load "glx" Load "dri2" Load "dbe" EndSection Section "InputDevice" Identifier "Keyboard0" Driver "kbd" EndSection Section "InputDevice" Identifier "Mouse0" Driver "mouse" Option "Protocol" "auto" Option "Device" "/dev/input/mice" Option "ZAxisMapping" "4 5 6 7" EndSection Section "Monitor" # Block type: 2:0 3:fd # Block type: 2:0 3:fc # Block type: 2:0 3:fd # Max dot clock (video bandwidth) 160 MHz # Block type: 2:0 3:fc # Block type: 2:0 3:ff # DPMS capabilities: Active off:yes Suspend:yes Standby:yes # Block type: 2:0 3:fd # Block type: 2:0 3:fc # Block type: 2:0 3:ff #ModeLine "1368x768_60.00" 85.86 1368 1440 1584 1800 768 769 772 795 -hsync +vsync #ModeLine "1368x768_59.80" 85.57 1368 1440 1584 1800 768 769 772 795 -hsync +vsync #ModeLine "1368x768_50.00" 69.92 1368 1424 1568 1768 768 769 772 791 -hsync +vsync Identifier "Monitor0" VendorName "Unknown" ModelName "Hitachi/HINT X96W D-SUB" HorizSync 28.0 - 82.0 VertRefresh 50.0 - 75.0 ModeLine "1366x768_50.00" 69.92 1366 1423 1567 1768 768 769 772 791 -hsync +vsync ModeLine "1360x768_50.00" 69.61 1360 1416 1560 1760 768 769 772 791 -hsync +vsync Option "DPMS" EndSection Section "Device" ### Available Driver options are:- ### Values: : integer, : float, : "True"/"False", ### : "String", : " Hz/kHz/MHz", ### : "%" ### [arg]: arg optional #Option "NoAccel" # [] # [] #Option "ColorKey" # #Option "VideoKey" # #Option "Tiling" # [] #Option "LinearFramebuffer" # [] #Option "SwapbuffersWait" # [] #Option "XvPreferOverlay" # [] #Option "HotPlug" # [] #Option "RelaxedFencing" # [] #Option "Throttle" # [] #Option "ZaphodHeads" # #Option "DelayedFlush" # [] #Option "TearFree" # [] #Option "PerCrtcPixmaps" # [] #Option "FallbackDebug" # [] #Option "DebugFlushBatches" # [] #Option "DebugFlushCaches" # [] #Option "DebugWait" # [] #Option "BufferCache" # [] #Option "TripleBuffer" # [] Identifier "confogured video device " Driver "nvidia" Option "TripleBuffer" "True" Option "UseDisplayDevice" "CRT-1" #Option "ModeValidation" "AllowNonEdidModes" EndSection Section "Device" Identifier "Device0" Driver "nvidia" VendorName "NVIDIA Corporation" BoardName "GeForce 210" EndSection Section "Screen" Identifier "Default Screen" Device "confogured video device " Monitor "Monitor0" EndSection Section "Screen" # Removed Option "metamodes" "nvidia-auto-select +0+0" # Removed Option "metamodes" "1366x768_50.00 +0+0; nvidia-auto-select +0+0" Identifier "Screen0" Device "Device0" Monitor "Monitor0" DefaultDepth 24 Option "ModeDebug" "True" Option "ModeValidation" "AllowNonEdidModes" Option "TwinView" "0" Option "TripleBuffer" "True" Option "Stereo" "0" Option "nvidiaXineramaInfoOrder" "CRT-1" Option "metamodes" "nvidia-auto-select +0+0" SubSection "Display" Depth 24 Modes "1366x768_50.00" EndSubSection EndSection Section "Extensions" Option "Composite" "Enable" EndSection
nvidia-settings always come back to default resolution "auto" .
the xorg.conf :


# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 310.19 (buildmeister@swio-display-x86-rhel47-11) Thu Nov 8 00:25:56 PST 2012

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 310.19 (buildmeister@swio-display-x86-rhel47-11) Thu Nov 8 00:26:06 PST 2012

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
Option "Xinerama" "0"
EndSection

Section "Files"
ModulePath "/usr/lib/xorg/modules"
FontPath "/usr/share/fonts/X11/misc"
FontPath "/usr/share/fonts/X11/cyrillic"
FontPath "/usr/share/fonts/X11/100dpi/:unscaled"
FontPath "/usr/share/fonts/X11/75dpi/:unscaled"
FontPath "/usr/share/fonts/X11/Type1"
FontPath "/usr/share/fonts/X11/100dpi"
FontPath "/usr/share/fonts/X11/75dpi"
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
FontPath "built-ins"
EndSection

Section "Module"
Load "record"
Load "extmod"
Load "glx"
Load "dri2"
Load "dbe"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"

# Block type: 2:0 3:fd
# Block type: 2:0 3:fc
# Block type: 2:0 3:fd
# Max dot clock (video bandwidth) 160 MHz
# Block type: 2:0 3:fc
# Block type: 2:0 3:ff
# DPMS capabilities: Active off:yes Suspend:yes Standby:yes
# Block type: 2:0 3:fd
# Block type: 2:0 3:fc
# Block type: 2:0 3:ff
#ModeLine "1368x768_60.00" 85.86 1368 1440 1584 1800 768 769 772 795 -hsync +vsync
#ModeLine "1368x768_59.80" 85.57 1368 1440 1584 1800 768 769 772 795 -hsync +vsync
#ModeLine "1368x768_50.00" 69.92 1368 1424 1568 1768 768 769 772 791 -hsync +vsync
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Hitachi/HINT X96W D-SUB"
HorizSync 28.0 - 82.0
VertRefresh 50.0 - 75.0
ModeLine "1366x768_50.00" 69.92 1366 1423 1567 1768 768 769 772 791 -hsync +vsync
ModeLine "1360x768_50.00" 69.61 1360 1416 1560 1760 768 769 772 791 -hsync +vsync
Option "DPMS"
EndSection

Section "Device"

### Available Driver options are:-
### Values: : integer, : float, : "True"/"False",
### : "String", : " Hz/kHz/MHz",
### : "%"
### [arg]: arg optional
#Option "NoAccel" # []
# []
#Option "ColorKey" #
#Option "VideoKey" #
#Option "Tiling" # []
#Option "LinearFramebuffer" # []
#Option "SwapbuffersWait" # []
#Option "XvPreferOverlay" # []
#Option "HotPlug" # []
#Option "RelaxedFencing" # []
#Option "Throttle" # []
#Option "ZaphodHeads" #
#Option "DelayedFlush" # []
#Option "TearFree" # []
#Option "PerCrtcPixmaps" # []
#Option "FallbackDebug" # []
#Option "DebugFlushBatches" # []
#Option "DebugFlushCaches" # []
#Option "DebugWait" # []
#Option "BufferCache" # []
#Option "TripleBuffer" # []
Identifier "confogured video device "
Driver "nvidia"
Option "TripleBuffer" "True"
Option "UseDisplayDevice" "CRT-1"
#Option "ModeValidation" "AllowNonEdidModes"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 210"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "confogured video device "
Monitor "Monitor0"
EndSection

Section "Screen"

# Removed Option "metamodes" "nvidia-auto-select +0+0"
# Removed Option "metamodes" "1366x768_50.00 +0+0; nvidia-auto-select +0+0"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "ModeDebug" "True"
Option "ModeValidation" "AllowNonEdidModes"
Option "TwinView" "0"
Option "TripleBuffer" "True"
Option "Stereo" "0"
Option "nvidiaXineramaInfoOrder" "CRT-1"
Option "metamodes" "nvidia-auto-select +0+0"
SubSection "Display"
Depth 24
Modes "1366x768_50.00"
EndSubSection
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection

#11
Posted 11/28/2012 09:23 PM   
Really don't know if this will help or not, but when I was trying a 6 screen setup where the top 3 screens were different size to the bottom, and the bottom ones needed to run at 50Hz, I had the following settings in my Xorg (some options are probably not needed but I remember trying so many combinations and these finally worked to prevent the monitors own EDID interfering): - [code] Section "Monitor" # HorizSync source: edid, VertRefresh source: edid Identifier "Monitor0" VendorName "Unknown" ModelName "Samsung SyncMaster" HorizSync 30.0 - 81.0 VertRefresh 50.0 - 60.0 Modeline "5760x1080" 326.596 5760 5776 5792 5880 1080 1083 1097 1111 +hsync +vsync Modeline "3840x1024" 254.310 3840 3856 3872 3976 1024 1025 1032 1066 +hsync +vsync Option "DPMS" Option "ExactModeTimingsDVI" "True" EndSection Section "Screen" Identifier "Screen0" Device "Device0" Monitor "Monitor0" Option "TwinView" "1" Option "TwinviewXineramaInfo" "True" Option "TwinViewXineramaInfoOverride" "1920x1080+1920+1024, 1920x1080+0+1024, 1920x1080+3840+1024, 1280x1024+960+0, 1280x1024+2240+0, 1280x1024+3520+0" Option "metamodes" "DFP-0: 5760x1080+0+1024, DFP-1:3840x1024+960+0" Option "UseEDID" "False" # Option "NoBandWidthTest" "True" Option "UseEDIDFreqs" "FALSE" Option "UseEdidDpi" "FALSE" Option "ModeDebug" "True" Option "ModeValidation" "AllowNon60HzDFPModes, NoMaxPClkCheck, NoEdidMaxPClkCheck, AllowInterlacedModes, NoMaxSizeCheck, NoHorizSyncCheck, NoVertRefreshCheck, NoWidthAlignmentCheck, NoDFPNativeResolutionCheck, NoVirtualSizeCheck, NoEdidModes, NoExtendedGpuCapabilitiesCheck, ObeyEdidContradictions, NoTotalSizeCheck, NoDualLinkDVICheck, NoDisplayPortBandwidthCheck" #"NoDFPNativeResolutionCheck, NoVirtualSizeCheck, NoMaxPClkCheck, NoHorizSyncCheck, NoExtendedGpuCapabilitiesCheck, NoVertRefreshCheck, NoWidthAlignmentCheck" DefaultDepth 24 SubSection "Display" Depth 24 EndSubSection EndSection [/code]
Really don't know if this will help or not, but when I was trying a 6 screen setup where the top 3 screens were different size to the bottom, and the bottom ones needed to run at 50Hz, I had the following settings in my Xorg (some options are probably not needed but I remember trying so many combinations and these finally worked to prevent the monitors own EDID interfering): -

Section "Monitor"
# HorizSync source: edid, VertRefresh source: edid
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Samsung SyncMaster"
HorizSync 30.0 - 81.0
VertRefresh 50.0 - 60.0
Modeline "5760x1080" 326.596 5760 5776 5792 5880 1080 1083 1097 1111 +hsync +vsync
Modeline "3840x1024" 254.310 3840 3856 3872 3976 1024 1025 1032 1066 +hsync +vsync

Option "DPMS"
Option "ExactModeTimingsDVI" "True"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
Option "TwinView" "1"

Option "TwinviewXineramaInfo" "True"
Option "TwinViewXineramaInfoOverride" "1920x1080+1920+1024, 1920x1080+0+1024, 1920x1080+3840+1024, 1280x1024+960+0, 1280x1024+2240+0, 1280x1024+3520+0"
Option "metamodes" "DFP-0: 5760x1080+0+1024, DFP-1:3840x1024+960+0"

Option "UseEDID" "False"
# Option "NoBandWidthTest" "True"
Option "UseEDIDFreqs" "FALSE"
Option "UseEdidDpi" "FALSE"

Option "ModeDebug" "True"
Option "ModeValidation" "AllowNon60HzDFPModes, NoMaxPClkCheck, NoEdidMaxPClkCheck, AllowInterlacedModes, NoMaxSizeCheck, NoHorizSyncCheck, NoVertRefreshCheck, NoWidthAlignmentCheck, NoDFPNativeResolutionCheck, NoVirtualSizeCheck, NoEdidModes, NoExtendedGpuCapabilitiesCheck, ObeyEdidContradictions, NoTotalSizeCheck, NoDualLinkDVICheck, NoDisplayPortBandwidthCheck"
#"NoDFPNativeResolutionCheck, NoVirtualSizeCheck, NoMaxPClkCheck, NoHorizSyncCheck, NoExtendedGpuCapabilitiesCheck, NoVertRefreshCheck, NoWidthAlignmentCheck"

DefaultDepth 24
SubSection "Display"
Depth 24
EndSubSection
EndSection

#12
Posted 11/30/2012 01:56 AM   
Thank you, I have noticed that 50 HZ over vga does not out put any signal to screen . May be with a dvi connector it is possible to get it on.
Thank you, I have noticed that 50 HZ over vga does not out put any signal to screen . May be with a dvi connector it is possible to get it on.

#13
Posted 11/30/2012 05:27 PM   
Scroll To Top

Add Reply