Simple Tessellation Shader (SDK Sample)
This thread is for comments/questions related to the Simple Tessellation Sample blog post on the Developer Zone (https://developer.nvidia.com/content/opengl-sdk-simple-tessellation-shader)
This thread is for comments/questions related to the Simple Tessellation Sample blog post on the Developer Zone (https://developer.nvidia.com/content/opengl-sdk-simple-tessellation-shader)

David Weller

NVIDIA Developer Programs Manager

Find us on twitter: @nvidiadeveloper

#1
Posted 01/10/2013 06:24 PM   
Sample fails on launch: C:\Users\someone\Desktop\simple_tessellation_shader\simple_tessellation_shader>s imple_tessellation_shader.exe GL version 4.3.0 Supports glsl include Compiling vertex shader Compiling tessellation control shader Tessellation control info ------------------------- 0(22) : error C7593: Builtin block member gl_Position not found in redeclaration of out gl_PerVertex Compiling tessellation evaluation shader for plane Tessellation evaluation info ---------------------------- 0(25) : error C7593: Builtin block member gl_Position not found in redeclaration of out gl_PerVertex Compiling tessellation evaluation shader for torus Tessellation evaluation info ---------------------------- 0(21) : error C7593: Builtin block member gl_Position not found in redeclaration of out gl_PerVertex Compiling fragment shader Failed to compile all shaders, exitting Win7 x64 EN Quadro K5000 drivers version 370.10
Sample fails on launch:

C:\Users\someone\Desktop\simple_tessellation_shader\simple_tessellation_shader>s
imple_tessellation_shader.exe
GL version 4.3.0
Supports glsl include
Compiling vertex shader
Compiling tessellation control shader
Tessellation control info
-------------------------
0(22) : error C7593: Builtin block member gl_Position not found in redeclaration
of out gl_PerVertex
Compiling tessellation evaluation shader for plane
Tessellation evaluation info
----------------------------
0(25) : error C7593: Builtin block member gl_Position not found in redeclaration
of out gl_PerVertex
Compiling tessellation evaluation shader for torus
Tessellation evaluation info
----------------------------
0(21) : error C7593: Builtin block member gl_Position not found in redeclaration
of out gl_PerVertex
Compiling fragment shader
Failed to compile all shaders, exitting

Win7 x64 EN
Quadro K5000
drivers version 370.10

#2
Posted 01/14/2013 08:32 AM   
Thanks for alerting me. I'll have a fix posted shortly. I believe the bug you are encountering is due to a driver fix. We recently fixed a bug where the driver incorrectly accepted built-ins without redeclaration.
Thanks for alerting me. I'll have a fix posted shortly.

I believe the bug you are encountering is due to a driver fix. We recently fixed a bug where the driver incorrectly accepted built-ins without redeclaration.

#3
Posted 01/15/2013 04:44 PM   
Yup, I have the same issue on a 680m gpu.
Yup, I have the same issue on a 680m gpu.

#4
Posted 01/19/2013 04:44 PM   
Updated drivers to ODE 310.90. Issue is still there :( Win x64 EN Quadro K5000 ODE 310.90
Updated drivers to ODE 310.90. Issue is still there :(

Win x64 EN
Quadro K5000
ODE 310.90

#5
Posted 01/22/2013 10:52 AM   
Bump
Bump

#6
Posted 02/13/2013 07:50 AM   
Bump again, two month passed...
Bump again, two month passed...

#7
Posted 03/10/2013 12:39 PM   
Here is a fix since nvidia doesn't care to post one... [url]http://www.geeks3d.com/20130106/nvidia-updates-its-opengl-sdk/[/url]
Here is a fix since nvidia doesn't care to post one...

http://www.geeks3d.com/20130106/nvidia-updates-its-opengl-sdk/

#8
Posted 09/29/2013 05:18 AM   
Scroll To Top