Linux 2.4 Support Timeline
The upcoming 319.xx driver series, which will be the next long-lived branch release, will also be the last NVIDIA Linux driver release to support Linux 2.4 kernels. Drivers after 319.xx will continue to support Linux 2.6 and later. Since 319.xx is a long-lived driver release, 319.xx drivers that support Linux 2.4 will continue to be available throughout the lifetime of that release, even after newer drivers have dropped support for Linux 2.4. Support for Linux 2.4 will not be removed from future releases of the 173.14.xx and 304.xx legacy drivers.
The upcoming 319.xx driver series, which will be the next long-lived branch release, will also be the last NVIDIA Linux driver release to support Linux 2.4 kernels. Drivers after 319.xx will continue to support Linux 2.6 and later. Since 319.xx is a long-lived driver release, 319.xx drivers that support Linux 2.4 will continue to be available throughout the lifetime of that release, even after newer drivers have dropped support for Linux 2.4.

Support for Linux 2.4 will not be removed from future releases of the 173.14.xx and 304.xx legacy drivers.

Daniel Dadap
NVIDIA Linux Graphics

#1
Posted 03/04/2013 09:16 PM   
As of version [url=https://devtalk.nvidia.com/default/topic/549155]325.08[/url] of the NVIDIA Linux driver, Linux 2.4 kernels are no longer supported.
As of version 325.08 of the NVIDIA Linux driver, Linux 2.4 kernels are no longer supported.

Daniel Dadap
NVIDIA Linux Graphics

#2
Posted 07/01/2013 02:42 PM   
Scroll To Top