Video tears on all screens
I have 3 attached screens. Video tears on all of them despite Xv Sync to VBlank being set to the screen on which the video playing. This occurs with VDPAU and Xv. I am using a non-composited awesomewm desktop. Here are some things I've tried: * mplayer with -vo gl3; -vo xv: no change * flipping stuff around in nvidia-settings * export __GL_SYNC_TO_VBLANK=1 * running nvidia-settings -l on X startup * export __VDPAU_NVIDIA_SYNC_DISPLAY_DEVICE=[screen] * Playing video under cairo-compmgr-git * Turning PowerMizer to Maximum from Adaptive And some other stuff. But I still get tearing all the time, on all screens, in all players. Note that I even tried a composited desktop, as some people say it is not possible to have real VSync on desktops that are not composited. I believe these people are incorrect because this is a regression -- I don't know the exact version I was on, but it seems around the New Year this tearing issue appeared. Previously, the video would sync to the display assigned in nvidia-settings. I would _really_ like this resolved. As I said, I feel it's a regression. I'm currently using the 319.12 beta drivers. I upgraded in hopes they would resolve this as the changes seemed fairly extensive, but they haven't. 313.xx has the same issue. Attaching nvidia-bug-report.sh.
I have 3 attached screens. Video tears on all of them despite Xv Sync to VBlank being set to the screen on which the video playing. This occurs with VDPAU and Xv. I am using a non-composited awesomewm desktop.

Here are some things I've tried:

* mplayer with -vo gl3; -vo xv: no change
* flipping stuff around in nvidia-settings
* export __GL_SYNC_TO_VBLANK=1
* running nvidia-settings -l on X startup
* export __VDPAU_NVIDIA_SYNC_DISPLAY_DEVICE=[screen]
* Playing video under cairo-compmgr-git
* Turning PowerMizer to Maximum from Adaptive

And some other stuff.

But I still get tearing all the time, on all screens, in all players. Note that I even tried a composited desktop, as some people say it is not possible to have real VSync on desktops that are not composited. I believe these people are incorrect because this is a regression -- I don't know the exact version I was on, but it seems around the New Year this tearing issue appeared. Previously, the video would sync to the display assigned in nvidia-settings.

I would _really_ like this resolved. As I said, I feel it's a regression. I'm currently using the 319.12 beta drivers. I upgraded in hopes they would resolve this as the changes seemed fairly extensive, but they haven't. 313.xx has the same issue.

Attaching nvidia-bug-report.sh.

#1
Posted 04/15/2013 07:29 AM   
3 screen setup here using Awesome WM - 313.30 I had to disable composite in xorg.conf to fix the tearing I was experiencing in XBMC and full screen OpenGL games (CK2 in this case): --------------------- Section "Extensions" Option "Composite" "Disabled" EndSection --------------------- Without this I had tearing (always about 1/3 from top of screen) regardless of how I had VSync set.
3 screen setup here using Awesome WM - 313.30

I had to disable composite in xorg.conf to fix the tearing I was experiencing in XBMC and full screen OpenGL games (CK2 in this case):

---------------------
Section "Extensions"

Option "Composite" "Disabled"

EndSection
---------------------

Without this I had tearing (always about 1/3 from top of screen) regardless of how I had VSync set.

#2
Posted 04/16/2013 08:52 AM   
Thanks! That worked for me, finally. I think that's still probably a driver bug that we can hopefully get fixed soon, but I am grateful to have video that doesn't tear now. Thank you very much. Send me a btc address and I'll shoot you a tip.
Thanks! That worked for me, finally. I think that's still probably a driver bug that we can hopefully get fixed soon, but I am grateful to have video that doesn't tear now. Thank you very much. Send me a btc address and I'll shoot you a tip.

#3
Posted 04/17/2013 03:42 AM   
[quote="sjuxax"]that we can hopefully get fixed soon[/quote]I waiting for this since 2010 year. (Have tearing issues on all my nVidia hardware.)
sjuxax said:that we can hopefully get fixed soon
I waiting for this since 2010 year. (Have tearing issues on all my nVidia hardware.)

#4
Posted 04/24/2013 09:05 AM   
Scroll To Top

Add Reply