Screen/Video tearing 7xx(Kepler), 9xx(Maxwell), 10xx(Pascal) in almost all applications, including d...
[quote="usuk"]I do care though if I can watch video's normaly like with my other old PC Radeon, which works flawlessly. GET OF UR LAZY ASSES & GO FIX THIS NVIDIA !!!![/quote] Yeah, XP SP3 user here too with the same problem using GTX760. My old nvidia FX5600 has no tearing problems in XP (connected to the same monitor). Gah... just wanted to keep using XP for browsing & older games. I can't believe that my ten year old desktop is running video content better in XP than GTX760 does in my new one.
usuk said:I do care though if I can watch video's normaly like with my other old PC Radeon, which works flawlessly.

GET OF UR LAZY ASSES & GO FIX THIS NVIDIA !!!!

Yeah, XP SP3 user here too with the same problem using GTX760. My old nvidia FX5600 has no tearing problems in XP (connected to the same monitor). Gah... just wanted to keep using XP for browsing & older games. I can't believe that my ten year old desktop is running video content better in XP than GTX760 does in my new one.

CPU: AMD FX-8320
RAM: Corsair 8.00GB Dual-Channel DDR3
Motherboard: ASUSTeK SABERTOOTH 990FX R2.0
Graphics: 2048MB NVIDIA GeForce GTX 760 (MSI)
OS: Windows XP 32-bit SP3 / Windows 7 64-bit SP1

Posted 10/29/2013 05:16 AM   
[quote="TechSmurfy"] Yeah, XP SP3 user here too with the same problem using GTX760. My old nvidia FX5600 has no tearing problems in XP (connected to the same monitor). Gah... just wanted to keep using XP for browsing & older games. I can't believe that my ten year old desktop is running video content better in XP than GTX760 does in my new one.[/quote] I don't find that completely surprising. Your 760 is probably hammering an insanely high frame rate compared to that FX5600.
TechSmurfy said:
Yeah, XP SP3 user here too with the same problem using GTX760. My old nvidia FX5600 has no tearing problems in XP (connected to the same monitor). Gah... just wanted to keep using XP for browsing & older games. I can't believe that my ten year old desktop is running video content better in XP than GTX760 does in my new one.


I don't find that completely surprising. Your 760 is probably hammering an insanely high frame rate compared to that FX5600.

Posted 10/29/2013 03:09 PM   
Since this thread floats to the top of Google searches on this topic for both Linux and Windows, I decided to add my 2 cents here. This exact same tearing issue has been driving me crazy for about a year with a GTX 660 Ti, on a Windows 7 box (yes with Aero on or off). Flash player and VLC both exhibit horrible tearing. Only Media Player Classic - Home Cinema in D3D Fullscreen mode is smooth. And the HTML5 video player in Chrome was a little better than Flash Player. Anyway, just tonight, upgraded from 220something drivers to the latest 330.82 drivers and *finally* the tearing is gone. Tearing tests in VLC, and on YoutTube using Flash Player as well as high motion videos with a lot of panning, all play smoothly now with no sign of tearing. There seems to be some other video playback improvements as well, but they're hard to quantify.
Since this thread floats to the top of Google searches on this topic for
both Linux and Windows, I decided to add my 2 cents here.

This exact same tearing issue has been driving me crazy for about a year with a GTX 660 Ti,
on a Windows 7 box (yes with Aero on or off). Flash player and VLC both exhibit horrible tearing.
Only Media Player Classic - Home Cinema in D3D Fullscreen mode is smooth.
And the HTML5 video player in Chrome was a little better than Flash Player.

Anyway, just tonight, upgraded from 220something drivers to the latest 330.82 drivers
and *finally* the tearing is gone. Tearing tests in VLC, and on YoutTube using Flash Player
as well as high motion videos with a lot of panning, all play smoothly now with
no sign of tearing. There seems to be some other video playback improvements as well,
but they're hard to quantify.

Posted 11/22/2013 10:10 AM   
I can confirm that the horizontal tearing issue exists on the GTX 770 as well. It's terrible. Not only the horizontal tearing, but also severe lag in all video types and players. I'm in Win7 x64 on a new production machine with SSD drives. I've had a tech working on this for about 6 hours, trying everything imaginable. VLC, MPC-HC, Quicktime... they all do it. I've owned dozens of PC's and never seen anything like this. How can a problem this prominent not be resolved immediately by NVidia? Now can it not be apparent in every product review? How can it not completely trash their bottom line and reputation? It baffles me that vidia doesn't even bother to address the comments about this in so many threads. I've been a dedicated NVidia consumer for a decade, and this has me ready to jump ship to AMD for the first time.
I can confirm that the horizontal tearing issue exists on the GTX 770 as well. It's terrible. Not only the horizontal tearing, but also severe lag in all video types and players. I'm in Win7 x64 on a new production machine with SSD drives. I've had a tech working on this for about 6 hours, trying everything imaginable. VLC, MPC-HC, Quicktime... they all do it.

I've owned dozens of PC's and never seen anything like this. How can a problem this prominent not be resolved immediately by NVidia? Now can it not be apparent in every product review? How can it not completely trash their bottom line and reputation?

It baffles me that vidia doesn't even bother to address the comments about this in so many threads.

I've been a dedicated NVidia consumer for a decade, and this has me ready to jump ship to AMD for the first time.

Posted 11/22/2013 08:20 PM   
Well nothing to add .......... In December it will be a year we reported this issue continously [url]https://devtalk.nvidia.com/default/topic/525640/linux/evga-geforce-gtx-660-ti-problems-/1[/url] Also more than a decade of NVidia graphic boards (started with RivaTNT, Geforce2, 4600, 5900XT, 460 GTX) ... and I never had experienced that before, and it ruins the "Geforce Experience" Now, even on the same PC, same OS, I had an 460GTX, and just replaced it by an 660Ti - boom and it was there For heavens sake fix this, it is absolutely illogical that this is related to desktop managers, X or so as it definitely never was a problem before. P.S: My personal guess is still that it is related to adaptive sync which cannot be turned off and introduced in Kepler - but this is just my personal bet .... Well I never tend to be cynical, but Thank you NVidia for the good performance!
Well nothing to add ..........

In December it will be a year we reported this issue continously
https://devtalk.nvidia.com/default/topic/525640/linux/evga-geforce-gtx-660-ti-problems-/1

Also more than a decade of NVidia graphic boards (started with RivaTNT, Geforce2, 4600, 5900XT, 460 GTX) ... and I never had experienced that before, and it ruins the "Geforce Experience"
Now, even on the same PC, same OS, I had an 460GTX, and just replaced it by an 660Ti - boom and it was there

For heavens sake fix this, it is absolutely illogical that this is related to desktop managers, X or so as it definitely never was a problem before. P.S: My personal guess is still that it is related to adaptive sync which cannot be turned off and introduced in Kepler - but this is just my personal bet ....

Well I never tend to be cynical, but

Thank you NVidia for the good performance!

Posted 11/22/2013 10:01 PM   
I came from a nvidia gts250 and it has been a great little deal for me. After installing all flavors and distros from ubuntu, I then decided to stick with kubuntu 12.04LTS for the only purpouse of playing steam games, watching HDTV with kaffeine tuner, video editing, you name it. I had this issue with massive checkered board pixel issue video tearing on the top portion of my hp 2709m monitor with my gtx660 from nvidia. I fixed it. I hope this helps you guys. I'm gona stop blabering and just post the fix. on a fresh install kubuntu 32bit or 64 bit LTS version 12.04, first thing i did was: 1. install the nvidia drivers via "additional drivers" version "nvidia accelerated graphics driver (post-release updates)(version 319-updates) 2. reboot 3. start->settings->system settings->startup and shutdown(way at the bottom)->session management->tick start with empty session and apply. 4. start->settings->nvidia x server settings-> click on "save to X configuration file->change to "/etc/X11/xorg.conf.bak" without quotes and save.->again click on "save to X configuration file->click on show preview and look for this section --------------------- Section "Screen" Identifier "Screen0" Device "Device0" Monitor "Monitor0" DefaultDepth 24 Option "Stereo" "0" Option "metamodes" "nvidia-auto-select +0+0" SubSection "Display" Depth 24 EndSubSection --------------------- change to --------------------- Section "Screen" Identifier "Screen0" Device "Device0" Monitor "Monitor0" DefaultDepth 24 Option "Stereo" "0" Option "metamodes" "nvidia-auto-select +0+0 { ForceFullCompositionPipeline = On }" SubSection "Display" Depth 24 EndSubSection --------------------- reminder-just change the line metamodes, all else leave alone save!!!!!!!!!! remember that if you want to edit this, you need to view this in your favorite txt editor as you cant view it through nvidia and you be scratching your head over why the settings didn't stick. I would kate into this file to view it and it is there so believe me. REEEEBOOOOOOOOOOOT!!!!!!!!!!!!!!!!!!!!!!! after a reboot. this part not needed but i want you to look at what your doing....lol go into start->system->system settings->application appearance->font->use anti-aliasing:enabled->configure use sub-pixel rgb and hinting style to full very important start->system->system settings->desktop effects->general tab, leave all checkmarks. start->system->system settings->desktop effects->advanced-> keep these: composite type: OpenGL Keep windows thumbnails:only for shown windows (not necessery but i have this set like this) Scale method: accurate (use crisp for smoother video) put a tickmark on this ("suspend desktop effects for fullscreen windows" important for smooth gaming and video playback fullscreen) Scale method:accurate opengl options tickmark on on both use opengl2 shaders and Use Vsync. in nvidia-settings, I have all of them ticked including sync to Vblank and image settings set to quality. reboot!!!!!!!!!!!!!!!!!!!!!!!!!!!!! now nothing tears This is apparently a driver issue from what I seen but i can't confirm. If you are running kubuntu, just follow these steps and you will be fine. If you are running compiz or gnome with compiz remix of some sort, do the typical settings i posted like a million years ago to get free video tearing. such as 200hz, do not detect refresh rate. If you don't have a compositor, your in the green. with compositing off, I get no window tearing at all including xubuntu. This appearantly works with all flavors of ubuntu linux. The main reason for the graphics card was to play "planetary annihilation" that currently works on kubuntu 12.04 64bit only. all settings full and it works fine. beta version. use VLC for video playback
I came from a nvidia gts250 and it has been a great little deal for me. After installing all flavors and distros from ubuntu, I then decided to stick with kubuntu 12.04LTS for the only purpouse of playing steam games, watching HDTV with kaffeine tuner, video editing, you name it. I had this issue with massive checkered board pixel issue video tearing on the top portion of my hp 2709m monitor with my gtx660 from nvidia. I fixed it. I hope this helps you guys. I'm gona stop blabering and just post the fix.

on a fresh install kubuntu 32bit or 64 bit LTS version 12.04, first thing i did was:
1. install the nvidia drivers via "additional drivers" version "nvidia accelerated graphics driver (post-release updates)(version 319-updates)
2. reboot
3. start->settings->system settings->startup and shutdown(way at the bottom)->session management->tick start with empty session and apply.
4. start->settings->nvidia x server settings-> click on "save to X configuration file->change to "/etc/X11/xorg.conf.bak" without quotes and save.->again click on "save to X configuration file->click on show preview and look for


this section
---------------------
Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "Stereo" "0"
Option "metamodes" "nvidia-auto-select +0+0"
SubSection "Display"
Depth 24
EndSubSection
---------------------

change to
---------------------
Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "Stereo" "0"
Option "metamodes" "nvidia-auto-select +0+0 { ForceFullCompositionPipeline = On }"
SubSection "Display"
Depth 24
EndSubSection
---------------------
reminder-just change the line metamodes, all else leave alone

save!!!!!!!!!! remember that if you want to edit this, you need to view this in your favorite txt editor as you cant view it through nvidia and you be scratching your head over why the settings didn't stick. I would kate into this file to view it and it is there so believe me.



REEEEBOOOOOOOOOOOT!!!!!!!!!!!!!!!!!!!!!!!

after a reboot.

this part not needed but i want you to look at what your doing....lol
go into start->system->system settings->application appearance->font->use anti-aliasing:enabled->configure use sub-pixel rgb and hinting style to full


very important
start->system->system settings->desktop effects->general tab, leave all checkmarks.
start->system->system settings->desktop effects->advanced->
keep these:
composite type: OpenGL
Keep windows thumbnails:only for shown windows (not necessery but i have this set like this)
Scale method: accurate (use crisp for smoother video)

put a tickmark on this ("suspend desktop effects for fullscreen windows" important for smooth gaming and video playback fullscreen) Scale method:accurate

opengl options tickmark on on both use opengl2 shaders and Use Vsync.

in nvidia-settings, I have all of them ticked including sync to Vblank and image settings set to quality.

reboot!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

now nothing tears

This is apparently a driver issue from what I seen but i can't confirm. If you are running kubuntu, just follow these steps and you will be fine. If you are running compiz or gnome with compiz remix of some sort, do the typical settings i posted like a million years ago to get free video tearing. such as 200hz, do not detect refresh rate.

If you don't have a compositor, your in the green. with compositing off, I get no window tearing at all including xubuntu. This appearantly works with all flavors of ubuntu linux.

The main reason for the graphics card was to play "planetary annihilation" that currently works on kubuntu 12.04 64bit only. all settings full and it works fine. beta version. use VLC for video playback

Posted 11/25/2013 10:17 PM   
With VSync turned on and a compositing WM your trick (ForceFullCompositionPipeline) is not really required.
With VSync turned on and a compositing WM your trick (ForceFullCompositionPipeline) is not really required.

Artem S. Tashkinov
Linux and Open Source advocate

Posted 11/26/2013 11:10 AM   
hmm. It is required. I been using linux for years and very aware of all flavors of environments of what they can or can't do. specifically ubuntu versions 12.04 and up in kde and xfce. Regardless of the compositor WM with the switches on or off, video and WM tear. Regardless of any changes to the opengl settings in the driver, Video and WM tear still occur. that trick up there saved my headaches and ill add i spent 2 days infront of my pc looking for a solution.
hmm. It is required. I been using linux for years and very aware of all flavors of environments of what they can or can't do. specifically ubuntu versions 12.04 and up in kde and xfce. Regardless of the compositor WM with the switches on or off, video and WM tear. Regardless of any changes to the opengl settings in the driver, Video and WM tear still occur. that trick up there saved my headaches and ill add i spent 2 days infront of my pc looking for a solution.

Posted 11/26/2013 04:04 PM   
Yes this fixes it, and also from the reports in the earlier other threads the "tearing experience" varies in regards of the different reporters, For me mostly flash and xv videos was affected, not noticable in games or desktop itself. Btw you can more easily apply this by one command on the shell: nvidia-settings --assign CurrentMetaMode="DFP-3: 1920x1200 { ForceCompositionPipeline = On } (adjust DFP-3 and display resolution to your config) Documentation is here: [url]http://http.download.nvidia.com/XFree86/Linux-x86/325.15/README/configtwinview.html[/url] BUT there is a "but": there is a performance loss by using "ForceFullCompositionPipeline" ~20-30%. This may actually only relevant if running games, but you pay a price so I consider it a workaround. You can benchmark by e.g. Unigine valley
Yes this fixes it, and also from the reports in the earlier other threads the "tearing experience" varies in regards of the different reporters, For me mostly flash and xv videos was affected, not noticable in games or desktop itself.

Btw you can more easily apply this by one command on the shell:
nvidia-settings --assign CurrentMetaMode="DFP-3: 1920x1200 { ForceCompositionPipeline = On }
(adjust DFP-3 and display resolution to your config) Documentation is here: http://http.download.nvidia.com/XFree86/Linux-x86/325.15/README/configtwinview.html

BUT there is a "but": there is a performance loss by using "ForceFullCompositionPipeline" ~20-30%. This may actually only relevant if running games, but you pay a price so I consider it a workaround.
You can benchmark by e.g. Unigine valley

Posted 11/26/2013 08:55 PM   
[quote="Al777"]Btw you can more easily apply this by one command on the shell: [code] nvidia-settings --assign CurrentMetaMode="DFP-3: 1920x1200 { ForceCompositionPipeline = On }" [/code] (adjust DFP-3 and display resolution to your config) Documentation is here: [url]http://http.download.nvidia.com/XFree86/Linux-x86/325.15/README/configtwinview.html[/url][/quote] This seems like the best solution, I've just verified it and it works beautifully. https://www.youtube.com/watch?v=ceX18O9pvLs Thanks!
Al777 said:Btw you can more easily apply this by one command on the shell:
nvidia-settings --assign CurrentMetaMode="DFP-3: 1920x1200 { ForceCompositionPipeline = On }"

(adjust DFP-3 and display resolution to your config) Documentation is here: http://http.download.nvidia.com/XFree86/Linux-x86/325.15/README/configtwinview.html


This seems like the best solution, I've just verified it and it works beautifully.

Thanks!

Artem S. Tashkinov
Linux and Open Source advocate

Posted 11/27/2013 09:09 AM   
[s]I've decided to live [b]with[/b] tearing - ForceCompositionPipeline makes some applications absolutely slow - for instance everything that is being run in Wine becomes intolerably slow and sluggish. No thanks, let's wait for new hacks and workarounds for Kepler.[/s] Del.
I've decided to live with tearing - ForceCompositionPipeline makes some applications absolutely slow - for instance everything that is being run in Wine becomes intolerably slow and sluggish.

No thanks, let's wait for new hacks and workarounds for Kepler.


Del.

Artem S. Tashkinov
Linux and Open Source advocate

Posted 11/27/2013 08:59 PM   
I've found a simple solution to fix tearing on KWin/KDE which works for my GTX 760. Go to System Settings > Desktop Effects > Advanced and set "Tearing Prevention (VSync)" to "Full scene repaints". Setting it to "Automatic" DOES NOT work. Also make sure that "Suspect desktop effects for full screen windows" is NOT checked otherwise full screen windows will tear. After setting this I don't have any tearing in VLC any more. This could be a KWin issue, since the "Automatic" setting does not appear to do the right thing. I will contact Martin Gräßlin about this.
I've found a simple solution to fix tearing on KWin/KDE which works for my GTX 760.

Go to System Settings > Desktop Effects > Advanced and set "Tearing Prevention (VSync)" to "Full scene repaints". Setting it to "Automatic" DOES NOT work. Also make sure that "Suspect desktop effects for full screen windows" is NOT checked otherwise full screen windows will tear.

After setting this I don't have any tearing in VLC any more.

This could be a KWin issue, since the "Automatic" setting does not appear to do the right thing. I will contact Martin Gräßlin about this.

Posted 12/14/2013 02:16 AM   
The fact that VSync fixes this issue for OpenGL compositing managers has been known for a very long time. This thread mainly concerns people who don't run a compositing manager - and for this usage case a solution is also provided (but it slows down your GPU quite a lot).
The fact that VSync fixes this issue for OpenGL compositing managers has been known for a very long time. This thread mainly concerns people who don't run a compositing manager - and for this usage case a solution is also provided (but it slows down your GPU quite a lot).

Artem S. Tashkinov
Linux and Open Source advocate

Posted 12/14/2013 12:26 PM   
Yes, this option is fixing the issue, but take a look at resources utilization when you for example move a windows. It shouldn't be like that, and Atomatic/Standard vsync option is working fine on not broken hardware/drivers.
Yes, this option is fixing the issue, but take a look at resources utilization when you for example move a windows. It shouldn't be like that, and Atomatic/Standard vsync option is working fine on not broken hardware/drivers.

Posted 12/19/2013 08:36 AM   
The option from Al777 indeed fixes the issue (thank you very much, by the way). I only have this issue since I re-installed my PC with openSUSE 13.1 with nvidia driver 325.15. I did not have this issue on openSUSE 12.1 with nvidia driver 319.23. So, what does this mean? Is this a bug introduced in a more recent driver?
The option from Al777 indeed fixes the issue (thank you very much, by the way). I only have this issue since I re-installed my PC with openSUSE 13.1 with nvidia driver 325.15. I did not have this issue on openSUSE 12.1 with nvidia driver 319.23. So, what does this mean? Is this a bug introduced in a more recent driver?

Posted 12/25/2013 05:05 PM   
Scroll To Top

Add Reply