How do I make the Nvidia graphics card the default in my laptop?
Hi: I have a SONY VAIO FIt-15 (Core i7 + Intel HD 4000/Nvidia GT 735M) I want have the Nvidia graphics for default (No matter if I have to disable the driver Intel or the battery life). I was using the bumblebee software, but it is insufficient, for example, the "Color Config" in Nvidia is much better than Intel, but doesn't works with Bumblebee. So, How do I make the Nvidia graphics card the default in my laptop? S.O: OpenSUSE 12.3 (x86_64) Kernel: 3.10 D.E: KDE 4.10.4
Hi:

I have a SONY VAIO FIt-15 (Core i7 + Intel HD 4000/Nvidia GT 735M)

I want have the Nvidia graphics for default (No matter if I have to disable the driver Intel or the battery life).

I was using the bumblebee software, but it is insufficient, for example, the "Color Config" in Nvidia is much better than Intel, but doesn't works with Bumblebee. So, How do I make the Nvidia graphics card the default in my laptop?

S.O: OpenSUSE 12.3 (x86_64)
Kernel: 3.10
D.E: KDE 4.10.4

#1
Posted 07/22/2013 03:30 PM   
1) First, make sure you've totally removed Bumblebee. 2) You need to modify your xorg.conf I use the following /etc/X11/xorg.conf file to make it work on openSUSE: http://pastebin.com/Rr5SyZJy (similar to the official one http://us.download.nvidia.com/XFree86/Linux-x86/319.32/README/randr14.html) 3) You need to modify your ~/.xinitrc Find where it says "Add your own lines here..." at the end of the file, and add: xrandr --setprovideroutputsource modesetting NVIDIA-0 xrandr --auto As you installed the nvidia driver manually (it's the only solution with kernel 3.10, I guess), it's possible that the libglx.so symbolic link created by the nvidia installer often gets overwritten by a libglx.so from openSUSE xorg updates. You'll have to fix that link or applications will crash: sudo ln -s /usr/lib64/xorg/modules/extensions/libglx.so.319.32 /usr/lib64/xorg/modules/extensions/libglx.so (replace 319.32 by your driver version)
1) First, make sure you've totally removed Bumblebee.

2) You need to modify your xorg.conf
I use the following /etc/X11/xorg.conf file to make it work on openSUSE:

http://pastebin.com/Rr5SyZJy

(similar to the official one http://us.download.nvidia.com/XFree86/Linux-x86/319.32/README/randr14.html)


3) You need to modify your ~/.xinitrc
Find where it says "Add your own lines here..." at the end of the file, and add:
xrandr --setprovideroutputsource modesetting NVIDIA-0
xrandr --auto

As you installed the nvidia driver manually (it's the only solution with kernel 3.10, I guess), it's possible that the libglx.so symbolic link created by the nvidia installer often gets overwritten by a libglx.so from openSUSE xorg updates. You'll have to fix that link or applications will crash:
sudo ln -s /usr/lib64/xorg/modules/extensions/libglx.so.319.32 /usr/lib64/xorg/modules/extensions/libglx.so
(replace 319.32 by your driver version)

#2
Posted 07/22/2013 05:20 PM   
[quote="AnAkkk"]1) First, make sure you've totally removed Bumblebee. 2) You need to modify your xorg.conf I use the following /etc/X11/xorg.conf file to make it work on openSUSE: http://pastebin.com/Rr5SyZJy (similar to the official one http://us.download.nvidia.com/XFree86/Linux-x86/319.32/README/randr14.html) 3) You need to modify your ~/.xinitrc Find where it says "Add your own lines here..." at the end of the file, and add: xrandr --setprovideroutputsource modesetting NVIDIA-0 xrandr --auto As you installed the nvidia driver manually (it's the only solution with kernel 3.10, I guess), it's possible that the libglx.so symbolic link created by the nvidia installer often gets overwritten by a libglx.so from openSUSE xorg updates. You'll have to fix that link or applications will crash: sudo ln -s /usr/lib64/xorg/modules/extensions/libglx.so.319.32 /usr/lib64/xorg/modules/extensions/libglx.so (replace 319.32 by your driver version)[/quote] Thanks but don't works. - I removed Bumblebee - I copied the file /etc/X11/xorg.conf (with the line "EndSection" in the Section "Files") ;) - I copied the file ~/.xinitrc.template to ~/.xinitrc and add the lines in "Add your own lines here..." - Also, moved /usr/lib64/xorg/modules/extensions/libglx.so to /usr/lib64/xorg/modules/extensions/libglx.so.bak (for backup) - Later ln -s /usr/lib64/xorg/modules/extensions/libglx.so.325.08 /usr/lib64/xorg/modules/extensions/libglx.so - Finally reboot and.... Black Screen. My xorg.0.log: http://pastebin.com/HUaqnDRq Also, my xorg.8.log: http://pastebin.com/N9z4FL46
AnAkkk said:1) First, make sure you've totally removed Bumblebee.

2) You need to modify your xorg.conf
I use the following /etc/X11/xorg.conf file to make it work on openSUSE:
http://pastebin.com/Rr5SyZJy
(similar to the official one http://us.download.nvidia.com/XFree86/Linux-x86/319.32/README/randr14.html)

3) You need to modify your ~/.xinitrc
Find where it says "Add your own lines here..." at the end of the file, and add:
xrandr --setprovideroutputsource modesetting NVIDIA-0
xrandr --auto

As you installed the nvidia driver manually (it's the only solution with kernel 3.10, I guess), it's possible that the libglx.so symbolic link created by the nvidia installer often gets overwritten by a libglx.so from openSUSE xorg updates. You'll have to fix that link or applications will crash:
sudo ln -s /usr/lib64/xorg/modules/extensions/libglx.so.319.32 /usr/lib64/xorg/modules/extensions/libglx.so
(replace 319.32 by your driver version)


Thanks but don't works.

- I removed Bumblebee
- I copied the file /etc/X11/xorg.conf (with the line "EndSection" in the Section "Files") ;)
- I copied the file ~/.xinitrc.template to ~/.xinitrc and add the lines in "Add your own lines here..."
- Also, moved /usr/lib64/xorg/modules/extensions/libglx.so to
/usr/lib64/xorg/modules/extensions/libglx.so.bak (for backup)

- Later
ln -s /usr/lib64/xorg/modules/extensions/libglx.so.325.08 /usr/lib64/xorg/modules/extensions/libglx.so

- Finally reboot and.... Black Screen.

My xorg.0.log: http://pastebin.com/HUaqnDRq
Also, my xorg.8.log: http://pastebin.com/N9z4FL46

#3
Posted 07/23/2013 09:40 PM   
You need to add:xrandr --output LVDS-0 --off before xrandr --auto in your .xinitrc. X.org 1.13.2 has a bug that was fixed in later versions. Also, you need to be running the xrandr program version 1.4.0: $ xrandr --version xrandr program version 1.4.0
You need to add:xrandr --output LVDS-0 --off
before xrandr --auto in your .xinitrc. X.org 1.13.2 has a bug that was fixed in later versions. Also, you need to be running the xrandr program version 1.4.0:
$ xrandr --version
xrandr program version 1.4.0

#4
Posted 07/24/2013 02:02 PM   
Thanks, but I have Black Screen again ... :( Well... I installed the version from the "Factory Repository" (7.6_1-8.2), but the X server is also 1.13.2. Supposedly this is the Stable Version. My "xrandr" version is 1.4.0 Note: I tried without /etc/X11/xorg.conf and I can start KDE, so, maybe the problem is with this file.
Thanks, but I have Black Screen again ... :(


Well... I installed the version from the "Factory Repository" (7.6_1-8.2), but the X server is also 1.13.2. Supposedly this is the Stable Version.

My "xrandr" version is 1.4.0

Note:

I tried without /etc/X11/xorg.conf and I can start KDE, so, maybe the problem is with this file.

#5
Posted 07/24/2013 05:01 PM   
Did you uncomment the UseDisplayDevice = "none" line in the nvidia Screen section in xorg.conf? You need to do that if you're only using the laptop screen and no others.
Did you uncomment the UseDisplayDevice = "none" line in the nvidia Screen section in xorg.conf? You need to do that if you're only using the laptop screen and no others.

#6
Posted 07/26/2013 12:43 AM   
I uncommented the line UseDisplayDevice = "none" but I had black screen again. :( The black screen always appears before of the "Login Screen"(KDM), My Xorg.0.log is: http://pastebin.com/cwSLJzM9 And my Xorg.8.log is: http://pastebin.com/ye0x2wF1
I uncommented the line UseDisplayDevice = "none" but I had black screen again. :(
The black screen always appears before of the "Login Screen"(KDM),

My Xorg.0.log is:

http://pastebin.com/cwSLJzM9


And my Xorg.8.log is:

http://pastebin.com/ye0x2wF1

#7
Posted 07/26/2013 11:14 PM   
Oh, you're using KDM. The commands in the .xinitrc won't get called when KDM starts. It'll read .xsessionrc, but only after login. To make sure the Nvidia card and Intel card are working properly, log in in text mode and call startx. That should work. If it works, you'll need to put xrandr commands into something KDM reads at start.
Oh, you're using KDM. The commands in the .xinitrc won't get called when KDM starts. It'll read .xsessionrc, but only after login. To make sure the Nvidia card and Intel card are working properly, log in in text mode and call startx. That should work. If it works, you'll need to put xrandr commands into something KDM reads at start.

#8
Posted 07/27/2013 02:14 AM   
Here is how to add them to the KDM startup scripts: https://wiki.archlinux.org/index.php/Xrandr#Setting_xrandr_commands_in_kdm.2Fgdm_startup_scripts
Here is how to add them to the KDM startup scripts: https://wiki.archlinux.org/index.php/Xrandr#Setting_xrandr_commands_in_kdm.2Fgdm_startup_scripts

#9
Posted 07/27/2013 02:15 AM   
Your xrandr version might be too old. Try adding the X11 repository, it might help: http://download.opensuse.org/repositories/X11:/XOrg/openSUSE_12.3/
Your xrandr version might be too old.
Try adding the X11 repository, it might help:


http://download.opensuse.org/repositories/X11:/XOrg/openSUSE_12.3/

#10
Posted 07/29/2013 06:36 PM   
First: THANKS! Sorry for the delay, I was sick. 1. I updated my packages from http://download.opensuse.org/repositories/X11:/XOrg/openSUSE_12.3/ 2. I disabled the "DisplayManager". 3. Now my Nvidia chip works for Default. ^_^ Really, YOU ROCKS!. THANKS AGAIN. Now, I have only a problem... the "nvidia-config" doesn't have "Color Config". :( So, I can't adjust gamma/brightness/contrast. Neither works "System Preferences > Screen > Gamma" nor "xcalib". Temporarily I'm using: xrandr --output LVDS-0 --gamma 0.68:0.68:0.68 --brightness 0.96 Someone has managed to run the nvidia-config with "color-config"?
First: THANKS!

Sorry for the delay, I was sick.

1. I updated my packages from http://download.opensuse.org/repositories/X11:/XOrg/openSUSE_12.3/

2. I disabled the "DisplayManager".
3. Now my Nvidia chip works for Default. ^_^

Really, YOU ROCKS!. THANKS AGAIN.

Now, I have only a problem... the "nvidia-config" doesn't have "Color Config". :(
So, I can't adjust gamma/brightness/contrast. Neither works "System Preferences > Screen > Gamma" nor "xcalib".

Temporarily I'm using:
xrandr --output LVDS-0 --gamma 0.68:0.68:0.68 --brightness 0.96

Someone has managed to run the nvidia-config with "color-config"?

#11
Posted 07/31/2013 06:00 PM   
I have a similar issue disabling my Intel HD Graphics 3000 for an NVIDIA GT540M installed in a Novatech nSpire Pro 2640m i7 2nd Generation Intel HM65 Chipset. I tried disabling it but comes back as a default can anyone assist here ??
I have a similar issue disabling my Intel HD Graphics 3000 for an NVIDIA GT540M installed in a Novatech nSpire Pro 2640m i7 2nd Generation Intel HM65 Chipset. I tried disabling it but comes back as a default can anyone assist here ??

#12
Posted 08/02/2013 12:38 AM   
Dear zchronos, Could you please describe your solution that worked in a bit more detail? Did you add the xrandr lines to a config file (which one exactly)? How did you disable DisplayManager? Thanks a lot...
Dear zchronos,

Could you please describe your solution that worked in a bit more detail? Did you add the xrandr lines to a config file (which one exactly)? How did you disable DisplayManager?

Thanks a lot...

#13
Posted 08/05/2013 10:55 AM   
Hi szpari, My solution(thanks to "AnAkkk" and "conky_vs_julian") was: 1. I updated my packages from http://download.opensuse.org/repositories/X11:/XOrg/openSUSE_12.3/ 2. I disabled the "DisplayManager". (Yast > Users Management > Advanced > Session > Automatic Login) 3. Close session and init 3. 4. Install Nvidia Driver (NVIDIA-Linux-x86_64-325.08.run in my case with patch by my kernel version) 5. Copy xorg.conf to /etc/X11/ ( http://pastebin.com/1DLiv96N ) 6. Check symbolic link, if is different then: mv /usr/lib64/xorg/modules/extensions/libglx.so /usr/lib64/xorg/modules/extensions/libglx.bak (only for backup) ln -s /usr/lib64/xorg/modules/extensions/libglx.so.325.08 /usr/lib64/xorg/modules/extensions/libglx.so (create the symbolic link) 7. Copy the ~/.xinitrc.template to ~/.xinitrc 8. Edit the .xinitrc ( http://pastebin.com/4H7p0RAh ) 9. Reboot The Nvidia chip works, but I can't configure the colors with nvidia-config. Uguu~
Hi szpari,

My solution(thanks to "AnAkkk" and "conky_vs_julian") was:

1. I updated my packages from http://download.opensuse.org/repositories/X11:/XOrg/openSUSE_12.3/
2. I disabled the "DisplayManager". (Yast > Users Management > Advanced > Session > Automatic Login)
3. Close session and init 3.
4. Install Nvidia Driver (NVIDIA-Linux-x86_64-325.08.run in my case with patch by my kernel version)
5. Copy xorg.conf to /etc/X11/ ( http://pastebin.com/1DLiv96N )
6. Check symbolic link, if is different then:

mv /usr/lib64/xorg/modules/extensions/libglx.so /usr/lib64/xorg/modules/extensions/libglx.bak
(only for backup)
ln -s /usr/lib64/xorg/modules/extensions/libglx.so.325.08 /usr/lib64/xorg/modules/extensions/libglx.so
(create the symbolic link)

7. Copy the ~/.xinitrc.template to ~/.xinitrc
8. Edit the .xinitrc ( http://pastebin.com/4H7p0RAh )

9. Reboot

The Nvidia chip works, but I can't configure the colors with nvidia-config. Uguu~

#14
Posted 08/07/2013 02:06 PM   
Are you making this in linux OS? I've the same problem in windows 7! How to change with that?
Are you making this in linux OS? I've the same problem in windows 7! How to change with that?

#15
Posted 12/19/2013 05:22 AM   
Scroll To Top