wrong libGL.la in /usr/lib64 (nvidia x86_64 319.xx,325.xx)
Hi, On slackware64, the nvidia installer overwrites /usr/lib64/libGL.la with the version that should be installed in /usr/lib, which leads to linkage error as stated in this thread:[url]http://www.linuxquestions.org/questions/slackware-14/building-libav-with-64-bit-nvidia-drivers-32bit-compatibility-drivers-4175470076/[/url] This issue is encountered with nvidia 319.{12,17,23,32,49} 325.{08,15}, even when answering "no" to the question "Install NVIDIA's 32-bit compatibility OpenGL libraries?" This issue does not occur with the nvidia installer 313.30 I looked for libGL.la into the nvidia-installer.log, and I found this : 313.30 [code] -> Installing: /tmp/template-XyKbG6 --> /usr/lib64/libGL.la -> Deleting: /tmp/template-XyKbG6 -> Installing: /tmp/template-bD194g --> /usr/lib/libGL.la -> Deleting: /tmp/template-bD194g [/code] 319.12->319.49 and 325.08,325.15 [code] -> Installing: /tmp/template-N73yXK --> /usr/lib64/libGL.la -> Deleting: /tmp/template-N73yXK -> Installing: /tmp/template-XZIIRT --> /usr/lib64/libGL.la -> Deleting: /tmp/template-XZIIRT[/code] [/code] 319.12 (Install NVIDIA's 32-bit compatibility OpenGL libraries ? No) [code] [...] -> Install NVIDIA's OpenGL header files? (Answer: No) [...] -> Installing: /tmp/template-HACVKO --> /usr/lib64/libGL.la -> Deleting: /tmp/template-HACVKO -> Installing: /tmp/template-69q8jK --> /usr/lib64/libGL.la -> Deleting: /tmp/template-69q8jK [/code]
Hi,

On slackware64, the nvidia installer overwrites /usr/lib64/libGL.la with the version that should be installed in /usr/lib, which leads to linkage error as stated in this thread:http://www.linuxquestions.org/questions/slackware-14/building-libav-with-64-bit-nvidia-drivers-32bit-compatibility-drivers-4175470076/

This issue is encountered with nvidia 319.{12,17,23,32,49} 325.{08,15}, even when answering "no" to the question "Install NVIDIA's 32-bit compatibility OpenGL libraries?" This issue does not occur with the nvidia installer 313.30

I looked for libGL.la into the nvidia-installer.log, and I found this :

313.30
-> Installing: /tmp/template-XyKbG6 --> /usr/lib64/libGL.la
-> Deleting: /tmp/template-XyKbG6
-> Installing: /tmp/template-bD194g --> /usr/lib/libGL.la
-> Deleting: /tmp/template-bD194g


319.12->319.49 and 325.08,325.15
-> Installing: /tmp/template-N73yXK --> /usr/lib64/libGL.la
-> Deleting: /tmp/template-N73yXK
-> Installing: /tmp/template-XZIIRT --> /usr/lib64/libGL.la
-> Deleting: /tmp/template-XZIIRT
[/code]

319.12 (Install NVIDIA's 32-bit compatibility OpenGL libraries ? No)
[...]
-> Install NVIDIA's OpenGL header files? (Answer: No)
[...]
-> Installing: /tmp/template-HACVKO --> /usr/lib64/libGL.la
-> Deleting: /tmp/template-HACVKO
-> Installing: /tmp/template-69q8jK --> /usr/lib64/libGL.la
-> Deleting: /tmp/template-69q8jK

#1
Posted 09/03/2013 12:13 PM   
Please attach nvidia bug report.
Please attach nvidia bug report.

Thanks,
Sandip.

#2
Posted 09/03/2013 01:28 PM   
Sorry, I forgot to attach this one. Added to my first post.
Sorry, I forgot to attach this one. Added to my first post.

#3
Posted 09/03/2013 01:49 PM   
Internally filed Bug 1361153 to track this issue.
Internally filed Bug 1361153 to track this issue.

Thanks,
Sandip.

#4
Posted 09/03/2013 03:32 PM   
Is there any further news for this bug? Would check the internal bug tracker if I could.. :)
Is there any further news for this bug?

Would check the internal bug tracker if I could.. :)

#5
Posted 10/10/2013 10:50 AM   
Zordrak, I think issue got fixed, Did you tested 319.60 and 331.13 driver?
Zordrak, I think issue got fixed, Did you tested 319.60 and 331.13 driver?

Thanks,
Sandip.

#6
Posted 10/10/2013 04:51 PM   
Scroll To Top