Nsight disconnected immediately
Hi, I was trying to use Nsight graphic debugging for my application. Nsight worked for another smaller application/demo, but failed on my working project. So far what I tried and all failed: 1: try using secure connection 2: try different ports 3: try abort on synchronize failure on/off 4: try to look for the logs in %appdata%, no error was logged. the latest error looks like [code]Error,01/07/2014 16:24:37,devenv.exe,'Communications localhost' id: 52,[comms]," at Nvda.Device.WcfCommunicationChannel..ctor(Guid communicationsThreadId, String clientName, String remoteHostName, Int32 port, String channelName, Boolean secure) ",,MultiProducerMessageQueue.ProcessMessage => MultiProducerMessageQueue.ExecuteFunctorDelegate => <>c__DisplayClass3.<BeginCreateSession>b__0 => WcfCommunicationChannelFactory.Nvda.Device.ICommunicationChannelFactory.CreateChannel => WcfCommunicationChannel..ctor => NLogLogger.Log => NLogLogger.LogCore[/code] There's no error when I just start debugging the application normally. It only took less than 1 second between Nsight connected/disconnected. Platform: GTX670, windows7 firewall disabled, VS2010, Nsight 3.2.2.13342, Driver 331.82. Tried some older Nsight but result is the same. Any inputs are much appreciated.
Hi, I was trying to use Nsight graphic debugging for my application. Nsight worked for another smaller application/demo, but failed on my working project.

So far what I tried and all failed:
1: try using secure connection
2: try different ports
3: try abort on synchronize failure on/off
4: try to look for the logs in %appdata%, no error was logged. the latest error looks like
Error,01/07/2014 16:24:37,devenv.exe,'Communications localhost' id: 52,[comms],"   at Nvda.Device.WcfCommunicationChannel..ctor(Guid communicationsThreadId, String clientName, String remoteHostName, Int32 port, String channelName, Boolean secure)
",,MultiProducerMessageQueue.ProcessMessage => MultiProducerMessageQueue.ExecuteFunctorDelegate => <>c__DisplayClass3.<BeginCreateSession>b__0 => WcfCommunicationChannelFactory.Nvda.Device.ICommunicationChannelFactory.CreateChannel => WcfCommunicationChannel..ctor => NLogLogger.Log => NLogLogger.LogCore



There's no error when I just start debugging the application normally. It only took less than 1 second between Nsight connected/disconnected.

Platform:
GTX670, windows7 firewall disabled, VS2010, Nsight 3.2.2.13342, Driver 331.82. Tried some older Nsight but result is the same.

Any inputs are much appreciated.

#1
Posted 01/07/2014 09:49 PM   
Scroll To Top

Add Reply