Nsight crashes at start debugging
I'm trying to use nsight debugging on a really simple program. When i start debugging, application crashes and a window is opened to save dump info. Sometimes i can see the first frame but no more. Any suggestion or idea? The program works well without nsight debugging. Nsight monitor is up and some info is poped up when debbuging connects and disconnects. It seems to works well. I'm using OGL 4.3, SDL 2.0 and GL3W. The computer is a laptop MSI i5 - 4210H, GTX850M, 4GB RAM
I'm trying to use nsight debugging on a really simple program. When i start debugging, application crashes and a window is opened to save dump info.
Sometimes i can see the first frame but no more. Any suggestion or idea?
The program works well without nsight debugging.

Nsight monitor is up and some info is poped up when debbuging connects and disconnects. It seems to works well.

I'm using OGL 4.3, SDL 2.0 and GL3W.
The computer is a laptop MSI i5 - 4210H, GTX850M, 4GB RAM

#1
Posted 03/23/2015 01:00 AM   
Hi Korgan, Maybe you need to check your Nsight User settings, make sure your 'working directory' is set as expected. Thanks An
Hi Korgan,

Maybe you need to check your Nsight User settings, make sure your 'working directory' is set as expected.

Thanks
An

#2
Posted 03/23/2015 02:54 AM   
I got it. If anybody else has the same problem and a "bug report" maybe. If i duplicate a visual studio project that works well with nsight, and then i try to debug with the project copy, then nsight wont work. Can anybody to confirm my theory at other computers? I use visual studio 2013. Thx anyway AYan.
I got it.
If anybody else has the same problem and a "bug report" maybe.
If i duplicate a visual studio project that works well with nsight, and then i try to debug with the project copy, then nsight wont work.
Can anybody to confirm my theory at other computers?

I use visual studio 2013.

Thx anyway AYan.

#3
Posted 03/24/2015 12:22 AM   
Same same but diffrent, I have exactly the same problem but with DX11. Start debugging with Nsight -> Start Graphics Debugging -> App Window pops up -> window is opened to save dump info. Using DirectX 11 and Visual Studio 2012. 'Working directory' is set correctly. System: Windows 8.1 Pro 64Bit Core i5 3.1GHz GTX 760 driver: 347.88 8GB Ram Visual Studio 2012 Nsight 4.6.0.15071
Same same but diffrent,

I have exactly the same problem but with DX11. Start debugging with Nsight -> Start Graphics Debugging -> App Window pops up -> window is opened to save dump info.

Using DirectX 11 and Visual Studio 2012. 'Working directory' is set correctly.

System:
Windows 8.1 Pro 64Bit
Core i5 3.1GHz
GTX 760 driver: 347.88
8GB Ram
Visual Studio 2012
Nsight 4.6.0.15071

#4
Posted 03/26/2015 11:14 AM   
Hi Takatu, Any chance we can have the dmp file? Even better, can you share us your sample and we can do more detail investigate? Thanks An
Hi Takatu,

Any chance we can have the dmp file? Even better, can you share us your sample and we can do more detail investigate?

Thanks
An

#5
Posted 03/27/2015 02:43 AM   
I do some other tests. I got the error because of nvidia configuration doesnt configure the exe as high performance graphics by default. In some projects i have it configured (in nvidia control panel) and it worked well, but if i copy the project, the new exe isnt configured (in nvidia control panel). When it is configured correctly then it doesnt crash. I hope this help you Takatu. AYan, Is there any way to say to the program that it is a graphics intense program and should be launched by high perf graphics processor?
I do some other tests. I got the error because of nvidia configuration doesnt configure the exe as high performance graphics by default.
In some projects i have it configured (in nvidia control panel) and it worked well, but if i copy the project, the new exe isnt configured (in nvidia control panel). When it is configured correctly then it doesnt crash.

I hope this help you Takatu.

AYan, Is there any way to say to the program that it is a graphics intense program and should be launched by high perf graphics processor?

#6
Posted 03/27/2015 11:01 AM   
Hi, AFAIK, config it to nvidia control panel is the easiest way, or you can try to plug an extra monitor to your laptop's external graphics port, that might force activate your dGPU, then you need to render your sample on that monitor to use the dGPU. @Takatu, your GPU sounds like a standalone version, but not the mobile one for laptop, right? Thanks An
Hi,

AFAIK, config it to nvidia control panel is the easiest way, or you can try to plug an extra monitor to your laptop's external graphics port, that might force activate your dGPU, then you need to render your sample on that monitor to use the dGPU.

@Takatu, your GPU sounds like a standalone version, but not the mobile one for laptop, right?

Thanks
An

#7
Posted 03/30/2015 03:58 AM   
Yeah, probably, that is the easiest way but im thinking on a general solution, not an adhoc solution. if i launch the program in any computer, graphics card should be the default target. Thanks anyway.
Yeah, probably, that is the easiest way but im thinking on a general solution, not an adhoc solution. if i launch the program in any computer, graphics card should be the default target.

Thanks anyway.

#8
Posted 03/30/2015 07:32 AM   
I had similar issue on my desktop (GTX780, Win10 64bit) and had to disable integrated GPU in the Device Manager to prevent app crashes when starting GPU debugging with NSight. Thanks! The hints here were very helpful.
I had similar issue on my desktop (GTX780, Win10 64bit) and had to disable integrated GPU in the Device Manager to prevent app crashes when starting GPU debugging with NSight. Thanks! The hints here were very helpful.

#9
Posted 10/26/2016 08:51 PM   
Hi, Use which GPU really depends on your BIOS and OS/Driver settings in your situation. I meet some similar issue that need to disable iGPU in BIOS. Thanks An
Hi,

Use which GPU really depends on your BIOS and OS/Driver settings in your situation. I meet some similar issue that need to disable iGPU in BIOS.

Thanks
An

#10
Posted 12/23/2016 08:21 AM   
Scroll To Top

Add Reply