[HowTo]Install VirtualGL and TurboVNC to Jetson TK1
Tips: [b]Run OpenGL program from VNC client using VirtualGL:[/b] [code]/opt/VirtualGL/bin/vglrun ./OpenGLProgram[/code] [b]Securing a TurboVNC Connection[/b] Add "-localhost" option to vncserver. "-localhost" option prevents remote VNC clients from connecting except when doing so through a secure tunnel. Make sure that ssh server is running on your Jetson TK1. On linux client, [code]ssh -L 5901:localhost:5901 ubuntu@tegra-ubuntu[/code] (Add "-f -N" option if you want ssh runs in background) Client viewer connect to localhost:5901 [code]vncviewer localhost:1[/code] For more details: [url]https://cdn.rawgit.com/TurboVNC/turbovnc/2.0/doc/index.html#hd006005[/url] [b]Executing program from ssh and showing windows on the desktop[/b] [code]export DISPLAY=:1 firefox &[/code] [b]Automatically starting TurboVNC server on every bootup[/b] [code]#Open /etc/sysconfig/tvncservers, uncomment last 2 lines and edit options. sudo vi /etc/sysconfig/tvncservers sudo update-rc.d tvncserver defaults[/code] Stop running TurboVNC server on boot [code]sudo update-rc.d tvncserver disable[/code] Enable running TurboVNC server on boot again [code]sudo update-rc.d tvncserver enable[/code]
Tips:
Run OpenGL program from VNC client using VirtualGL:
/opt/VirtualGL/bin/vglrun ./OpenGLProgram


Securing a TurboVNC Connection
Add "-localhost" option to vncserver.
"-localhost" option prevents remote VNC clients from connecting except when doing so through a secure tunnel.
Make sure that ssh server is running on your Jetson TK1.
On linux client,
ssh -L 5901:localhost:5901 ubuntu@tegra-ubuntu

(Add "-f -N" option if you want ssh runs in background)
Client viewer connect to localhost:5901
vncviewer localhost:1

For more details:
https://cdn.rawgit.com/TurboVNC/turbovnc/2.0/doc/index.html#hd006005

Executing program from ssh and showing windows on the desktop
export DISPLAY=:1
firefox &


Automatically starting TurboVNC server on every bootup
#Open /etc/sysconfig/tvncservers, uncomment last 2 lines and edit options.
sudo vi /etc/sysconfig/tvncservers
sudo update-rc.d tvncserver defaults

Stop running TurboVNC server on boot
sudo update-rc.d tvncserver disable

Enable running TurboVNC server on boot again
sudo update-rc.d tvncserver enable

#16
Posted 10/04/2015 10:50 AM   
I have built VirtualGL, TurboVNC and libjpeg-turbo for 64-bit Linux For Tegra R24.1. But they are not test on Jetson TX1. They were built and tested on Nvidia Shield Android TV with 64-bit Linux For Tegra R24.1. They might work on Jetson TX1 with 64-bit L4T R24.1, because same 64-bit Sample Root Filesystem and 64-bit driver package for Jetson TX1 is used on my Shield TV. Edit: deb package files built on Linux For Tegra R24.2: http://demotomohiro.github.io/hardware/jetson_tk1/pkg/l4t24.2/libjpeg-turbo_1.5.2_arm64.deb http://demotomohiro.github.io/hardware/jetson_tk1/pkg/l4t24.2/turbovnc_2.1_arm64.deb http://demotomohiro.github.io/hardware/jetson_tk1/pkg/l4t24.2/virtualgl_2.5.1_arm64.deb [b]How to install:[/b] [code]wget http://demotomohiro.github.io/hardware/jetson_tk1/pkg/libjpeg-turbo_1.5.1_arm64.deb wget http://demotomohiro.github.io/hardware/jetson_tk1/pkg/virtualgl_2.5.1_arm64.deb wget http://demotomohiro.github.io/hardware/jetson_tk1/pkg/turbovnc_2.0.91_arm64.deb sudo dpkg -i libjpeg-turbo_1.5.1_arm64.deb sudo dpkg -i virtualgl_2.5.1_arm64.deb sudo dpkg -i turbovnc_2.0.91_arm64.deb sudo vi /etc/ld.so.conf.d/libjpeg-turbo.conf[/code] Add the following line [code]/opt/libjpeg-turbo/lib64[/code] [code]sudo ldconfig #Configure VirtualGL #https://cdn.rawgit.com/VirtualGL/virtualgl/2.5/doc/index.html#hd006 sudo /opt/VirtualGL/bin/vglserver_config sudo usermod -a -G vglusers ubuntu #Star TurboVNC /opt/TurboVNC/bin/vncserver #Stop TurboVNC /opt/TurboVNC/bin/vncserver -kill :1 #install xfce4 sudo apt-get install xfce4 gnome-icon-theme-full xfce4-terminal vi .vnc/xstartup.turbovnc[/code] Set following text [code]#!/bin/sh unset SESSION_MANAGER unset DBUS_SESSION_BUS_ADDRESS startxfce4 &[/code] Run OpenGL program from VNC client. [code]/opt/VirtualGL/bin/vglrun ./OpenGLProgram[/code] If you see black menu or panels, disable screen saver.
I have built VirtualGL, TurboVNC and libjpeg-turbo for 64-bit Linux For Tegra R24.1.
But they are not test on Jetson TX1.
They were built and tested on Nvidia Shield Android TV with 64-bit Linux For Tegra R24.1.
They might work on Jetson TX1 with 64-bit L4T R24.1, because same 64-bit Sample Root Filesystem and 64-bit driver package for Jetson TX1 is used on my Shield TV.

Edit:
deb package files built on Linux For Tegra R24.2:
http://demotomohiro.github.io/hardware/jetson_tk1/pkg/l4t24.2/libjpeg-turbo_1.5.2_arm64.deb
http://demotomohiro.github.io/hardware/jetson_tk1/pkg/l4t24.2/turbovnc_2.1_arm64.deb
http://demotomohiro.github.io/hardware/jetson_tk1/pkg/l4t24.2/virtualgl_2.5.1_arm64.deb

How to install:
wget http://demotomohiro.github.io/hardware/jetson_tk1/pkg/libjpeg-turbo_1.5.1_arm64.deb
wget http://demotomohiro.github.io/hardware/jetson_tk1/pkg/virtualgl_2.5.1_arm64.deb
wget http://demotomohiro.github.io/hardware/jetson_tk1/pkg/turbovnc_2.0.91_arm64.deb

sudo dpkg -i libjpeg-turbo_1.5.1_arm64.deb
sudo dpkg -i virtualgl_2.5.1_arm64.deb
sudo dpkg -i turbovnc_2.0.91_arm64.deb

sudo vi /etc/ld.so.conf.d/libjpeg-turbo.conf

Add the following line
/opt/libjpeg-turbo/lib64

sudo ldconfig

#Configure VirtualGL
#https://cdn.rawgit.com/VirtualGL/virtualgl/2.5/doc/index.html#hd006
sudo /opt/VirtualGL/bin/vglserver_config
sudo usermod -a -G vglusers ubuntu

#Star TurboVNC
/opt/TurboVNC/bin/vncserver
#Stop TurboVNC
/opt/TurboVNC/bin/vncserver -kill :1

#install xfce4
sudo apt-get install xfce4 gnome-icon-theme-full xfce4-terminal

vi .vnc/xstartup.turbovnc

Set following text
#!/bin/sh

unset SESSION_MANAGER
unset DBUS_SESSION_BUS_ADDRESS
startxfce4 &


Run OpenGL program from VNC client.
/opt/VirtualGL/bin/vglrun ./OpenGLProgram

If you see black menu or panels, disable screen saver.

#17
Posted 07/31/2016 02:30 PM   
[b]How to built VirtualGL, TurboVNC and libjpeg-turbo for 64-bit Linux For Tegra R24.1.[/b] [code]#install necessary packages to build them. sudo apt-get install git sudo apt-get install autoconf sudo apt-get install libtool sudo apt-get install cmake sudo apt-get install g++ sudo apt-get install libpam0g-dev sudo apt-get install libssl-dev #Build and install libjpeg-turbo git clone https://github.com/libjpeg-turbo/libjpeg-turbo.git mkdir libjpeg-turbo-build cd libjpeg-turbo autoreconf -fiv cd ../libjpeg-turbo-build sh ../libjpeg-turbo/configure make vi pkgscripts/makedpkg.tmpl #Change "DEBARCH=aarch64" to "DEBARCH=arm64" make deb sudo dpkg -i libjpeg-turbo_1.5.1_arm64.deb cd ../ #Build and install VirtualGL git clone https://github.com/VirtualGL/virtualgl.git mkdir virtualgl-build cd virtualgl-build cmake -G "Unix Makefiles" -DTJPEG_LIBRARY="-L/opt/libjpeg-turbo/lib64/ -lturbojpeg" ../virtualgl make[/code] If you got link error from "libGL.so", check this: [url]https://devtalk.nvidia.com/default/topic/946136/jetson-tx1/building-an-opengl-application/[/url] [code]vi pkgscripts/makedpkg #Change "DEBARCH=aarch64" to "DEBARCH=arm64" vi pkgscripts/deb-control #Change "Architecture: aarch64" to "Architecture: arm64" make deb sudo dpkg -i virtualgl_2.5.1_arm64.deb cd .. #Build and install TurboVNC git clone https://github.com/TurboVNC/turbovnc.git mkdir turbovnc-build cd turbovnc-build cmake -G "Unix Makefiles" -DTVNC_BUILDJAVA=0 -DTJPEG_LIBRARY="-L/opt/libjpeg-turbo/lib64/ -lturbojpeg" ../turbovnc make[/code] If you got error like #error "GLYPHPADBYTES must be 4", edit ../turbovnc/unix/Xvnc/programs/Xserver/include/servermd.h and add following code before line "#ifdef __avr32__" [code]#ifdef __aarch64__ # define IMAGE_BYTE_ORDER LSBFirst # define BITMAP_BIT_ORDER LSBFirst # define GLYPHPADBYTES 4 #endif[/code] [code]vi pkgscripts/makedpkg #Change "DEBARCH=aarch64" to "DEBARCH=arm64" vi pkgscripts/deb-control #Change "Architecture: aarch64" to "Architecture: arm64" make deb sudo dpkg -i turbovnc_2.0.91_arm64.deb[/code]
How to built VirtualGL, TurboVNC and libjpeg-turbo for 64-bit Linux For Tegra R24.1.
#install necessary packages to build them.
sudo apt-get install git
sudo apt-get install autoconf
sudo apt-get install libtool
sudo apt-get install cmake
sudo apt-get install g++
sudo apt-get install libpam0g-dev
sudo apt-get install libssl-dev

#Build and install libjpeg-turbo
git clone https://github.com/libjpeg-turbo/libjpeg-turbo.git

mkdir libjpeg-turbo-build
cd libjpeg-turbo
autoreconf -fiv
cd ../libjpeg-turbo-build
sh ../libjpeg-turbo/configure
make
vi pkgscripts/makedpkg.tmpl
#Change "DEBARCH=aarch64" to "DEBARCH=arm64"
make deb
sudo dpkg -i libjpeg-turbo_1.5.1_arm64.deb
cd ../

#Build and install VirtualGL
git clone https://github.com/VirtualGL/virtualgl.git

mkdir virtualgl-build
cd virtualgl-build
cmake -G "Unix Makefiles" -DTJPEG_LIBRARY="-L/opt/libjpeg-turbo/lib64/ -lturbojpeg" ../virtualgl
make

If you got link error from "libGL.so", check this:
https://devtalk.nvidia.com/default/topic/946136/jetson-tx1/building-an-opengl-application/
vi pkgscripts/makedpkg
#Change "DEBARCH=aarch64" to "DEBARCH=arm64"
vi pkgscripts/deb-control
#Change "Architecture: aarch64" to "Architecture: arm64"
make deb
sudo dpkg -i virtualgl_2.5.1_arm64.deb
cd ..

#Build and install TurboVNC
git clone https://github.com/TurboVNC/turbovnc.git

mkdir turbovnc-build
cd turbovnc-build
cmake -G "Unix Makefiles" -DTVNC_BUILDJAVA=0 -DTJPEG_LIBRARY="-L/opt/libjpeg-turbo/lib64/ -lturbojpeg" ../turbovnc
make

If you got error like #error "GLYPHPADBYTES must be 4",
edit ../turbovnc/unix/Xvnc/programs/Xserver/include/servermd.h and add following code before line "#ifdef __avr32__"
#ifdef __aarch64__

# define IMAGE_BYTE_ORDER LSBFirst
# define BITMAP_BIT_ORDER LSBFirst
# define GLYPHPADBYTES 4

#endif


vi pkgscripts/makedpkg
#Change "DEBARCH=aarch64" to "DEBARCH=arm64"
vi pkgscripts/deb-control
#Change "Architecture: aarch64" to "Architecture: arm64"
make deb
sudo dpkg -i turbovnc_2.0.91_arm64.deb

#18
Posted 07/31/2016 02:31 PM   
[quote="ShervinEmami_NVIDIA"]Has anyone (besides demotomohiro) been able to follow the instructions above and verify that it works? I haven't had time to test it properly myself, but if someone verifies it works then I'll post it on the Wiki.[/quote] I did verify it and everything works very well. The only two things I had to adapt for deploying it on [i]Jetson TK1[/i] were: [olist] [.]Architecture type for deb packages shall be set to: [code]#In pkgscripts/makedpkg DEBARCH=armhf #In pkgscripts/deb-control Architecture: armhf [/code] [/.] [.]Path to libjpeg-turbo library must point to its 32-bit version: [code]"-L/opt/libjpeg-turbo/lib32/ -lturbojpeg"[/code] [/.] [/olist] On top of that I had to follow those instructions given by [b]dirtydigs[/b]: [quote="dirtydigs"]I've tested it using demotomohiro's binaries, and it works very well:) There can be a slight delay sometimes, but the performance is very good overall. A couple of things though - I didn't have a screen section in my xorg.conf, so I edited it to look like this: [code] Section "Screen" Identifier "Screen0" Device "Tegra0" Monitor "DSI-0" Option "AllowEmptyInitialConfiguration" Option "UseEdid" "False" EndSection [/code] I also had to [code] chmod +x ~/.vnc/xstartup.turbovnc [/code] and to get the tab key working [code] vi ~/.config/xfce4/xfconf/xfce-perchannel-xml/xfce4-keyboard-shortcuts.xml [/code] under the <property name="custom" type="empty"> section find the line <property name="<Super>Tab" type="string" value="switch_window_key"/> and change it to <property name="<Super>Tab" type="empty"/> from [url]http://ubuntuforums.org/archive/index.php/t-1771058.html[/url] tested using windows 8.1 with the jetson connected to the network using a linksys ae1000 and the grinch 21.3.4 Thanks demotomohiro ![/quote] [b]EDIT:[/b] I came across a problem similar to the one previously described by [b]JavierGranado[/b]: [quote="JavierGranado"]I have followed all the steps and I get to control the Jetson TK1 from my Laptop (Ubuntu 14.04 or Windows 8.1), I can only see images from games samples brownser and "no graphics" CUDA samples like "maxMul" but with CUDA samples like "particles" or "ocean FFT" I can't get see anything in my remote desktop. I am sure I am to connect to my Jetson TK1 (I cheked). My Jetson TK! is LAN connected to the router and my Laptop via WIFI access. Any suggestion ? Thanks.[/quote] I can flawlessly run [i]GameWorksOpenGLSamples[/i], but any example from [i]NVIDIA_CUDA-6.5_Samples[/i] yields segmentation fault.
ShervinEmami_NVIDIA said:Has anyone (besides demotomohiro) been able to follow the instructions above and verify that it works? I haven't had time to test it properly myself, but if someone verifies it works then I'll post it on the Wiki.


I did verify it and everything works very well. The only two things I had to adapt for deploying it on Jetson TK1 were:

  1. Architecture type for deb packages shall be set to:
    #In pkgscripts/makedpkg
    DEBARCH=armhf
    #In pkgscripts/deb-control
    Architecture: armhf

  2. Path to libjpeg-turbo library must point to its 32-bit version:
    "-L/opt/libjpeg-turbo/lib32/ -lturbojpeg"



On top of that I had to follow those instructions given by dirtydigs:

dirtydigs said:I've tested it using demotomohiro's binaries, and it works very well:) There can be a slight delay sometimes, but the performance is very good overall.

A couple of things though - I didn't have a screen section in my xorg.conf, so I edited it to look like this:


Section "Screen"
Identifier "Screen0"
Device "Tegra0"
Monitor "DSI-0"
Option "AllowEmptyInitialConfiguration"
Option "UseEdid" "False"
EndSection


I also had to

chmod +x ~/.vnc/xstartup.turbovnc


and to get the tab key working

vi ~/.config/xfce4/xfconf/xfce-perchannel-xml/xfce4-keyboard-shortcuts.xml



under the <property name="custom" type="empty"> section

find the line

<property name="<Super>Tab" type="string" value="switch_window_key"/>

and change it to

<property name="<Super>Tab" type="empty"/>

from http://ubuntuforums.org/archive/index.php/t-1771058.html

tested using windows 8.1 with the jetson connected to the network using a linksys ae1000 and the grinch 21.3.4

Thanks demotomohiro !


EDIT:

I came across a problem similar to the one previously described by JavierGranado:

JavierGranado said:I have followed all the steps and I get to control the Jetson TK1 from my Laptop (Ubuntu 14.04 or Windows 8.1), I can only see images from games samples brownser and "no graphics" CUDA samples like "maxMul" but with CUDA samples like "particles" or "ocean FFT" I can't get see anything in my remote desktop. I am sure I am to connect to my Jetson TK1 (I cheked).

My Jetson TK! is LAN connected to the router and my Laptop via WIFI access.

Any suggestion ?

Thanks.


I can flawlessly run GameWorksOpenGLSamples, but any example from NVIDIA_CUDA-6.5_Samples yields segmentation fault.

#19
Posted 08/12/2016 02:32 PM   
In my Jetson TX1 with L4T R21.4, TurboVNC 2.0.1 and VirtualGL 2.4.1 works without editing xorg.conf and ~/.vnc/xstartup.turbovnc. Tab key works without editing ~/.config/xfce4/xfconf/xfce-perchannel-xml/xfce4-keyboard-shortcuts.xml. Xorg must be running without connecting HDMI display, because default /etc/X11/xorg.conf in L4T R21.4 enables option "AllowEmptyInitialConfiguration". When you run OpenGL program from TurboVNC client, that program must be executed with vglrun. For example: [code]/opt/VirtualGL/bin/vglrun ./oceanFFT[/code] Are you sure that your user is added to "vglusers" group? Do your CUDA samples work when you are using HDMI display? Do your CUDA samples which dont use OpenGL (deviceQuery, matrixMul, etc) work without TurboVNC?
In my Jetson TX1 with L4T R21.4, TurboVNC 2.0.1 and VirtualGL 2.4.1 works without editing xorg.conf and ~/.vnc/xstartup.turbovnc.
Tab key works without editing ~/.config/xfce4/xfconf/xfce-perchannel-xml/xfce4-keyboard-shortcuts.xml.

Xorg must be running without connecting HDMI display, because default /etc/X11/xorg.conf in L4T R21.4 enables option "AllowEmptyInitialConfiguration".

When you run OpenGL program from TurboVNC client, that program must be executed with vglrun.
For example:
/opt/VirtualGL/bin/vglrun ./oceanFFT

Are you sure that your user is added to "vglusers" group?
Do your CUDA samples work when you are using HDMI display?
Do your CUDA samples which dont use OpenGL (deviceQuery, matrixMul, etc) work without TurboVNC?

#20
Posted 08/17/2016 06:29 AM   
[quote="demotomohiro"] Are you sure that your user is added to "vglusers" group? [/quote] Yes, I am sure that my user is added to vglusers group. This is the output of issuing [i]groups[/i] command on user [i]ubuntu[/i] [code] [ubuntu: ~] $ groups ubuntu ubuntu : ubuntu adm dialout sudo audio video vglusers [/code] [quote="demotomohiro"] Do your CUDA samples work when you are using HDMI display? [/quote] Yes, they do work when I launch them using the display directly connected to my [i]Jetson TK1[/i]. [quote="demotomohiro"] Do your CUDA samples which dont use OpenGL (deviceQuery, matrixMul, etc) work without TurboVNC? [/quote] Yes, non-OpenGL examples work flawlessly. This is the output of [i]deviceQuery[/i] program: [code] [ubuntu: ~/NVIDIA_CUDA-6.5_Samples/bin/armv7l/linux/release/gnueabihf] $ ./deviceQuery ./deviceQuery Starting... CUDA Device Query (Runtime API) version (CUDART static linking) Detected 1 CUDA Capable device(s) Device 0: "GK20A" CUDA Driver Version / Runtime Version 6.5 / 6.5 CUDA Capability Major/Minor version number: 3.2 Total amount of global memory: 1892 MBytes (1984385024 bytes) ( 1) Multiprocessors, (192) CUDA Cores/MP: 192 CUDA Cores GPU Clock rate: 852 MHz (0.85 GHz) Memory Clock rate: 924 Mhz Memory Bus Width: 64-bit L2 Cache Size: 131072 bytes Maximum Texture Dimension Size (x,y,z) 1D=(65536), 2D=(65536, 65536), 3D=(4096, 4096, 4096) Maximum Layered 1D Texture Size, (num) layers 1D=(16384), 2048 layers Maximum Layered 2D Texture Size, (num) layers 2D=(16384, 16384), 2048 layers Total amount of constant memory: 65536 bytes Total amount of shared memory per block: 49152 bytes Total number of registers available per block: 32768 Warp size: 32 Maximum number of threads per multiprocessor: 2048 Maximum number of threads per block: 1024 Max dimension size of a thread block (x,y,z): (1024, 1024, 64) Max dimension size of a grid size (x,y,z): (2147483647, 65535, 65535) Maximum memory pitch: 2147483647 bytes Texture alignment: 512 bytes Concurrent copy and kernel execution: Yes with 1 copy engine(s) Run time limit on kernels: No Integrated GPU sharing Host Memory: Yes Support host page-locked memory mapping: Yes Alignment requirement for Surfaces: Yes Device has ECC support: Disabled Device supports Unified Addressing (UVA): Yes Device PCI Bus ID / PCI location ID: 0 / 0 Compute Mode: < Default (multiple host threads can use ::cudaSetDevice() with device simultaneously) > deviceQuery, CUDA Driver = CUDART, CUDA Driver Version = 6.5, CUDA Runtime Version = 6.5, NumDevs = 1, Device0 = GK20A Result = PASS [/code]
demotomohiro said:
Are you sure that your user is added to "vglusers" group?


Yes, I am sure that my user is added to vglusers group. This is the output of issuing groups command on user ubuntu

[ubuntu: ~] $ groups ubuntu
ubuntu : ubuntu adm dialout sudo audio video vglusers


demotomohiro said:
Do your CUDA samples work when you are using HDMI display?


Yes, they do work when I launch them using the display directly connected to my Jetson TK1.

demotomohiro said:
Do your CUDA samples which dont use OpenGL (deviceQuery, matrixMul, etc) work without TurboVNC?


Yes, non-OpenGL examples work flawlessly. This is the output of deviceQuery program:

[ubuntu: ~/NVIDIA_CUDA-6.5_Samples/bin/armv7l/linux/release/gnueabihf] $ ./deviceQuery
./deviceQuery Starting...

CUDA Device Query (Runtime API) version (CUDART static linking)

Detected 1 CUDA Capable device(s)

Device 0: "GK20A"
CUDA Driver Version / Runtime Version 6.5 / 6.5
CUDA Capability Major/Minor version number: 3.2
Total amount of global memory: 1892 MBytes (1984385024 bytes)
( 1) Multiprocessors, (192) CUDA Cores/MP: 192 CUDA Cores
GPU Clock rate: 852 MHz (0.85 GHz)
Memory Clock rate: 924 Mhz
Memory Bus Width: 64-bit
L2 Cache Size: 131072 bytes
Maximum Texture Dimension Size (x,y,z) 1D=(65536), 2D=(65536, 65536), 3D=(4096, 4096, 4096)
Maximum Layered 1D Texture Size, (num) layers 1D=(16384), 2048 layers
Maximum Layered 2D Texture Size, (num) layers 2D=(16384, 16384), 2048 layers
Total amount of constant memory: 65536 bytes
Total amount of shared memory per block: 49152 bytes
Total number of registers available per block: 32768
Warp size: 32
Maximum number of threads per multiprocessor: 2048
Maximum number of threads per block: 1024
Max dimension size of a thread block (x,y,z): (1024, 1024, 64)
Max dimension size of a grid size (x,y,z): (2147483647, 65535, 65535)
Maximum memory pitch: 2147483647 bytes
Texture alignment: 512 bytes
Concurrent copy and kernel execution: Yes with 1 copy engine(s)
Run time limit on kernels: No
Integrated GPU sharing Host Memory: Yes
Support host page-locked memory mapping: Yes
Alignment requirement for Surfaces: Yes
Device has ECC support: Disabled
Device supports Unified Addressing (UVA): Yes
Device PCI Bus ID / PCI location ID: 0 / 0
Compute Mode:
< Default (multiple host threads can use ::cudaSetDevice() with device simultaneously) >

deviceQuery, CUDA Driver = CUDART, CUDA Driver Version = 6.5, CUDA Runtime Version = 6.5, NumDevs = 1, Device0 = GK20A
Result = PASS

#21
Posted 08/18/2016 11:29 AM   
@demotomohiro: I was able to successfully run CUDA samples such as oceanfft on turboVNC using VirtualGL in my TX1. However, ROS RVIZ fails to launch in turboVNC and gives a five second framerate when using virtualGL only. Do you have any solutions for this issue?
@demotomohiro: I was able to successfully run CUDA samples such as oceanfft on turboVNC using VirtualGL in my TX1. However, ROS RVIZ fails to launch in turboVNC and gives a five second framerate when using virtualGL only. Do you have any solutions for this issue?

#22
Posted 12/01/2016 10:02 AM   
CUDA samples using OpenGL didn't work with "vglrun ./filename" on my Shield TV with L4T R24.2.1. They worked by adding "-nodl" option to vglrun like "vglrun -nodl ./filename".
CUDA samples using OpenGL didn't work with "vglrun ./filename" on my Shield TV with L4T R24.2.1.
They worked by adding "-nodl" option to vglrun like "vglrun -nodl ./filename".

#23
Posted 02/08/2017 07:59 PM   
Hi, I am just wondering if the method was tested with Jetson TX2. Does the metod function over Bluetooth? Thanks. https://devtalk.nvidia.com/default/topic/1013381/jetson-tx2/connecting-a-display-tab-via-bluetooth-/
Hi, I am just wondering if the method was tested with Jetson TX2. Does the metod function over Bluetooth? Thanks.
https://devtalk.nvidia.com/default/topic/1013381/jetson-tx2/connecting-a-display-tab-via-bluetooth-/

E pluribus unum

#24
Posted 06/09/2017 08:17 AM   
What about TX2 ? shoud we use DEBARCH=armhf/arm64/aarch64 ? As uname -a is showing the system architecture of type aarch64, I believe it think be aarch64. But when I am using aarch64, it is showing system type is not matching with amd64, what is the exact system architecture then ?
What about TX2 ? shoud we use DEBARCH=armhf/arm64/aarch64 ?
As uname -a is showing the system architecture of type aarch64, I believe it think be aarch64. But when I am using aarch64, it is showing system type is not matching with amd64, what is the exact system architecture then ?

msinvent

#25
Posted 07/21/2017 11:48 AM   
amd64 would be your 64-bit AMD CPU on the desktop PC. This is a TK1 forum, you may want to post in the TX2 forum, but generally speaking arm64 or aarch64 would be correct on a TX2. However, this isn't the issue...the program wasn't compiled to run on a TX2 if it wants amd64. To run on a TX2 it needs to be compiled for that using arm64/aarch64 tools (native tools if built on a TX2, cross-compile tools if built on a PC).
amd64 would be your 64-bit AMD CPU on the desktop PC. This is a TK1 forum, you may want to post in the TX2 forum, but generally speaking arm64 or aarch64 would be correct on a TX2. However, this isn't the issue...the program wasn't compiled to run on a TX2 if it wants amd64. To run on a TX2 it needs to be compiled for that using arm64/aarch64 tools (native tools if built on a TX2, cross-compile tools if built on a PC).

#26
Posted 07/21/2017 08:43 PM   
Do you have the instructions updated? I was trying the old ones but I am not sure if i am doing them right. Thanks in advance.
Do you have the instructions updated? I was trying the old ones but I am not sure if i am doing them right. Thanks in advance.

#27
Posted 08/04/2017 09:13 PM   
On comment #14 when i get to line 4. sudo /opt/VirtualGL/bin/vglserver_config. if i execute it i get the following; [url]https://drive.google.com/open?id=0B4-ooeVD-7cLS3JUR2tzbk1SZFE[/url] is there anything wrong that i did?
On comment #14 when i get to line 4. sudo /opt/VirtualGL/bin/vglserver_config. if i execute it i get the following;
https://drive.google.com/open?id=0B4-ooeVD-7cLS3JUR2tzbk1SZFE
is there anything wrong that i did?

#28
Posted 08/04/2017 09:33 PM   
I'm sorry but I don't have Jetson TX2 and I have never tried them on Jetson TX2. I found the topic about another remote desktop for Jetson TX2. I don't know whether it supports OpenGL like TurboVNC and VirtualGL. [url]https://devtalk.nvidia.com/default/topic/1001017/remote-desktoping-into-jetson-tx2-from-windows-10/[/url] You can find how to build libjpeg-turbo, TurboVNC and VirtualGL in following links: [url]https://github.com/libjpeg-turbo/libjpeg-turbo/blob/master/BUILDING.md[/url] [url]https://github.com/TurboVNC/turbovnc/blob/master/BUILDING.md[/url] [url]https://github.com/VirtualGL/virtualgl/blob/master/BUILDING.md[/url] It seems build procedures for Linux didn't changed since I wrote the comment #18. [quote=""]On comment #14 when i get to line 4. sudo /opt/VirtualGL/bin/vglserver_config. if i execute it i get the following; [url]https://drive.google.com/open?id=0B4-ooeVD-7cLS3JUR2tzbk1SZFE[/url] is there anything wrong that i did?[/quote] vncserver program execute script file ~/.vnc/xstartup.turbovnc. If that error came from that script file, setting following text to that file might fix it. [code]#!/bin/sh unset SESSION_MANAGER unset DBUS_SESSION_BUS_ADDRESS startxfce4 &[/code] Package files on Comment #14 are built for 32bit ARM CPU on Jetson TK1. Package files on Commont #17 are built for 64bit ARM CPU on Shield TV and using newer source codes. Later one might be better for Jetson TX2.
I'm sorry but I don't have Jetson TX2 and I have never tried them on Jetson TX2.

I found the topic about another remote desktop for Jetson TX2.
I don't know whether it supports OpenGL like TurboVNC and VirtualGL.
https://devtalk.nvidia.com/default/topic/1001017/remote-desktoping-into-jetson-tx2-from-windows-10/

You can find how to build libjpeg-turbo, TurboVNC and VirtualGL in following links:
https://github.com/libjpeg-turbo/libjpeg-turbo/blob/master/BUILDING.md
https://github.com/TurboVNC/turbovnc/blob/master/BUILDING.md
https://github.com/VirtualGL/virtualgl/blob/master/BUILDING.md
It seems build procedures for Linux didn't changed since I wrote the comment #18.

said:On comment #14 when i get to line 4. sudo /opt/VirtualGL/bin/vglserver_config. if i execute it i get the following;
https://drive.google.com/open?id=0B4-ooeVD-7cLS3JUR2tzbk1SZFE
is there anything wrong that i did?

vncserver program execute script file ~/.vnc/xstartup.turbovnc.
If that error came from that script file, setting following text to that file might fix it.
#!/bin/sh

unset SESSION_MANAGER
unset DBUS_SESSION_BUS_ADDRESS
startxfce4 &

Package files on Comment #14 are built for 32bit ARM CPU on Jetson TK1.
Package files on Commont #17 are built for 64bit ARM CPU on Shield TV and using newer source codes.
Later one might be better for Jetson TX2.

#29
Posted 08/04/2017 11:59 PM   
Hello! So i tried to run the pacjage files in comment 17 and i think i almost get it to work but i get this after line 1 in the last code box of the comment: https://drive.google.com/open?id=0B4-ooeVD-7cLS3JUR2tzbk1SZFE do you know of any way this can be fixed?
Hello!
So i tried to run the pacjage files in comment 17 and i think i almost get it to work but i get this after line 1 in the last code box of the comment:

https://drive.google.com/open?id=0B4-ooeVD-7cLS3JUR2tzbk1SZFE

do you know of any way this can be fixed?

#30
Posted 08/05/2017 09:17 PM   
Scroll To Top

Add Reply