Fullscreen YouTube (in Chrome) not working with 358 beta
I'm running Ubuntu 15.10 and going from the 355.11 to 358.09 drivers breaks fullscreen video playback on YouTube in Chrome 46.0.2490.86 (64-bit). Repro steps: install 358 drivers, open Chrome 46, double-click a video on youtube.com to go fullscreen, observe that display output is frozen until you leave fullscreen. Hardware: Intel 4790K, ASUS Z97-A (2601 BIOS), Gigabyte GTX 970, 3840x2160 DisplayPort monitor Software: Ubuntu 15.10 64-bit, xfce4 (compositor disabled), nvidia-358 from https://launchpad.net/~graphics-drivers/+archive/ubuntu/ppa
I'm running Ubuntu 15.10 and going from the 355.11 to 358.09 drivers breaks fullscreen video playback on YouTube in Chrome 46.0.2490.86 (64-bit). Repro steps: install 358 drivers, open Chrome 46, double-click a video on youtube.com to go fullscreen, observe that display output is frozen until you leave fullscreen.

Hardware: Intel 4790K, ASUS Z97-A (2601 BIOS), Gigabyte GTX 970, 3840x2160 DisplayPort monitor

Software: Ubuntu 15.10 64-bit, xfce4 (compositor disabled), nvidia-358 from https://launchpad.net/~graphics-drivers/+archive/ubuntu/ppa

#1
Posted 11/11/2015 09:37 PM   
Use a standalone compositor like compton. Xorg is crap and without compositor it's even more crap. I can't reproduce your problem with the same driver and Chromium Version 46.0.2490.80 (64-bit) on Gnome 3.18. So the problem must be the compositor. I don't know if the built in compositor in XFCE could solve this. As far as I know it's not an OpenGL compositor. http://ubuntuforums.org/showthread.php?t=2144468 You can try this compton.conf.
Use a standalone compositor like compton. Xorg is crap and without compositor it's even more crap.

I can't reproduce your problem with the same driver and Chromium Version 46.0.2490.80 (64-bit) on Gnome 3.18. So the problem must be the compositor. I don't know if the built in compositor in XFCE could solve this. As far as I know it's not an OpenGL compositor.


http://ubuntuforums.org/showthread.php?t=2144468
You can try this compton.conf.

#2
Posted 11/12/2015 12:26 PM   
Thanks. It does seem to work with the xfce4 compositor enabled. I had it disabled because it makes vsync tearing even worse. With 358, it looks like any kind of Chrome fullscreen (e.g. F11 on this page) freezes display output for me without the compositor. I'll give compton a try, thanks for the pointer.
Thanks. It does seem to work with the xfce4 compositor enabled. I had it disabled because it makes vsync tearing even worse.

With 358, it looks like any kind of Chrome fullscreen (e.g. F11 on this page) freezes display output for me without the compositor.

I'll give compton a try, thanks for the pointer.

#3
Posted 11/12/2015 09:20 PM   
I have the same issues on Unity/Compiz (F11 fullscreen fails in Chrome, as does Fullscreening a youtube video). Running Ubuntu 16.04 (dev) 64-bit with same PPA. Both Chromium and Chrome exhibit the behavior. AFAIK you can't disable compositing in Unity/Compiz. Firefox-youtube fullscreen works fine (both flash or HTML5). I couldn't reproduce with Totem or VLC (tried multiple output).
I have the same issues on Unity/Compiz (F11 fullscreen fails in Chrome, as does Fullscreening a youtube video). Running Ubuntu 16.04 (dev) 64-bit with same PPA. Both Chromium and Chrome exhibit the behavior. AFAIK you can't disable compositing in Unity/Compiz.

Firefox-youtube fullscreen works fine (both flash or HTML5). I couldn't reproduce with Totem or VLC (tried multiple output).

#4
Posted 11/12/2015 11:12 PM   
I have a Geforce 750 Ti, and disabling hardware acceleration in Chrome makes it work again.
I have a Geforce 750 Ti, and disabling hardware acceleration in Chrome makes it work again.

#5
Posted 11/13/2015 05:00 AM   
Thanks again, blackout24. Simply running compton fixes this particular fullscreen freeze issue. Running compton with the configuration you linked also fixes the horrible screen tearing issues in Firefox for me.
Thanks again, blackout24. Simply running compton fixes this particular fullscreen freeze issue. Running compton with the configuration you linked also fixes the horrible screen tearing issues in Firefox for me.

#6
Posted 11/14/2015 11:33 AM   
[quote=""]Thanks again, blackout24. Simply running compton fixes this particular fullscreen freeze issue. Running compton with the configuration you linked also fixes the horrible screen tearing issues in Firefox for me.[/quote] You're welcome. More advanced compositing window managers like mutter for Gnome disable compositing when a 3D application goes fullscreen and try to let the application render directly to the GPU to avoid the slight overhead the compositor brings. There is a tweak guide here: https://github.com/chjj/compton/wiki/perf-guide However the overhead is generally rather small (5% maybe) and with a 970 you shouldn't run into any performance problems with current Linux games anyway. Some games also don't support real fullscreen mode and use "Fullscreen windowed" which just stretches the window to fill the screen. I have been told that this is to make the games play nice with all the different window managers that people might use.
said:Thanks again, blackout24. Simply running compton fixes this particular fullscreen freeze issue. Running compton with the configuration you linked also fixes the horrible screen tearing issues in Firefox for me.


You're welcome. More advanced compositing window managers like mutter for Gnome disable compositing when a 3D application goes fullscreen and try to let the application render directly to the GPU to avoid the slight overhead the compositor brings. There is a tweak guide here:

https://github.com/chjj/compton/wiki/perf-guide


However the overhead is generally rather small (5% maybe) and with a 970 you shouldn't run into any performance problems with current Linux games anyway. Some games also don't support real fullscreen mode and use "Fullscreen windowed" which just stretches the window to fill the screen. I have been told that this is to make the games play nice with all the different window managers that people might use.

#7
Posted 11/14/2015 12:24 PM   
Scroll To Top

Add Reply