USB 3 transfer failures
Sorry for the late reply. We're still investigating this issue. Once any finding, I will do the update. Thanks
Sorry for the late reply.

We're still investigating this issue. Once any finding, I will do the update.

Thanks

#16
Posted 05/09/2016 06:42 AM   
[quote=""]Sorry for the late reply. We're still investigating this issue. Once any finding, I will do the update. Thanks[/quote] Same issue here... any updates?
said:Sorry for the late reply.

We're still investigating this issue. Once any finding, I will do the update.

Thanks

Same issue here... any updates?

#17
Posted 06/07/2016 02:37 AM   
This became available after Kay could post it, but we have a firmware patch that should resolve this. You can replace the USB firmware file by unzipping and copying the unzipped file to your [b]/lib/firmware/[/b] directory with the following command: [code]cp xusb_sil_rel_fw-test /lib/firmware/tegra21x_xusb_firmware[/code] Then reboot the system. Let us know if this resolves the issue or if any subsequent issues are encountered.
This became available after Kay could post it, but we have a firmware patch that should resolve this.

You can replace the USB firmware file by unzipping and copying the unzipped file to your /lib/firmware/ directory with the following command:

cp xusb_sil_rel_fw-test /lib/firmware/tegra21x_xusb_firmware

Then reboot the system. Let us know if this resolves the issue or if any subsequent issues are encountered.

#18
Posted 06/09/2016 06:00 PM   
After some light testing, this appears to fix the transfer issue. Thank you very much! There appears to be issues with the RGB color stream, but I don't know if this is on the raw data side or the application side just yet. [b]Update: [/b] The RGB issue is on the application side with conversion of color formats. It be working!
After some light testing, this appears to fix the transfer issue.
Thank you very much!
There appears to be issues with the RGB color stream, but I don't know if this is on the raw data side or the application side just yet.
Update: The RGB issue is on the application side with conversion of color formats. It be working!

jetsonhacks.com

#19
Posted 06/11/2016 06:38 PM   
Kangalow: is this on 23.2 or 24.1? Regards
Kangalow: is this on 23.2 or 24.1?

Regards

#20
Posted 06/12/2016 10:24 PM   
@RNZNobody L4T 23.2, I don't know what the status of the firmware patch is under 24.1.
@RNZNobody
L4T 23.2, I don't know what the status of the firmware patch is under 24.1.

jetsonhacks.com

#21
Posted 06/12/2016 11:58 PM   
@Kangalow I'm also having issues with the RGB color stream. How did you fix the conversion of color formats?
@Kangalow
I'm also having issues with the RGB color stream. How did you fix the conversion of color formats?

#22
Posted 06/15/2016 02:59 PM   
@zebra50 The Jetson JPEG hardware decoder produces a RGBA format color stream, the viewer is for BGRA. I didn't look through much of the code other than to satisfy my curiosity, note that there may already be proper conversion code available within the libfreenect2 library. 5 minute, brain dead slow code for the Protonect example follows. If you're going to use this for reals, you should invest in optimizing the code, this looks suspiciously like something one could do in parallel. [code] libfreenect2::Frame *rgb = frames[libfreenect2::Frame::Color]; // On the Jetson, the hardware decoder produces RGBA // The viewer uses BGRA, this is the brain dead approach to conversion unsigned char *convertedData = (unsigned char*) malloc(rgb->height*rgb->width*rgb->bytes_per_pixel) ; int offset = 0; for (unsigned int y = 0 ; y < rgb->height; y++) { for (unsigned int x=0 ; x < rgb->width; x++) { convertedData[offset] = rgb->data[offset+2] ; convertedData[offset+1] = rgb->data[offset+1]; convertedData[offset+2] = rgb->data[offset+0]; convertedData[offset+3] = rgb->data[offset+3]; offset += 4; } } memcpy(rgb->data,convertedData,rgb->height*rgb->width*rgb->bytes_per_pixel); // Free the data somewhere free(convertedData) ; [/code]
@zebra50
The Jetson JPEG hardware decoder produces a RGBA format color stream, the viewer is for BGRA. I didn't look through much of the code other than to satisfy my curiosity, note that there may already be proper conversion code available within the libfreenect2 library. 5 minute, brain dead slow code for the Protonect example follows. If you're going to use this for reals, you should invest in optimizing the code, this looks suspiciously like something one could do in parallel.

libfreenect2::Frame *rgb = frames[libfreenect2::Frame::Color];
// On the Jetson, the hardware decoder produces RGBA
// The viewer uses BGRA, this is the brain dead approach to conversion
unsigned char *convertedData = (unsigned char*) malloc(rgb->height*rgb->width*rgb->bytes_per_pixel) ;
int offset = 0;
for (unsigned int y = 0 ; y < rgb->height; y++) {
for (unsigned int x=0 ; x < rgb->width; x++) {
convertedData[offset] = rgb->data[offset+2] ;
convertedData[offset+1] = rgb->data[offset+1];
convertedData[offset+2] = rgb->data[offset+0];
convertedData[offset+3] = rgb->data[offset+3];
offset += 4;
}
}
memcpy(rgb->data,convertedData,rgb->height*rgb->width*rgb->bytes_per_pixel);
// Free the data somewhere
free(convertedData) ;

jetsonhacks.com

#23
Posted 06/15/2016 04:24 PM   
[quote=""]This became available after Kay could post it, but we have a firmware patch that should resolve this. You can replace the USB firmware file by unzipping and copying the unzipped file to your [b]/lib/firmware/[/b] directory with the following command: [code]cp xusb_sil_rel_fw-test /lib/firmware/tegra21x_xusb_firmware[/code] Then reboot the system. Let us know if this resolves the issue or if any subsequent issues are encountered. [/quote] Testing another camera with this JTX1 patch, the Intel RealSense R200. The R200 identifies correctly, but does not start streaming. The R200 works correctly with the previous firmware.
said:This became available after Kay could post it, but we have a firmware patch that should resolve this.

You can replace the USB firmware file by unzipping and copying the unzipped file to your /lib/firmware/ directory with the following command:

cp xusb_sil_rel_fw-test /lib/firmware/tegra21x_xusb_firmware

Then reboot the system. Let us know if this resolves the issue or if any subsequent issues are encountered.



Testing another camera with this JTX1 patch, the Intel RealSense R200. The R200 identifies correctly, but does not start streaming. The R200 works correctly with the previous firmware.

jetsonhacks.com

#24
Posted 07/17/2016 05:31 PM   
@Kangalow [quote=""]@zebra50 The Jetson JPEG hardware decoder produces a RGBA format color stream, the viewer is for BGRA.[/quote] Actually you can fix it by changing the line 56 from viewer.h [code]typedef ImageFormat<4, GL_RGBA, GL_BGRA, GL_UNSIGNED_BYTE> F8C4;[/code] to [code]typedef ImageFormat<4, GL_RGBA, GL_RGBA, GL_UNSIGNED_BYTE> F8C4;[/code] I am using libfreenect from Qt application and getting BGRA frames is an issue since QImage which I am converting the frame, doesn't support BGRA format. Some kind of solution would be needed either to libfreenect or tegra's libjpeg. Are there sources for tegra libjpeg somewhere? I could try to recompile it changing the RGB offsets from jmorecfg.h and use it only on libfreenect since it is using dlopen instead of linking.
@Kangalow
said:@zebra50
The Jetson JPEG hardware decoder produces a RGBA format color stream, the viewer is for BGRA.


Actually you can fix it by changing the line 56 from viewer.h
typedef ImageFormat<4, GL_RGBA, GL_BGRA, GL_UNSIGNED_BYTE> F8C4;

to
typedef ImageFormat<4, GL_RGBA, GL_RGBA, GL_UNSIGNED_BYTE> F8C4;


I am using libfreenect from Qt application and getting BGRA frames is an issue since QImage which I am converting the frame, doesn't support BGRA format. Some kind of solution would be needed either to libfreenect or tegra's libjpeg.
Are there sources for tegra libjpeg somewhere?
I could try to recompile it changing the RGB offsets from jmorecfg.h and use it only on libfreenect since it is using dlopen instead of linking.

#25
Posted 08/11/2016 11:31 AM   
[quote=""]This became available after Kay could post it, but we have a firmware patch that should resolve this. You can replace the USB firmware file by unzipping and copying the unzipped file to your [b]/lib/firmware/[/b] directory with the following command: [code]cp xusb_sil_rel_fw-test /lib/firmware/tegra21x_xusb_firmware[/code] Then reboot the system. Let us know if this resolves the issue or if any subsequent issues are encountered. [/quote] I tried and libfreenect2 works in this case. However, the performance here is very very poor. But Kinect 2 connected to an external USB expansion card can reach the normal performance.
said:This became available after Kay could post it, but we have a firmware patch that should resolve this.

You can replace the USB firmware file by unzipping and copying the unzipped file to your /lib/firmware/ directory with the following command:

cp xusb_sil_rel_fw-test /lib/firmware/tegra21x_xusb_firmware

Then reboot the system. Let us know if this resolves the issue or if any subsequent issues are encountered.


I tried and libfreenect2 works in this case. However, the performance here is very very poor. But Kinect 2 connected to an external USB expansion card can reach the normal performance.

#26
Posted 09/13/2016 12:49 AM   
Will the patch work on Jetson TK1?
Will the patch work on Jetson TK1?

#27
Posted 05/18/2017 04:39 AM   
On R24 revision 2.1, I am seeing the Kinect v2 work intermittently, but drop out with transfer failure errors after a few minutes. Is the only solution to this a PCIe USB expansion? We are using a 3rd party carrier board with no PCIe port, only an M.2 port for an ssd (Auvidea J120)
On R24 revision 2.1, I am seeing the Kinect v2 work intermittently, but drop out with transfer failure errors after a few minutes. Is the only solution to this a PCIe USB expansion? We are using a 3rd party carrier board with no PCIe port, only an M.2 port for an ssd (Auvidea J120)

#28
Posted 06/27/2017 02:43 PM   
Hi haljarrett, please attach the log for reference. Is it possible to try it on devkit?
Hi haljarrett, please attach the log for reference. Is it possible to try it on devkit?

#29
Posted 07/06/2017 08:43 AM   
Find attached the relevant section of the dmesg log file - It is about 10 seconds worth of messages, most of which seem related. This seems to be the most relevant section, but I am not sure which other parts hold significance: [Tue Jul 11 18:58:03 2017] usb 2-2.1: reset SuperSpeed USB device number 37 using tegra-xhci [Tue Jul 11 18:58:03 2017] usb 2-2.1: Parent hub missing LPM exit latency info. Power management will be impacted. ... A bunch of: [Tue Jul 11 18:58:03 2017] platform c9.regulator: Driver reg-fixed-sync-voltage requests probe deferral [Tue Jul 11 18:58:03 2017] platform ca.regulator: Driver reg-fixed-sync-voltage requests probe deferral [Tue Jul 11 18:58:03 2017] platform cb.regulator: Driver reg-fixed-sync-voltage requests probe deferral [Tue Jul 11 18:58:03 2017] platform cc.regulator: Driver reg-fixed-sync-voltage requests probe deferral [Tue Jul 11 18:58:03 2017] platform cd.regulator: Driver reg-fixed-sync-voltage requests probe deferral [Tue Jul 11 18:58:03 2017] reg-fixed-sync-voltage ce.regulator: Consumer c0 does not have device name ... And finally: [Tue Jul 11 18:58:03 2017] tegra-xhci tegra-xhci: WARN Event TRB for slot 7 ep 2 with no TDs queued? [Tue Jul 11 18:58:03 2017] tegra-xhci tegra-xhci: WARN Event TRB for slot 7 ep 2 with no TDs queued? [Tue Jul 11 18:58:03 2017] tegra-xhci tegra-xhci: WARN Event TRB for slot 7 ep 2 with no TDs queued? [Tue Jul 11 18:58:05 2017] tegra-xhci tegra-xhci: WARN Event TRB for slot 7 ep 2 with no TDs queued? [Tue Jul 11 18:58:05 2017] tegra-xhci tegra-xhci: WARN Event TRB for slot 7 ep 2 with no TDs queued? [Tue Jul 11 18:58:05 2017] tegra-xhci tegra-xhci: WARN Event TRB for slot 7 ep 2 with no TDs queued? [Tue Jul 11 18:58:06 2017] tegra-xhci tegra-xhci: WARN Event TRB for slot 7 ep 2 with no TDs queued? [Tue Jul 11 18:58:06 2017] tegra-xhci tegra-xhci: WARN Event TRB for slot 7 ep 2 with no TDs queued? [Tue Jul 11 18:58:06 2017] tegra-xhci tegra-xhci: WARN Event TRB for slot 7 ep 2 with no TDs queued? As for running it on the devkit, by that do you mean the default provided development board?
Find attached the relevant section of the dmesg log file - It is about 10 seconds worth of messages, most of which seem related. This seems to be the most relevant section, but I am not sure which other parts hold significance:

[Tue Jul 11 18:58:03 2017] usb 2-2.1: reset SuperSpeed USB device number 37 using tegra-xhci
[Tue Jul 11 18:58:03 2017] usb 2-2.1: Parent hub missing LPM exit latency info. Power management will be impacted.

...

A bunch of:

[Tue Jul 11 18:58:03 2017] platform c9.regulator: Driver reg-fixed-sync-voltage requests probe deferral
[Tue Jul 11 18:58:03 2017] platform ca.regulator: Driver reg-fixed-sync-voltage requests probe deferral
[Tue Jul 11 18:58:03 2017] platform cb.regulator: Driver reg-fixed-sync-voltage requests probe deferral
[Tue Jul 11 18:58:03 2017] platform cc.regulator: Driver reg-fixed-sync-voltage requests probe deferral
[Tue Jul 11 18:58:03 2017] platform cd.regulator: Driver reg-fixed-sync-voltage requests probe deferral
[Tue Jul 11 18:58:03 2017] reg-fixed-sync-voltage ce.regulator: Consumer c0 does not have device name

...
And finally:

[Tue Jul 11 18:58:03 2017] tegra-xhci tegra-xhci: WARN Event TRB for slot 7 ep 2 with no TDs queued?
[Tue Jul 11 18:58:03 2017] tegra-xhci tegra-xhci: WARN Event TRB for slot 7 ep 2 with no TDs queued?
[Tue Jul 11 18:58:03 2017] tegra-xhci tegra-xhci: WARN Event TRB for slot 7 ep 2 with no TDs queued?
[Tue Jul 11 18:58:05 2017] tegra-xhci tegra-xhci: WARN Event TRB for slot 7 ep 2 with no TDs queued?
[Tue Jul 11 18:58:05 2017] tegra-xhci tegra-xhci: WARN Event TRB for slot 7 ep 2 with no TDs queued?
[Tue Jul 11 18:58:05 2017] tegra-xhci tegra-xhci: WARN Event TRB for slot 7 ep 2 with no TDs queued?
[Tue Jul 11 18:58:06 2017] tegra-xhci tegra-xhci: WARN Event TRB for slot 7 ep 2 with no TDs queued?
[Tue Jul 11 18:58:06 2017] tegra-xhci tegra-xhci: WARN Event TRB for slot 7 ep 2 with no TDs queued?
[Tue Jul 11 18:58:06 2017] tegra-xhci tegra-xhci: WARN Event TRB for slot 7 ep 2 with no TDs queued?


As for running it on the devkit, by that do you mean the default provided development board?

#30
Posted 07/11/2017 07:31 PM   
Scroll To Top

Add Reply