Hard hang on VDPAU playback with 364.12
Hello, Using the newest beta driver 364.12, running mpv/mplayer causes a hard lock of the computer after opening window and showing 1 frame of the video. Even Alt-SysRq combos don't work. So the only way is a hard reset, which no logs survive... but it's not a kernel panic because keyboard leds don't blink, really a hard lockup! GPU is GTX 570, system is Fedora 23 (kernel 4.4.5, Xorg 1.18.1, libvdpau 1.1)
Hello,

Using the newest beta driver 364.12, running mpv/mplayer causes a hard lock of the computer after opening window and showing 1 frame of the video. Even Alt-SysRq combos don't work. So the only way is a hard reset, which no logs survive... but it's not a kernel panic because keyboard leds don't blink, really a hard lockup!

GPU is GTX 570, system is Fedora 23 (kernel 4.4.5, Xorg 1.18.1, libvdpau 1.1)

#1
Posted 03/21/2016 10:30 PM   
Some more info, maybe helpful? - vdpauinfo / nvidia-setting's vdpau page works, only actual playback fails - all videos I've tried were h.264, somehow I didn't think to check different codecs, - the hang always happened very fast, but not on the first and not always on the same frame (one time it played 1 frame, another time 3-4 frames). Now I'm back to 361.28 waiting for a fix :/
Some more info, maybe helpful?

- vdpauinfo / nvidia-setting's vdpau page works, only actual playback fails

- all videos I've tried were h.264, somehow I didn't think to check different codecs,

- the hang always happened very fast, but not on the first and not always on the same frame (one time it played 1 frame, another time 3-4 frames).

Now I'm back to 361.28 waiting for a fix :/

#2
Posted 03/21/2016 10:53 PM   
I confirm, it happens only when: [code] $ cat /etc/modprobe.d/nvidia-drm.conf # Load nvidia-drm.ko at boot. # modeset:Enable atomic kernel modesetting (1 = enable, 0 = disable (default)) (bool) options nvidia-drm modeset=1 [/code]
I confirm, it happens only when:
$ cat /etc/modprobe.d/nvidia-drm.conf
# Load nvidia-drm.ko at boot.
# modeset:Enable atomic kernel modesetting (1 = enable, 0 = disable (default)) (bool)
options nvidia-drm modeset=1

#3
Posted 03/22/2016 06:09 PM   
Ah yes, I did add that to my modprobe.d as well. Wasn't expecting VDPAU, out of all things, to be affected. Thanks for confirmation.
Ah yes, I did add that to my modprobe.d as well. Wasn't expecting VDPAU, out of all things, to be affected. Thanks for confirmation.

#4
Posted 03/22/2016 06:44 PM   
Thanks for reporting this. I filed bug 1746262 to track it.
Thanks for reporting this. I filed bug 1746262 to track it.

Aaron Plattner
NVIDIA Linux Graphics

#5
Posted 03/22/2016 10:23 PM   
Scroll To Top

Add Reply