Nsight, Visual Studio Edition crashes when clicking on "pause and capture frame"
I have 960M and Windows 10, vs2015 and the lastest nsight version. (and TDR of 30 seconds) I can launch my OpenGL application with graphics debugging but when I click on the button "pause and capture frame" on the hud, it crashes with the message : "3d engine has quit unexpectedly". However, my application works fine. How can I fix the problem ? Thanks for your response. Dump file : [url]http://www98.zippyshare.com/v/iJXPnbMD/file.html[/url]
I have 960M and Windows 10, vs2015 and the lastest nsight version. (and TDR of 30 seconds)
I can launch my OpenGL application with graphics debugging but when I click on the button "pause and capture frame" on the hud, it crashes with the message : "3d engine has quit unexpectedly". However, my application works fine.

How can I fix the problem ?

Thanks for your response.

Dump file : http://www98.zippyshare.com/v/iJXPnbMD/file.html

#1
Posted 07/29/2016 01:02 AM   
Nevermind, I installed new drivers, and now this error message appears : https://devtalk.nvidia.com/default/topic/949938/nsight-visual-studio-edition/api-usage-unsupported-glgetintegerv-glgetstring-glclear/ Then I tried to install the 361.91 driver. And the same bug as the first one occured.
Nevermind, I installed new drivers, and now this error message appears : https://devtalk.nvidia.com/default/topic/949938/nsight-visual-studio-edition/api-usage-unsupported-glgetintegerv-glgetstring-glclear/

Then I tried to install the 361.91 driver. And the same bug as the first one occured.

#2
Posted 07/29/2016 04:53 AM   
Hi Talesseed, I think that's due to you are using Laptop with Win10, which means you are under Win10 Hybrid Graphics mode, and that will make the crash happen on Nsight. Could you please just disable the iGPU and Win10 will disable hybrid mode, you can continue use Nsight without crash. Thanks An
Hi Talesseed,

I think that's due to you are using Laptop with Win10, which means you are under Win10 Hybrid Graphics mode, and that will make the crash happen on Nsight.

Could you please just disable the iGPU and Win10 will disable hybrid mode, you can continue use Nsight without crash.

Thanks
An

#3
Posted 08/05/2016 04:03 AM   
I have a similar issue. When I start my application in graphics debug mode, it runs fine. When I try to click "Pause and Capture Frame", the application and debugger crash without any dialog or error message. In the logfile in %AppData%\NVIDIA Corporation\Nsight\Monitor\1.0\Logs, this was the output: Error,10/27/2016 11:37:33,Nsight.Monitor.exe,'Win32' id: 9,[Messaging],"Could not get childnode 20bbbe0 203a8 from Context ",,MultiProducerMessageQueue.ProcessNextMessage => MultiProducerMessageQueue.ProcessMessage => MultiProducerMessageQueue.ExecuteFunctorDelegate => <>c__DisplayClass1.<Nvda.Messaging.Interop.IMessageCallback.HandleMessages>b__0 => NLogLogger.Log => NLogLogger.LogCore => LoggerImpl.Write Error,10/27/2016 11:54:04,Nsight.Monitor.exe,'Win32' id: 9,[Messaging],"Could not get childnode 3aa050 203a8 from Context ",,MultiProducerMessageQueue.ProcessNextMessage => MultiProducerMessageQueue.ProcessMessage => MultiProducerMessageQueue.ExecuteFunctorDelegate => <>c__DisplayClass1.<Nvda.Messaging.Interop.IMessageCallback.HandleMessages>b__0 => NLogLogger.Log => NLogLogger.LogCore => LoggerImpl.Write I am running Nsight Visual Studio 5.0 in VS2015, separate machines for host and target, target has GTX 560 and driver version 362.00. This debugger used to function before a few seemingly innocuous changes to non-OpenGL code in our engine. Any help would be appreciated, Will
I have a similar issue. When I start my application in graphics debug mode, it runs fine. When I try to click "Pause and Capture Frame", the application and debugger crash without any dialog or error message. In the logfile in %AppData%\NVIDIA Corporation\Nsight\Monitor\1.0\Logs, this was the output:

Error,10/27/2016 11:37:33,Nsight.Monitor.exe,'Win32' id: 9,[Messaging],"Could not get childnode 20bbbe0 203a8 from Context
",,MultiProducerMessageQueue.ProcessNextMessage => MultiProducerMessageQueue.ProcessMessage => MultiProducerMessageQueue.ExecuteFunctorDelegate => <>c__DisplayClass1.<Nvda.Messaging.Interop.IMessageCallback.HandleMessages>b__0 => NLogLogger.Log => NLogLogger.LogCore => LoggerImpl.Write
Error,10/27/2016 11:54:04,Nsight.Monitor.exe,'Win32' id: 9,[Messaging],"Could not get childnode 3aa050 203a8 from Context
",,MultiProducerMessageQueue.ProcessNextMessage => MultiProducerMessageQueue.ProcessMessage => MultiProducerMessageQueue.ExecuteFunctorDelegate => <>c__DisplayClass1.<Nvda.Messaging.Interop.IMessageCallback.HandleMessages>b__0 => NLogLogger.Log => NLogLogger.LogCore => LoggerImpl.Write

I am running Nsight Visual Studio 5.0 in VS2015, separate machines for host and target, target has GTX 560 and driver version 362.00. This debugger used to function before a few seemingly innocuous changes to non-OpenGL code in our engine.

Any help would be appreciated,
Will

#4
Posted 10/27/2016 06:08 PM   
Oh, I forgot to mention, both machines are Windows 7 64-bit.
Oh, I forgot to mention, both machines are Windows 7 64-bit.

#5
Posted 10/27/2016 06:10 PM   
Hi, That looks weird, can you take a try on a more recent driver/Nsight? If it still happen, we might need your sample to do more detail investigation. Thanks An
Hi,

That looks weird, can you take a try on a more recent driver/Nsight? If it still happen, we might need your sample to do more detail investigation.

Thanks
An

#6
Posted 12/23/2016 08:35 AM   
Scroll To Top

Add Reply