Connection to the Nsight monitor on 'localhost' failed - problem
Hi, since a couple of days ago, I can no longer use NSight. I get the error: "Connection to the Nsight monitor on 'localhost' failed. Please make sure the monitor is running on the target machine and the security settings match." I have read and tried everything I could find on this topic. The monitor is running, the security settings do match. I uninstalled and re-installed NSight (clean install). (I think) some Geforce Experience was installed when this problem started occuring. I'm using Visual Studio prof 2013, NSight for VS Edition 5.0.0 (also tried 5.1), driver 368.81, Cuda 7.5. My cuda code still runs ok, just as before. I'm at a loss. Without NSight, I really can't do my work! Any help would be highly appreciated. Karl
Hi,

since a couple of days ago, I can no longer use NSight. I get the error:
"Connection to the Nsight monitor on 'localhost' failed. Please make sure the monitor is running on the target machine and the security settings match."

I have read and tried everything I could find on this topic. The monitor is running, the security settings do match. I uninstalled and re-installed NSight (clean install). (I think) some Geforce Experience was installed when this problem started occuring. I'm using Visual Studio prof 2013, NSight for VS Edition 5.0.0 (also tried 5.1), driver 368.81, Cuda 7.5. My cuda code still runs ok, just as before.

I'm at a loss. Without NSight, I really can't do my work!

Any help would be highly appreciated.

Karl

#1
Posted 08/09/2016 01:17 PM   
Hi KarlHollenbeck, Looks like a network connection issue. The security settings means "Enable secure connection", please make sure the configuration under vs->nsight and nsight monitor match. Nsight use port 8000 as default, please make sure that this port is not used by another application, I suggest you to try another port. Best Regards Harry
Hi KarlHollenbeck,

Looks like a network connection issue.

The security settings means "Enable secure connection", please make sure the configuration under vs->nsight and nsight monitor match.

Nsight use port 8000 as default, please make sure that this port is not used by another application, I suggest you to try another port.

Best Regards
Harry

#2
Posted 08/10/2016 03:57 AM   
Hi Harry, thanks for your suggestions. However, no success yet. The "enable secure connection" settings match (I tried both false and true, resp., on both sides). I also use a port that I know is not blocked by our firewall and not used by another application (I tried several actually). Besides, a local connection should work no matter what... Karl
Hi Harry,

thanks for your suggestions. However, no success yet.

The "enable secure connection" settings match (I tried both false and true, resp., on both sides). I also use a port that I know is not blocked by our firewall and not used by another application (I tried several actually). Besides, a local connection should work no matter what...

Karl

#3
Posted 08/10/2016 10:55 AM   
I figured it out. This was really nasty! Apparently, NSight put a file <My C++ project name>.vcxproj.<my user name>.nvuser into the project directory. When I deleted this file, I could start NSight again. Hope this message can prevent other from wasting so much time as I did on this one.
I figured it out. This was really nasty!

Apparently, NSight put a file
<My C++ project name>.vcxproj.<my user name>.nvuser
into the project directory.
When I deleted this file, I could start NSight again.

Hope this message can prevent other from wasting so much time as I did on this one.

#4
Posted 08/11/2016 06:57 AM   
Scroll To Top

Add Reply