Xorg 1.19 support
Apparently Xorg 1.19 was just released. [url]https://cgit.freedesktop.org/xorg/xserver/commit/?id=7e5c9bdf73e4185ac4cf7f044da0793a5cc3e62c[/url] Obviously the binary drivers are not compatible with it. Till we get support for it, are there any workarounds? or should we just be patient? thank you!
Apparently Xorg 1.19 was just released.
https://cgit.freedesktop.org/xorg/xserver/commit/?id=7e5c9bdf73e4185ac4cf7f044da0793a5cc3e62c
Obviously the binary drivers are not compatible with it. Till we get support for it, are there any workarounds? or should we just be patient? thank you!

#1
Posted 11/16/2016 03:41 AM   
There was a last-minute bug fix that required a rebuild, so it's slightly behind schedule but it should be coming soon. I can't check at the moment but I [i]think[/i] 375.10 is binary compatible with the frozen version of the ABI. You can try using the -ignoreABI option with 375.10 if you're impatient. @agoins will correct me if I'm wrong.
Answer Accepted by Original Poster
There was a last-minute bug fix that required a rebuild, so it's slightly behind schedule but it should be coming soon.

I can't check at the moment but I think 375.10 is binary compatible with the frozen version of the ABI. You can try using the -ignoreABI option with 375.10 if you're impatient.

@agoins will correct me if I'm wrong.

Aaron Plattner
NVIDIA Linux Graphics

#2
Posted 11/16/2016 04:38 AM   
[code] (EE) Backtrace: (EE) 0: /nix/store/3rlkkbx0xid5k4qm0z27q49q3ns9ipf5-xorg-server-1.19.0/bin/X (OsSigHandler+0x29) [0x59dcf9] (EE) 1: /nix/store/ch5j1pjry0891624hwnvishnwbj2wdak-glibc-2.23/lib/libpthread.so.0 (funlockfile+0x50) [0x7fa6a0103faf] (EE) 2: /run/opengl-driver-x86_64-linux/lib/libnvidia-glcore.so.375.10 (nvidiaAddDrawableHandler+0x54599e) [0x7fa69966ea2c] (EE) (EE) Segmentation fault at address 0x10 (EE) Fatal server error: (EE) Caught signal 11 (Segmentation fault). Server aborting [/code] Quickly testing with ignoreABI set, it looks like 375.10 is not compatible with 1.19. So you'll have to wait for an updated release.
(EE) Backtrace:
(EE) 0: /nix/store/3rlkkbx0xid5k4qm0z27q49q3ns9ipf5-xorg-server-1.19.0/bin/X (OsSigHandler+0x29) [0x59dcf9]
(EE) 1: /nix/store/ch5j1pjry0891624hwnvishnwbj2wdak-glibc-2.23/lib/libpthread.so.0 (funlockfile+0x50) [0x7fa6a0103faf]
(EE) 2: /run/opengl-driver-x86_64-linux/lib/libnvidia-glcore.so.375.10 (nvidiaAddDrawableHandler+0x54599e) [0x7fa69966ea2c]
(EE)
(EE) Segmentation fault at address 0x10
(EE)
Fatal server error:
(EE) Caught signal 11 (Segmentation fault). Server aborting


Quickly testing with ignoreABI set, it looks like 375.10 is not compatible with 1.19. So you'll have to wait for an updated release.

#3
Posted 11/16/2016 07:59 PM   
It is a good thing new xserver releases don't happen every month :)
It is a good thing new xserver releases don't happen every month :)

#4
Posted 11/16/2016 08:40 PM   
Guys, You know you shouldn't have to worry too much if you just make a better support for Nouveau? Just see how AMD does it. Their AMDGPU Pro driver is also incompatible, but users can use regular opensource AMDGPU meanwhile without too much performance loss until the closedsource is done. For now, I have a Maxwell, and Nouveau performance is awful due lack of support on fan (gpu not overclocked). Please provide support on that :) Both opensource and closedsource drivers can perfectly coexist, but the opensource must be always available because is easier to port/fix by thirdparty devs
Guys,

You know you shouldn't have to worry too much if you just make a better support for Nouveau? Just see how AMD does it. Their AMDGPU Pro driver is also incompatible, but users can use regular opensource AMDGPU meanwhile without too much performance loss until the closedsource is done. For now, I have a Maxwell, and Nouveau performance is awful due lack of support on fan (gpu not overclocked).

Please provide support on that :) Both opensource and closedsource drivers can perfectly coexist, but the opensource must be always available because is easier to port/fix by thirdparty devs

#5
Posted 11/17/2016 02:18 AM   
I'm not really in a rush to update to Xorg 1.19. I'm simply planning to update to the upcoming Fedora 25 (coming out on november 22 which includes the latest xorg server) all my home desktops and laptops as well as the machines at my office where the nvidia full acceleration is really needed. So I'll wait for the new driver before upgrading everything. Thank you @aplattner for the response.
I'm not really in a rush to update to Xorg 1.19. I'm simply planning to update to the upcoming Fedora 25 (coming out on november 22 which includes the latest xorg server) all my home desktops and laptops as well as the machines at my office where the nvidia full acceleration is really needed. So I'll wait for the new driver before upgrading everything.

Thank you @aplattner for the response.

#6
Posted 11/17/2016 05:03 PM   
I was told that Xorg 1.19 would fix tearing issues with optimus set-ups running Ubuntu 16.10. So, has this been fixed? If so, how do I upgrade to the new version of Xorg? Do I just sudo apt-get upgrade?
I was told that Xorg 1.19 would fix tearing issues with optimus set-ups running Ubuntu 16.10. So, has this been fixed? If so, how do I upgrade to the new version of Xorg? Do I just sudo apt-get upgrade?

#7
Posted 11/18/2016 03:12 AM   
New release 375.20 is now available. Added support for X.Org xserver ABI 23 (xorg-server 1.19)
New release 375.20 is now available. Added support for X.Org xserver ABI 23 (xorg-server 1.19)

#8
Posted 11/18/2016 04:48 PM   
[quote=""]New release 375.20 is now available. Added support for X.Org xserver ABI 23 (xorg-server 1.19)[/quote] It works fine with 375.20, many thanks. In case someone wants to test it also in Gentoo, I have created an overlay here: https://github.com/waltercool/waltercooloverlay/tree/master/x11-drivers/nvidia-drivers bumblebee+primus works fine under kernel 4.8.7 with nvidia drivers 375.20 until now.
said:New release 375.20 is now available. Added support for X.Org xserver ABI 23 (xorg-server 1.19)


It works fine with 375.20, many thanks.

In case someone wants to test it also in Gentoo, I have created an overlay here: https://github.com/waltercool/waltercooloverlay/tree/master/x11-drivers/nvidia-drivers


bumblebee+primus works fine under kernel 4.8.7 with nvidia drivers 375.20 until now.

#9
Posted 11/18/2016 06:26 PM   
Still waiting update for 340-xx
Still waiting update for 340-xx

#10
Posted 11/18/2016 09:53 PM   
[quote=""]Still waiting update for 340-xx[/quote] also 304.xxx please thanks
said:Still waiting update for 340-xx


also 304.xxx please

thanks

#11
Posted 11/22/2016 02:57 PM   
[quote=""]Still waiting update for 340-xx[/quote] Would like to see this too for my old 9800GT...
said:Still waiting update for 340-xx

Would like to see this too for my old 9800GT...

#12
Posted 11/28/2016 05:44 AM   
Some programs are built to need Nvidia drivers and do not work with noveau (Minecraft, BricsCAD...) It would be sad if users get annoyed by that when new distro releases go out soon (fedora, Mageia, maybe more are soon launched) And we testers of the dvelopment version of distros need to test it before...
Some programs are built to need Nvidia drivers and do not work with noveau (Minecraft, BricsCAD...)

It would be sad if users get annoyed by that when new distro releases go out soon
(fedora, Mageia, maybe more are soon launched)
And we testers of the dvelopment version of distros need to test it before...

#13
Posted 11/30/2016 04:29 PM   
I'm on a kepler card supported by 375.20 driver but the distribution I use is holding back on xorg-server till nvidia releases updates for the 340.xx and 304.xx branches. It would be nice to hear an update. Edit: I got an answer on irc. No ETA yet.
I'm on a kepler card supported by 375.20 driver but the distribution I use is holding back on xorg-server till nvidia releases updates for the 340.xx and 304.xx branches.
It would be nice to hear an update.

Edit: I got an answer on irc. No ETA yet.

#14
Posted 12/02/2016 08:41 PM   
Does anyone here have an ETA on the 340.xx driver release? I am running a good 'ol GeForce 210 GPU Tim
Does anyone here have an ETA on the 340.xx driver release? I am running a good 'ol GeForce 210 GPU

Tim

Image


AMD Ryzen 1800x @ 4.3GHz | ASRock X370 Fatality Pro Gaming Mobo | GSkill 32GB DDR-4 2400 DS/DC Kit | nVidia Titan X Pascal | 1 Samsung 960 Pro 1TB NVMe M.2 SSD | 2 Samsung 960 EVO 1TB SSD's | M-Audio 7.1 THX Sound Card | Logitech Z-5500 550W THX 5.1 SS | Acer 27" 144Hz G-Sync IPS LCD Panel 3K | Internet Pipe: 1Gbit FTTH | Thermaltake Chaser Case | Logitech X-56 HOTAS Flight Control System | OS - Mageia Linux AMD 64 | FreeNAS 6TB Server | ClearOS 8.x Home Essentials Gateway/Firewall/Router AMD 64 | Windows 10 64bit | FreeBSD 64 Bit

#15
Posted 12/03/2016 08:32 PM   
Scroll To Top

Add Reply