Cannot debug CUDA (Pascall)
Hi there, I just got a new GTX1050 laptop (XPS 15) and I'm having trouble getting CUDA debugging to work. I installed VS2015 (Community), Nsight Visual Studio edition 5.2, CUDA Toolkit 8.0 and the latest GeForce driver (378.49). I tried to execute the default template and it runs just fine. But when I try to debug the application, I get a warning/error message: "A CUDA context was created on a GPU that is not currently debuggable". According to the Nsight requirements, my laptop (and Pascall in general) should be supported for CUDA debugging: https://developer.nvidia.com/nsight-visual-studio-edition-requirements Does anyone know how to fix this? Mathijs
Hi there,

I just got a new GTX1050 laptop (XPS 15) and I'm having trouble getting CUDA debugging to work.
I installed VS2015 (Community), Nsight Visual Studio edition 5.2, CUDA Toolkit 8.0 and the latest GeForce driver (378.49).

I tried to execute the default template and it runs just fine.
But when I try to debug the application, I get a warning/error message: "A CUDA context was created on a GPU that is not currently debuggable".
According to the Nsight requirements, my laptop (and Pascall in general) should be supported for CUDA debugging:
https://developer.nvidia.com/nsight-visual-studio-edition-requirements

Does anyone know how to fix this?

Mathijs

#1
Posted 02/08/2017 04:45 PM   
Hi Mathijs, Of course nsight supports 1050, could you try the latest nsight at https://developer.nvidia.com/gameworksdownload#?dn=nsight-visual-studio-edition-5-2-0 Best Regards Harry
Hi Mathijs,

Of course nsight supports 1050, could you try the latest nsight at https://developer.nvidia.com/gameworksdownload#?dn=nsight-visual-studio-edition-5-2-0



Best Regards
Harry

#2
Posted 02/09/2017 04:42 AM   
Hi Harry, Thank you for replying. EDIT: I see that there is a newer version available for both CUDA (8.0.61) and Nsight (5.2.0.16321). Downloading now, will update the post when I tried both. EDIT2: Installed the new CUDA/Nsight releases and it works! Thanks Harry for the links! Apparently I either used the wrong links to download it originally or it just got updated in the last 2 days. Regards, Mathijs
Hi Harry,

Thank you for replying.

EDIT:
I see that there is a newer version available for both CUDA (8.0.61) and Nsight (5.2.0.16321).
Downloading now, will update the post when I tried both.

EDIT2:
Installed the new CUDA/Nsight releases and it works!
Thanks Harry for the links!
Apparently I either used the wrong links to download it originally or it just got updated in the last 2 days.

Regards,
Mathijs

#3
Posted 02/09/2017 06:00 AM   
Scroll To Top

Add Reply