GTX 460 + Nsight 5.0 can't debug kernel code
Hello VGA: GTX 460 Nsight: 5.0.0.15294 CUDA: 8.0 Visual Studio 2015 Nvidia driver: 372.70 I've tried to debug my kernel but nsight says: A CUDA context was created on a GPU that is not currently debuggable. Breakpoints will be disabled. As I know until Nsight still supports the GTX 460 card until version 5.0. As far as I remember in the past, I could debug device codes with the card. Is it possible yet? Should I set something in NSight or Visual Studio? Regards, L
Hello

VGA: GTX 460
Nsight: 5.0.0.15294
CUDA: 8.0
Visual Studio 2015
Nvidia driver: 372.70

I've tried to debug my kernel but nsight says:
A CUDA context was created on a GPU that is not currently debuggable. Breakpoints will be disabled.

As I know until Nsight still supports the GTX 460 card until version 5.0.
As far as I remember in the past, I could debug device codes with the card. Is it possible yet? Should I set something in NSight or Visual Studio?

Regards, L

#1
Posted 02/16/2017 11:44 PM   
Hi Yodafon, Did you update the cuda? I'm not sure if nsight 5.0 can debug the cuda 8.0 code on Fermi cards. Best Regards Harry
Hi Yodafon,

Did you update the cuda? I'm not sure if nsight 5.0 can debug the cuda 8.0 code on Fermi cards.

Best Regards
Harry

#2
Posted 02/17/2017 03:53 AM   
What do you mean: "updated"? First I've installed Cuda 8.0 with Nsight 5.2 but unfortunatelly this Nsight version doesn't support Fermi cards anymore so I went back to Nsight 5.0. Do you say that I should use CUDA 7.5 or 7.0?
What do you mean: "updated"?
First I've installed Cuda 8.0 with Nsight 5.2 but unfortunatelly this Nsight version doesn't support Fermi cards anymore so I went back to Nsight 5.0.
Do you say that I should use CUDA 7.5 or 7.0?

#3
Posted 02/17/2017 08:13 AM   
Yeah, this is what I mean, actually we never test the cuda8.0 + nsight 5.0 + fermi, AFAIK nsight 5.0 only supports cuda 7.5
Yeah, this is what I mean, actually we never test the cuda8.0 + nsight 5.0 + fermi, AFAIK nsight 5.0 only supports cuda 7.5

#4
Posted 02/20/2017 02:50 AM   
Nsight 5.2 doesn't support Fermi Nsight 5.0 does. Cuda 8.0 doesn't support Nsight 5.0 Cuda 7.5 does. Cuda 7.5 doesn't support Visual Studio 2015 Cuda 8.0 does. So what can I do if I want to use Visual Studio 2015 with Fermi card and kernel debug? :D
Nsight 5.2 doesn't support Fermi
Nsight 5.0 does.
Cuda 8.0 doesn't support Nsight 5.0
Cuda 7.5 does.
Cuda 7.5 doesn't support Visual Studio 2015
Cuda 8.0 does.

So what can I do if I want to use Visual Studio 2015 with Fermi card and kernel debug? :D

#5
Posted 02/20/2017 08:35 PM   
Looks like it's a dead end, :-( , the easiest way is using old version of visual studio like 2013,2012, sorry to inconvenience you
Looks like it's a dead end, :-( , the easiest way is using old version of visual studio like 2013,2012, sorry to inconvenience you

#6
Posted 02/21/2017 02:58 AM   
yeah I've reverted to VS 2013, Cuda 7.5 and nsight 5.0. For learning and ~1 TFlops this is enough. I will buy a gtx 1070 if I have more knowledge :V :D
yeah I've reverted to VS 2013, Cuda 7.5 and nsight 5.0.

For learning and ~1 TFlops this is enough. I will buy a gtx 1070 if I have more knowledge :V :D

#7
Posted 02/21/2017 10:34 AM   
Scroll To Top

Add Reply